mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Burman Yan" <yan_952@hotmail.com>
To: dmitry.torokhov@gmail.com
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org, khali@linux-fr.org
Subject: Re: [PATCH] HP Mobile data protection system driver with interrupt handling
Date: Wed, 08 Nov 2006 07:16:10 +0200	[thread overview]
Message-ID: <BAY20-F11ABC4481755DCE7E07715D8F10@phx.gbl> (raw)
In-Reply-To: <d120d5000611071237j509d0cbfxe441b68066fb75f5@mail.gmail.com>




>From: "Dmitry Torokhov" <dmitry.torokhov@gmail.com>
>To: "Burman Yan" <yan_952@hotmail.com>
>CC: akpm@osdl.org, linux-kernel@vger.kernel.org, khali@linux-fr.org
>Subject: Re: [PATCH] HP Mobile data protection system driver with interrupt 
>handling
>Date: Tue, 7 Nov 2006 15:37:51 -0500
>
>On 11/7/06, Burman Yan <yan_952@hotmail.com> wrote:
>>
>> >From: "Dmitry Torokhov" <dmitry.torokhov@gmail.com>
>> >To: "Andrew Morton" <akpm@osdl.org>
>> >CC: "Burman Yan" <yan_952@hotmail.com>, linux-kernel@vger.kernel.org, 
>>"Jean
>> >Delvare" <khali@linux-fr.org>
>> >Subject: Re: [PATCH] HP Mobile data protection system driver with 
>>interrupt
>> >handling
>> >Date: Mon, 6 Nov 2006 17:18:53 -0500
>> >
>> >On 11/6/06, Andrew Morton <akpm@osdl.org> wrote:
>> >>On Fri, 03 Nov 2006 18:33:31 +0200
>> >>"Burman Yan" <yan_952@hotmail.com> wrote:
>> >> > +
>> >> > +static unsigned int mouse = 0;
>> >>
>> >>The `= 0' is unneeded.
>> >>
>> >> > +module_param(mouse, bool, S_IRUGO);
>> >> > +MODULE_PARM_DESC(mouse, "Enable the input class device on module
>> >>load");
>> >
>> >Does the parameter have to be called "mouse"? I'd rename it to "input"
>> >and drop the work "class" from parameter description.
>>
>>Dropping the "class" seems logical, but calling the parameter input
>>seems confusing to me - to a user that doesn't want to read too much
>>manual/code and just wants to play around with the device (I do that
>>sometimes)
>>mouse sounds more reasonable to me.
>>
>
>Except that the device is more similar to a joystick than a mouse...

Agreed - joystick it is.

>
>--
>Dmitry

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today it's FREE! 
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/


  reply	other threads:[~2006-11-08  5:16 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-11-03 16:33 Burman Yan
2006-11-06 21:15 ` Andrew Morton
2006-11-06 22:18   ` Dmitry Torokhov
2006-11-07 19:19     ` Burman Yan
2006-11-07 20:37       ` Dmitry Torokhov
2006-11-08  5:16         ` Burman Yan [this message]
2006-11-07 19:09   ` Burman Yan
2006-11-07  7:03 ` Pavel Machek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=BAY20-F11ABC4481755DCE7E07715D8F10@phx.gbl \
    --to=yan_952@hotmail.com \
    --cc=akpm@osdl.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=khali@linux-fr.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®