From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751168AbdAMG6s convert rfc822-to-8bit (ORCPT ); Fri, 13 Jan 2017 01:58:48 -0500 Received: from mga01.intel.com ([192.55.52.88]:34685 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751066AbdAMG6q (ORCPT ); Fri, 13 Jan 2017 01:58:46 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.33,220,1477983600"; d="scan'208";a="1111964522" Subject: Re: [PATCH 2/5] staging/lustre/mgc: Combine two seq_printf() calls into one call in lprocfs_mgc_rd_ir_state() Mime-Version: 1.0 (Apple Message framework v1283) Content-Type: text/plain; charset=us-ascii From: Oleg Drokin In-Reply-To: <25b07069-c624-cdd4-ca7b-85aaae51e79e@users.sourceforge.net> Date: Fri, 13 Jan 2017 01:58:37 -0500 Cc: , , "Andreas Dilger" , Ben Evans , Bobi Jam , Emoly Liu , Fan Yong , Greg Kroah-Hartman , Gregoire Pichon , Henri Doreau , James Simmons , Jinshan Xiong , "John L. Hammond" , "Kirill A. Shutemov" , Lai Siyao , Sebastien Buisson , Stephen Champion , wang di , LKML , Content-Transfer-Encoding: 8BIT Message-Id: References: <45ae8939-a775-865b-ade0-9e38a7ff2b5d@users.sourceforge.net> <25b07069-c624-cdd4-ca7b-85aaae51e79e@users.sourceforge.net> To: SF Markus Elfring X-Mailer: Apple Mail (2.1283) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Jan 1, 2017, at 11:35 AM, SF Markus Elfring wrote: > From: Markus Elfring > Date: Sun, 1 Jan 2017 15:40:29 +0100 > > Some data were printed into a sequence by two separate function calls. > Print the same data by a single function call instead. > > This issue was detected by using the Coccinelle software. > > Signed-off-by: Markus Elfring > --- > drivers/staging/lustre/lustre/mgc/mgc_request.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/staging/lustre/lustre/mgc/mgc_request.c b/drivers/staging/lustre/lustre/mgc/mgc_request.c > index b9c522a3c7a4..a6ca48d7e96b 100644 > --- a/drivers/staging/lustre/lustre/mgc/mgc_request.c > +++ b/drivers/staging/lustre/lustre/mgc/mgc_request.c > @@ -460,11 +460,8 @@ int lprocfs_mgc_rd_ir_state(struct seq_file *m, void *data) > > imp = obd->u.cli.cl_import; > ocd = &imp->imp_connect_data; > - > - seq_printf(m, "imperative_recovery: %s\n", > + seq_printf(m, "imperative_recovery: %s\nclient_state:\n", > OCD_HAS_FLAG(ocd, IMP_RECOV) ? "ENABLED" : "DISABLED"); > - seq_printf(m, "client_state:\n"); > - Ugh, do we really need this? I know it saves one call to seq_printf, but this is not a super performance-critical code, and two calls are actually easier to read, don't you think? > spin_lock(&config_list_lock); > list_for_each_entry(cld, &config_llog_list, cld_list_chain) { > if (!cld->cld_recover) > -- > 2.11.0