From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752214AbbCYLr0 (ORCPT ); Wed, 25 Mar 2015 07:47:26 -0400 Received: from smtprelay.synopsys.com ([198.182.60.111]:55450 "EHLO smtprelay.synopsys.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751876AbbCYLrY convert rfc822-to-8bit (ORCPT ); Wed, 25 Mar 2015 07:47:24 -0400 From: Vineet Gupta To: Alex Dowad , "linux-kernel@vget.kernel.org" CC: open list Subject: Re: [PATCH 03/32] arc: copy_thread(): rename 'arg' argument to 'kthread_arg' Thread-Topic: [PATCH 03/32] arc: copy_thread(): rename 'arg' argument to 'kthread_arg' Thread-Index: AQHQXbhDmH0hoTH/fUWWtZiMQjLJ3w== Date: Wed, 25 Mar 2015 11:47:21 +0000 Message-ID: References: <1426269888-25600-1-git-send-email-alexinbeijing@gmail.com> <1426269888-25600-3-git-send-email-alexinbeijing@gmail.com> Accept-Language: en-US, en-IN Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.12.197.3] Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Friday 13 March 2015 11:35 PM, Alex Dowad wrote: > The 'arg' argument to copy_thread() is only ever used when forking a new > kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency > with do_fork() and other arch-specific implementations of copy_thread()). > > Signed-off-by: Alex Dowad > --- > arch/arc/kernel/process.c | 9 ++++++--- > 1 file changed, 6 insertions(+), 3 deletions(-) > > diff --git a/arch/arc/kernel/process.c b/arch/arc/kernel/process.c > index fdd8971..cf366bd 100644 > --- a/arch/arc/kernel/process.c > +++ b/arch/arc/kernel/process.c > @@ -49,7 +49,9 @@ void arch_cpu_idle(void) > > asmlinkage void ret_from_fork(void); > > -/* Layout of Child kernel mode stack as setup at the end of this function is > +/* Copy architecture-specific thread state > + * > + * Layout of Child kernel mode stack as setup at the end of this function is > * > * | ... | > * | ... | > @@ -81,7 +83,7 @@ asmlinkage void ret_from_fork(void); > * ------------------ <===== END of PAGE > */ > int copy_thread(unsigned long clone_flags, > - unsigned long usp, unsigned long arg, > + unsigned long usp, unsigned long kthread_arg, > struct task_struct *p) > { > struct pt_regs *c_regs; /* child's pt_regs */ > @@ -110,9 +112,10 @@ int copy_thread(unsigned long clone_flags, > childksp[1] = (unsigned long)ret_from_fork; /* blink */ > > if (unlikely(p->flags & PF_KTHREAD)) { > + /* kernel thread */ This seems extraneous given that PF_KTHREAD above check makes is obvious that this is a kernel thread. > memset(c_regs, 0, sizeof(struct pt_regs)); > > - c_callee->r13 = arg; /* argument to kernel thread */ > + c_callee->r13 = kthread_arg; > c_callee->r14 = usp; /* function */ > > return 0; Applied to for-next after pruning the comment above. Thx, -Vineet