From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id D29AE3822AE for ; Tue, 21 Jul 2026 08:45:34 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784623537; cv=none; b=sgtRqanqHBOxNdk2J+xAtrULrqzoqtsRRCEaqjg6tlFOBzydrpTwt2WHcVWNz7IM46YjPG7GtChJmQPNWAQ/rPlWn4sFcbcEvKp5h+TkZtgogA9VXti0ffGsM4mtuKgqRTE9e7XhGgR/wIMiBYJUQxe0seVgk404FLLB4BX9+GY= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1784623537; c=relaxed/simple; bh=Zy1Nn4URB19/IqtHJAIHhfq96fnaaSmmSkl4BjsDLoI=; h=MIME-Version:References:In-Reply-To:From:Date:Message-ID:Subject: To:Cc:Content-Type; b=AOVAV8fCJUhHXaUJ9IF8d3O2wbzq7Ws5JgQ59hBuSM8kXp0JuUP6icOI9Z0GzBgRYJ7/axAaJqAvl+EmvQYHWsm9I/gfEhlaLPyEsY6E8yGkCPzvnw/dwhfIqemmwHuXGzJgaWCqAfVGS78G+zLa9wag+XPoHws+qbaC2I5Mx9E= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=H8xOtLEB; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="H8xOtLEB" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 0434C1F00AC4 for ; Tue, 21 Jul 2026 08:45:34 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1784623534; bh=mda3/lxuFBmPENdZVts/4V3Xa5gfiA3vEnncLDtHU0U=; h=References:In-Reply-To:From:Date:Subject:To:Cc; b=H8xOtLEBeHw3D1Mgo66uUN9jrIvmZoVrTyRkEQWKZAN3qUCvcP/QbUx0yA74H1hS2 eVKtvEz9rsTjo73YA70F3ZVLjsMgQOn/g4FCGg8TlSnbfx1U/W7ia8ycZV6kLIICrC lVTx00//c+91oD+xNXWtzkymz8Av9vkrjM6w/XKDa5QAh1mUfl1CGYMcRhPR0Pp7pZ 3B6aVbbesGKmWyaH78to8ih9vBn1GneqU98QH6zWLMIp6E+iKtdCyz6lhQix8OrIEs J5AEZ5bW1o1OxNkeFZQKJRuTkGoxDRaWOZzbZ9DCoVOBmafKp+9hBZMrJSuDDzZRNr BGk0y3dNcn/Jw== Received: by mail-lf1-f45.google.com with SMTP id 2adb3069b0e04-5b2a44a3b66so840035e87.1 for ; Tue, 21 Jul 2026 01:45:33 -0700 (PDT) X-Forwarded-Encrypted: i=1; AHgh+RqbXIkUBdgg2MmCxXV52gNArW4QMXzWdodF+spP+i/nuSwl9gStCuCa4zsocGTemLn6PftYsy0B71jR7+A=@vger.kernel.org X-Gm-Message-State: AOJu0YwyCB6XdaxnbFdWwo9/xrWkZUSaV89EjEM+IdLak8NFCyZ28vb9 smZlESQRdOm080nbEgBcZyknHxbaGH/eMoOqLfnChhVwR5f4xh0QvpRVTweUAGHVL/PQPbMlP+o PBk+iKxujyQrfbGgVhx8zYwS03v63R4k= X-Received: by 2002:a05:6512:39c7:b0:5b2:a328:cdd5 with SMTP id 2adb3069b0e04-5b2a328cef0mr1147687e87.49.1784623532800; Tue, 21 Jul 2026 01:45:32 -0700 (PDT) Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 References: <20260721081858.1169276-1-ruanjinjie@huawei.com> <20260721081858.1169276-7-ruanjinjie@huawei.com> In-Reply-To: From: Linus Walleij Date: Tue, 21 Jul 2026 10:45:20 +0200 X-Gmail-Original-Message-ID: X-Gm-Features: AUfX_mxAPadijNGOw3KjbcQm4dql7ZsTZweXiQL_6HWNJOpSmXm_9tY3eS5UFxg Message-ID: Subject: Re: [PATCH v17 06/15] arm64: syscall: Rework the syscall exit path in el0_svc_common() To: Jinjie Ruan Cc: catalin.marinas@arm.com, will@kernel.org, kees@kernel.org, oleg@redhat.com, luto@amacapital.net, wad@chromium.org, thuth@redhat.com, peterz@infradead.org, mark.rutland@arm.com, ada.coupriediaz@arm.com, kevin.brodsky@arm.com, yeoreum.yun@arm.com, anshuman.khandual@arm.com, james.morse@arm.com, tglx@kernel.org, broonie@kernel.org, pengcan@kylinos.cn, ryan.roberts@arm.com, liqiang01@kylinos.cn, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, linux-mm@kvack.org Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: quoted-printable On Tue, Jul 21, 2026 at 10:43=E2=80=AFAM Linus Walleij = wrote: > On Tue, Jul 21, 2026 at 10:19=E2=80=AFAM Jinjie Ruan wrote: > > > > In preparation for moving arm64 over to the generic entry, > > invert the nested conditional flags check within el0_svc_common(). > > > > No functional changes. > (...) > > if (!has_syscall_work(flags) && !IS_ENABLED(CONFIG_DEBUG_RSEQ))= { > > flags =3D read_thread_flags(); > > - if (!has_syscall_work(flags) && !(flags & _TIF_SINGLEST= EP)) > > - return; > > + if (has_syscall_work(flags) || flags & _TIF_SINGLESTEP) > > + syscall_trace_exit(regs); > > + return; > > What about just: > > if (...) > goto trace_exit; > > This is easier to follow IMO. > > With that: > Reviewed-by: Linus Walleij Aha I see you refactor it again in patch 8, no big deal then. This is fine, add the Reviewed-by. Yours, Linus Walleij