From: Amit Kucheria <amit.kucheria@verdurent.com>
To: Wei Wang <wvw@google.com>
Cc: Wei Wang <wei.vince.wang@gmail.com>,
Zhang Rui <rui.zhang@intel.com>,
Eduardo Valentin <edubezval@gmail.com>,
Daniel Lezcano <daniel.lezcano@linaro.org>,
Linux PM list <linux-pm@vger.kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] thermal: create softlink by name for thermal_zone and cooling_device
Date: Mon, 11 Nov 2019 10:56:34 +0530 [thread overview]
Message-ID: <CAHLCerN4ymf7LOGQPRLuAwirwCUaQGynrnUMfgU6+frDswey5A@mail.gmail.com> (raw)
In-Reply-To: <CAGXk5yp4uSCESvve5j_LbCr7b_55DqBagjNr_Dsdi=HppSpBPg@mail.gmail.com>
On Thu, Oct 17, 2019 at 3:04 AM Wei Wang <wvw@google.com> wrote:
>
> On Wed, Oct 16, 2019 at 10:16 AM Amit Kucheria
> <amit.kucheria@verdurent.com> wrote:
> >
> > On Wed, Oct 16, 2019 at 10:20 PM Amit Kucheria
> > <amit.kucheria@verdurent.com> wrote:
> > >
> > > On Tue, Oct 15, 2019 at 11:43 AM Wei Wang <wvw@google.com> wrote:
> > > >
> > > > The paths thermal_zone%d and cooling_device%d are not intuitive and the
> > > > numbers are subject to change due to device tree change. This usually
> > > > leads to tree traversal in userspace code.
> > > > The patch creates `tz-by-name' and `cdev-by-name' for thermal zone and
> > > > cooling_device respectively.
> > >
> > > I like this.
> > >
> > > > Signed-off-by: Wei Wang <wvw@google.com>
> > > > ---
> > > > drivers/thermal/thermal_core.c | 23 +++++++++++++++++++++--
> > > > 1 file changed, 21 insertions(+), 2 deletions(-)
> > > >
> > > > diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
> > > > index d4481cc8958f..0ff8fb1d7b0a 100644
> > > > --- a/drivers/thermal/thermal_core.c
> > > > +++ b/drivers/thermal/thermal_core.c
> > > > @@ -22,6 +22,7 @@
> > > > #include <net/netlink.h>
> > > > #include <net/genetlink.h>
> > > > #include <linux/suspend.h>
> > > > +#include <linux/kobject.h>
> > > >
> > > > #define CREATE_TRACE_POINTS
> > > > #include <trace/events/thermal.h>
> > > > @@ -46,6 +47,8 @@ static DEFINE_MUTEX(poweroff_lock);
> > > >
> > > > static atomic_t in_suspend;
> > > > static bool power_off_triggered;
> > > > +static struct kobject *cdev_link_kobj;
> > > > +static struct kobject *tz_link_kobj;
> > > >
> > > > static struct thermal_governor *def_governor;
> > > >
> > > > @@ -954,7 +957,7 @@ __thermal_cooling_device_register(struct device_node *np,
> > > > struct thermal_zone_device *pos = NULL;
> > > > int result;
> > > >
> > > > - if (type && strlen(type) >= THERMAL_NAME_LENGTH)
> > > > + if (!type || !type[0] || strlen(type) >= THERMAL_NAME_LENGTH)
> > > > return ERR_PTR(-EINVAL);
> > >
> > > This should be a separate fix, if needed.
> Agree, but the link now requires that "" as invalid _type_.
I'm not sure I understand. What does this change have to do with
adding symlinks below?
> > >
> > > > if (!ops || !ops->get_max_state || !ops->get_cur_state ||
> > > > @@ -989,9 +992,15 @@ __thermal_cooling_device_register(struct device_node *np,
> > > > return ERR_PTR(result);
> > > > }
> > > >
> > > > - /* Add 'this' new cdev to the global cdev list */
> > > > + /* Add 'this' new cdev to the global cdev list and create link*/
> > > > mutex_lock(&thermal_list_lock);
> > > > list_add(&cdev->node, &thermal_cdev_list);
> > > > + if (!cdev_link_kobj)
> > > > + cdev_link_kobj = kobject_create_and_add("cdev-by-name",
> > > > + cdev->device.kobj.parent);
> > > > + if (!cdev_link_kobj || sysfs_create_link(cdev_link_kobj,
> > > > + &cdev->device.kobj, cdev->type))
> > > > + dev_err(&cdev->device, "Failed to create cdev-by-name link\n");
> > >
> > > Any reason not to use the following form instead? It seems easier to read.
> > >
> > > if (!cdev_link_kobj) {
> > > cdev_link_kobj = kobject_create_and_add("cdev-by-name",
> > > cdev->device.kobj.parent);
> > > ret = sysfs_create_link(cdev_link_kobj,
> > > &cdev->device.kobj, cdev->type))
> > > if (ret)
> > > dev_err(&cdev->device, "Failed to create
> > > cdev-by-name link\n");
> > > }
> >
> > I can now see why you had to do that - none of the other links would
> > get created after the first one.
> >
> > Perhaps create the directories in the __init functions and only create
> > the links here?
> >
> AFAICT, this is no such API except the private get_device_parent()
> under driver/base/. Also the lazy initialization makes sense in such
> case when there is no thermal device attached. Looks like the class
> dir is also lazy-initialized when first device registered
> https://elixir.bootlin.com/linux/v5.3.5/source/drivers/base/core.c#L1790.
OK.
> >
> > > > mutex_unlock(&thermal_list_lock);
> > > >
> > > > /* Update binding information for 'this' new cdev */
> > > > @@ -1157,6 +1166,8 @@ void thermal_cooling_device_unregister(struct thermal_cooling_device *cdev)
> > > > }
> > > > }
> > > > }
> > > > + if (cdev_link_kobj)
> > > > + sysfs_remove_link(cdev_link_kobj, cdev->type);
> > > >
> > > > mutex_unlock(&thermal_list_lock);
> > > >
> > > > @@ -1340,6 +1351,12 @@ thermal_zone_device_register(const char *type, int trips, int mask,
> > > >
> > > > mutex_lock(&thermal_list_lock);
> > > > list_add_tail(&tz->node, &thermal_tz_list);
> > > > + if (!tz_link_kobj)
> > > > + tz_link_kobj = kobject_create_and_add("tz-by-name",
> > > > + tz->device.kobj.parent);
> > > > + if (!tz_link_kobj || sysfs_create_link(tz_link_kobj,
> > > > + &tz->device.kobj, tz->type))
> > > > + dev_err(&tz->device, "Failed to create tz-by-name link\n");
> > >
> > > Same as above.
> > >
> > > > mutex_unlock(&thermal_list_lock);
> > > >
> > > > /* Bind cooling devices for this zone */
> > > > @@ -1411,6 +1428,8 @@ void thermal_zone_device_unregister(struct thermal_zone_device *tz)
> > > > }
> > > > }
> > > > }
> > > > + if (tz_link_kobj)
> > > > + sysfs_remove_link(tz_link_kobj, tz->type);
> > > >
> > > > mutex_unlock(&thermal_list_lock);
> > > >
> > > > --
> > > > 2.23.0.700.g56cf767bdb-goog
> > > >
next prev parent reply other threads:[~2019-11-11 5:26 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-15 6:13 Wei Wang
2019-10-16 16:50 ` Amit Kucheria
2019-10-16 17:15 ` Amit Kucheria
2019-10-16 21:34 ` Wei Wang
2019-11-11 5:26 ` Amit Kucheria [this message]
2019-11-11 17:52 ` Wei Wang
2019-12-04 12:45 ` Amit Kucheria
2019-12-04 21:56 ` [PATCH v2 0/2] thermal: introduce by-name softlink Wei Wang
2019-12-04 21:56 ` [PATCH v2 1/2] thermal: fix and clean up tz and cdev registration Wei Wang
2019-12-05 4:13 ` Amit Kucheria
2019-12-05 6:14 ` Wei Wang
2019-12-05 6:26 ` Amit Kucheria
2019-12-05 7:06 ` Amit Kucheria
2019-12-05 7:56 ` Zhang Rui
2019-12-04 21:56 ` [PATCH v2 2/2] thermal: create softlink by name for thermal_zone and cooling_device Wei Wang
2019-12-05 4:14 ` Amit Kucheria
2019-12-04 21:58 ` [PATCH] " Wei Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=CAHLCerN4ymf7LOGQPRLuAwirwCUaQGynrnUMfgU6+frDswey5A@mail.gmail.com \
--to=amit.kucheria@verdurent.com \
--cc=daniel.lezcano@linaro.org \
--cc=edubezval@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rui.zhang@intel.com \
--cc=wei.vince.wang@gmail.com \
--cc=wvw@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®