From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755944AbaIWNci (ORCPT ); Tue, 23 Sep 2014 09:32:38 -0400 Received: from mail-vc0-f172.google.com ([209.85.220.172]:65124 "EHLO mail-vc0-f172.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754710AbaIWNcg (ORCPT ); Tue, 23 Sep 2014 09:32:36 -0400 MIME-Version: 1.0 In-Reply-To: <20140922200716.GB3128@worktop.programming.kicks-ass.net> References: <1411415590-12193-1-git-send-email-bobby.prani@gmail.com> <20140922200716.GB3128@worktop.programming.kicks-ass.net> From: Pranith Kumar Date: Tue, 23 Sep 2014 09:32:05 -0400 Message-ID: Subject: Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read() To: Peter Zijlstra Cc: "open list:X86 ARCHITECTURE..." Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Sep 22, 2014 at 4:07 PM, Peter Zijlstra wrote: > On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote: >> Use the much easier to read ACCESS_ONCE() which is basically the same thing as >> the cast to volatile. >> >> Please note the change in volatile cast: ACCESS_ONCE(v)->counter to >> ACCESS_ONCE(v->counter). >> >> Signed-off-by: Pranith Kumar >> --- >> arch/x86/include/asm/atomic.h | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) > > If you want to do something like so, then be consistent and do them all. Hi Peter, The changelog across all archs is as follows 18 files changed, 24 insertions(+), 24 deletions(-) Do you think it is better to send it as one patch or break up into patch for each arch? -- Pranith