From: Jarod Wilson <jarod@redhat.com>
To: LKML <linux-kernel@vger.kernel.org>
Cc: Jay Vosburgh <j.vosburgh@gmail.com>,
Veaceslav Falico <vfalico@gmail.com>,
Andy Gospodarek <andy@greyhouse.net>,
"David S. Miller" <davem@davemloft.net>,
Jakub Kicinski <kuba@kernel.org>, Thomas Davis <tadavis@lbl.gov>,
Netdev <netdev@vger.kernel.org>
Subject: Re: [PATCH net-next v3 5/5] bonding: update Documentation for port/bond terminology
Date: Wed, 7 Oct 2020 18:59:41 -0400 [thread overview]
Message-ID: <CAKfmpSeSWNKEoxtYP9sY30wDUFaSAk76GghmBhTefLo07ThHiw@mail.gmail.com> (raw)
In-Reply-To: <20201007181409.1275639-6-jarod@redhat.com>
On Wed, Oct 7, 2020 at 2:14 PM Jarod Wilson <jarod@redhat.com> wrote:
>
> Swap in port/bond terminology where appropriate, leaving all legacy sysfs
> and procfs interface mentions in place, but marked as deprecated.
> Additionally, add more netlink/iproute2 documentation, and note that this
> is the preferred method of interfacing with the bonding driver. While
> we're at it, also make some mention of NetworkManager's existence.
I neglected to update the ToC and put in some leading #'s that I
should have, so there will be at least one more revision of this set,
but would appreciate feedback on this version of the Documentation
update with respect to preservation of existing interface names,
explaining the changes, and deprecation.
--
Jarod Wilson
jarod@redhat.com
prev parent reply other threads:[~2020-10-07 22:59 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-10-07 18:14 [PATCH net-next v3 0/5] bonding: rename bond components Jarod Wilson
2020-10-07 18:14 ` [PATCH net-next v3 1/5] bonding: rename 802.3ad's struct port to ad_port Jarod Wilson
2020-10-07 18:14 ` [PATCH net-next v3 2/5] bonding: replace use of the term master where possible Jarod Wilson
2020-10-07 18:14 ` [PATCH net-next v3 3/5] bonding: rename slave to port " Jarod Wilson
2020-10-07 18:14 ` [PATCH net-next v3 4/5] bonding: rename bonding_sysfs_slave.c to _port.c Jarod Wilson
2020-10-07 18:14 ` [PATCH net-next v3 5/5] bonding: update Documentation for port/bond terminology Jarod Wilson
2020-10-07 22:59 ` Jarod Wilson [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=CAKfmpSeSWNKEoxtYP9sY30wDUFaSAk76GghmBhTefLo07ThHiw@mail.gmail.com \
--to=jarod@redhat.com \
--cc=andy@greyhouse.net \
--cc=davem@davemloft.net \
--cc=j.vosburgh@gmail.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=tadavis@lbl.gov \
--cc=vfalico@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®