mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Daniel Almeida <daniel.almeida@collabora.com>
To: Tamir Duberstein <tamird@gmail.com>
Cc: "Miguel Ojeda" <ojeda@kernel.org>,
	"Alex Gaynor" <alex.gaynor@gmail.com>,
	"Boqun Feng" <boqun.feng@gmail.com>,
	"Gary Guo" <gary@garyguo.net>,
	"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
	"Benno Lossin" <benno.lossin@proton.me>,
	"Andreas Hindborg" <a.hindborg@kernel.org>,
	"Alice Ryhl" <aliceryhl@google.com>,
	"Trevor Gross" <tmgross@umich.edu>,
	"Danilo Krummrich" <dakr@kernel.org>,
	"Boris-Chengbiao Zhou" <bobo1239@web.de>,
	"Kees Cook" <kees@kernel.org>, "Fiona Behrens" <me@kloenk.dev>,
	rust-for-linux@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Lukas Wirth" <lukas.wirth@ferrous-systems.com>
Subject: Re: [PATCH v5 07/13] scripts: generate_rust_analyzer.py: avoid optional arguments
Date: Tue, 1 Apr 2025 09:58:40 -0300	[thread overview]
Message-ID: <CCB6D89D-D513-4514-8992-AC37313F5588@collabora.com> (raw)
In-Reply-To: <20250325-rust-analyzer-host-v5-7-385e7f1e1e23@gmail.com>

Hi Tamir,

This patch looks good to me but,

> On 25 Mar 2025, at 17:06, Tamir Duberstein <tamird@gmail.com> wrote:
> 
> Make all arguments required to reduce the probability of incorrect
> implicit behavior. Use keyword arguments for clarity.
> 
> Signed-off-by: Tamir Duberstein <tamird@gmail.com>
> ---
> scripts/generate_rust_analyzer.py | 90 +++++++++++++++++++++++++++------------
> 1 file changed, 62 insertions(+), 28 deletions(-)
> 
> diff --git a/scripts/generate_rust_analyzer.py b/scripts/generate_rust_analyzer.py
> index b37d8345486a..badcef4126cf 100755
> --- a/scripts/generate_rust_analyzer.py
> +++ b/scripts/generate_rust_analyzer.py
> @@ -69,9 +69,10 @@ def generate_crates(
>     def build_crate(
>         display_name: str,
>         root_module: pathlib.Path,
> +        *,
>         deps: List[str],
> -        cfg: List[str] = [],
> -        is_workspace_member: bool = True,
> +        cfg: List[str],
> +        is_workspace_member: bool,
>     ) -> Crate:
>         return {
>             "display_name": display_name,
> @@ -92,21 +93,34 @@ def generate_crates(
>     def append_crate(
>         display_name: str,
>         root_module: pathlib.Path,
> +        *,
>         deps: List[str],
> -        cfg: List[str] = [],
> -        is_workspace_member: bool = True,
> +        cfg: List[str],
>     ) -> None:
>         register_crate(
> -            build_crate(display_name, root_module, deps, cfg, is_workspace_member)
> +            build_crate(
> +                display_name,
> +                root_module,
> +                deps=deps,
> +                cfg=cfg,
> +                is_workspace_member=True,
> +            )
>         )
> 
>     def append_proc_macro_crate(
>         display_name: str,
>         root_module: pathlib.Path,
> +        *,
>         deps: List[str],
> -        cfg: List[str] = [],
> +        cfg: List[str],
>     ) -> None:
> -        crate = build_crate(display_name, root_module, deps, cfg)
> +        crate = build_crate(
> +            display_name,
> +            root_module,
> +            deps=deps,
> +            cfg=cfg,
> +            is_workspace_member=True,
> +        )
>         proc_macro_dylib_name = (
>             subprocess.check_output(
>                 [
> @@ -133,66 +147,75 @@ def generate_crates(
> 
>     def append_sysroot_crate(
>         display_name: str,
> +        *,
>         deps: List[str],
> -        cfg: List[str] = [],
> +        cfg: List[str],
>     ) -> None:
> -        append_crate(
> -            display_name,
> -            sysroot_src / display_name / "src" / "lib.rs",
> -            deps,
> -            cfg,
> -            is_workspace_member=False,
> +        register_crate(
> +            build_crate(
> +                display_name,
> +                sysroot_src / display_name / "src" / "lib.rs",
> +                deps=deps,
> +                cfg=cfg,
> +                is_workspace_member=False,
> +            )
>         )

Why the change from append to register+build here? Maybe this change
should be in another patch?

— Daniel

  reply	other threads:[~2025-04-01 12:59 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-25 20:06 [PATCH v5 00/13] rust: generate_rust_analyzer.py: define host crates and scripts Tamir Duberstein
2025-03-25 20:06 ` [PATCH v5 01/13] scripts: generate_rust_analyzer.py: add missing whitespace Tamir Duberstein
2025-04-17  6:50   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 02/13] scripts: generate_rust_analyzer.py: use double quotes Tamir Duberstein
2025-04-17  6:51   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 03/13] scripts: generate_rust_analyzer.py: add trailing comma Tamir Duberstein
2025-04-17  6:51   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 04/13] scripts: generate_rust_analyzer.py: extract `{build,register}_crate` Tamir Duberstein
2025-04-17  6:53   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 05/13] scripts: generate_rust_analyzer.py: drop `"is_proc_macro": false` Tamir Duberstein
2025-03-31 16:46   ` Daniel Almeida
2025-04-17  6:55   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 06/13] scripts: generate_rust_analyzer.py: add type hints Tamir Duberstein
2025-03-31 17:09   ` Daniel Almeida
2025-03-31 17:47     ` Tamir Duberstein
2025-04-01 13:01       ` Daniel Almeida
2025-04-17  7:10   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 07/13] scripts: generate_rust_analyzer.py: avoid optional arguments Tamir Duberstein
2025-04-01 12:58   ` Daniel Almeida [this message]
2025-04-01 13:34     ` Tamir Duberstein
2025-04-17 11:17       ` Daniel Almeida
2025-04-17  7:13   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 08/13] scripts: generate_rust_analyzer.py: use str(pathlib.Path) Tamir Duberstein
2025-04-17  7:15   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 09/13] scripts: generate_rust_analyzer.py: identify crates explicitly Tamir Duberstein
2025-04-17  7:18   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 10/13] scripts: generate_rust_analyzer.py: define host crates Tamir Duberstein
2025-04-17  7:19   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 11/13] scripts: generate_rust_analyzer.py: avoid FD leak Tamir Duberstein
2025-04-17  7:19   ` Trevor Gross
2025-03-25 20:06 ` [PATCH v5 12/13] scripts: generate_rust_analyzer.py: define scripts Tamir Duberstein
2025-04-17  7:25   ` Trevor Gross
2025-04-17 13:10     ` Tamir Duberstein
2025-03-25 20:06 ` [PATCH v5 13/13] scripts: generate_rust_analyzer.py: use `cfg_groups` Tamir Duberstein
2025-04-17  7:29   ` Trevor Gross
2025-04-17 13:14     ` Tamir Duberstein

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CCB6D89D-D513-4514-8992-AC37313F5588@collabora.com \
    --to=daniel.almeida@collabora.com \
    --cc=a.hindborg@kernel.org \
    --cc=alex.gaynor@gmail.com \
    --cc=aliceryhl@google.com \
    --cc=benno.lossin@proton.me \
    --cc=bjorn3_gh@protonmail.com \
    --cc=bobo1239@web.de \
    --cc=boqun.feng@gmail.com \
    --cc=dakr@kernel.org \
    --cc=gary@garyguo.net \
    --cc=kees@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lukas.wirth@ferrous-systems.com \
    --cc=me@kloenk.dev \
    --cc=ojeda@kernel.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=tamird@gmail.com \
    --cc=tmgross@umich.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®