From: "Jarkko Sakkinen" <jarkko@kernel.org>
To: "Jo Van Bulck" <jo.vanbulck@cs.kuleuven.be>,
<kai.huang@intel.com>, <linux-sgx@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Cc: <dave.hansen@linux.intel.com>
Subject: Re: [PATCH 3/8] selftests/sgx: Handle relocations in test enclave
Date: Thu, 10 Aug 2023 23:32:14 +0300 [thread overview]
Message-ID: <CUP5FP8OHD3I.2MUE3TTRVNRTQ@suppilovahvero> (raw)
In-Reply-To: <20230808193145.8860-4-jo.vanbulck@cs.kuleuven.be>
On Tue Aug 8, 2023 at 10:31 PM EEST, Jo Van Bulck wrote:
> Static-pie binaries normally include a startup routine to perform any ELF
> relocations from .rela.dyn. Since the enclave loading process is different
> and glibc is not included, do the necessary relocation for encl_op_array
> entries manually at runtime relative to the enclave base to ensure correct
> function pointers.
>
> Signed-off-by: Jo Van Bulck <jo.vanbulck@cs.kuleuven.be>
What happens if I only apply 1/8 and 2/8 from this patch set?
I'm just wondering why there is no mention of "-static-pie" here.
> ---
> tools/testing/selftests/sgx/test_encl.c | 35 +++++++++++++++--------
> tools/testing/selftests/sgx/test_encl.lds | 3 ++
> 2 files changed, 26 insertions(+), 12 deletions(-)
>
> diff --git a/tools/testing/selftests/sgx/test_encl.c b/tools/testing/selftests/sgx/test_encl.c
> index c0d6397295e3..c71dfbadd2d9 100644
> --- a/tools/testing/selftests/sgx/test_encl.c
> +++ b/tools/testing/selftests/sgx/test_encl.c
> @@ -119,21 +119,32 @@ static void do_encl_op_nop(void *_op)
>
> }
>
> +/*
> + * Symbol placed at the start of the enclave image by the linker script.
> + * Declare this extern symbol with visibility "hidden" to ensure the
> + * compiler does not access it through the GOT.
> + */
> +extern uint8_t __attribute__((visibility("hidden"))) __enclave_base;
I'd rename this as __encl_base to be consistent with other naming here.
You could also declare for convenience and clarity:
static const uint64_t encl_base = (uint64_t)&__encl_base;
> +
> +void (*encl_op_array[ENCL_OP_MAX])(void *) = {
> + do_encl_op_put_to_buf,
> + do_encl_op_get_from_buf,
> + do_encl_op_put_to_addr,
> + do_encl_op_get_from_addr,
> + do_encl_op_nop,
> + do_encl_eaccept,
> + do_encl_emodpe,
> + do_encl_init_tcs_page,
> +};
> +
Why you need to drop "const"? The array is not dynamically updated, i.e.
there's no reason to move it away from rodata section. If this was
kernel code, such modification would be considered as a regression.
I would also consider cleaning this up a bit further, while you are
refactoring anyway, and declare a typedef:
typedef void (*encl_op_t)(void *);
const encl_op_t encl_op_array[ENCL_OP_MAX] = {
> void encl_body(void *rdi, void *rsi)
> {
> - const void (*encl_op_array[ENCL_OP_MAX])(void *) = {
> - do_encl_op_put_to_buf,
> - do_encl_op_get_from_buf,
> - do_encl_op_put_to_addr,
> - do_encl_op_get_from_addr,
> - do_encl_op_nop,
> - do_encl_eaccept,
> - do_encl_emodpe,
> - do_encl_init_tcs_page,
> - };
> -
> struct encl_op_header *op = (struct encl_op_header *)rdi;
>
> + /*
> + * Manually rebase the loaded function pointer as enclaves cannot
> + * rely on startup routines to perform static pie relocations.
> + */
This comment is not very useful. I'd consider dropping it.
> if (op->type < ENCL_OP_MAX)
> - (*encl_op_array[op->type])(op);
> + (*(((uint64_t) &__enclave_base) + encl_op_array[op->type]))(op);
~
should not have white space here (coding style)
This would be cleaner IMHO:
void encl_body(void *rdi, void *rsi)
{
struct encl_op_header *header = (struct encl_op_header *)rdi;
encl_op_t op;
if (header->type >= ENCL_OP_MAX)
return;
/*
* "encl_base" needs to be added, as this call site *cannot be*
* made rip-relative by the compiler, or fixed up by any other
* possible means.
*/
op = encl_base + encl_op_array[header->type];
(*op)(header);
}
> }
> diff --git a/tools/testing/selftests/sgx/test_encl.lds b/tools/testing/selftests/sgx/test_encl.lds
> index ca659db2a534..73d9c8bbe7de 100644
> --- a/tools/testing/selftests/sgx/test_encl.lds
> +++ b/tools/testing/selftests/sgx/test_encl.lds
> @@ -32,6 +32,9 @@ SECTIONS
> *(.note*)
> *(.debug*)
> *(.eh_frame*)
> + /* Dynamic symbol table not supported in enclaves */
I'd drop this comment.
> + *(.dyn*)
> + *(.gnu.hash)
> }
> }
>
> --
> 2.34.1
BR, Jarkko
next prev parent reply other threads:[~2023-08-10 20:32 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-08-08 19:31 [PATCH v2 0/8] selftests/sgx: Fix compilation errors Jo Van Bulck
2023-08-08 19:31 ` [PATCH 1/8] selftests/sgx: Fix uninitialized pointer dereference in error path Jo Van Bulck
2023-08-10 19:15 ` Jarkko Sakkinen
2023-08-18 11:30 ` Huang, Kai
2023-08-08 19:31 ` [PATCH 2/8] selftests/sgx: Produce static-pie executable for test enclave Jo Van Bulck
2023-08-10 19:22 ` Jarkko Sakkinen
2023-08-08 19:31 ` [PATCH 3/8] selftests/sgx: Handle relocations in " Jo Van Bulck
2023-08-10 20:32 ` Jarkko Sakkinen [this message]
2023-08-19 0:32 ` Jo Van Bulck
2023-08-22 10:07 ` Jarkko Sakkinen
2023-08-08 19:31 ` [PATCH 4/8] selftests/sgx: Fix linker script asserts Jo Van Bulck
2023-08-08 19:31 ` [PATCH 5/8] selftests/sgx: Include memory clobber for inline asm in test enclave Jo Van Bulck
2023-08-18 11:31 ` Huang, Kai
2023-08-08 19:31 ` [PATCH 6/8] selftests/sgx: Ensure expected enclave data buffer size and placement Jo Van Bulck
2023-08-18 13:10 ` Huang, Kai
2023-08-19 1:09 ` Jo Van Bulck
2023-08-08 19:31 ` [PATCH 7/8] selftests/sgx: Separate linker options Jo Van Bulck
2023-08-08 19:31 ` [PATCH 8/8] selftests/sgx: Specify freestanding environment for enclave compilation Jo Van Bulck
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=CUP5FP8OHD3I.2MUE3TTRVNRTQ@suppilovahvero \
--to=jarkko@kernel.org \
--cc=dave.hansen@linux.intel.com \
--cc=jo.vanbulck@cs.kuleuven.be \
--cc=kai.huang@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-sgx@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®