From: "Benno Lossin" <lossin@kernel.org>
To: "Danilo Krummrich" <dakr@kernel.org>
Cc: <gregkh@linuxfoundation.org>, <rafael@kernel.org>,
<ojeda@kernel.org>, <alex.gaynor@gmail.com>,
<boqun.feng@gmail.com>, <gary@garyguo.net>,
<bjorn3_gh@protonmail.com>, <benno.lossin@proton.me>,
<a.hindborg@kernel.org>, <aliceryhl@google.com>,
<tmgross@umich.edu>, <rust-for-linux@vger.kernel.org>,
<linux-kernel@vger.kernel.org>,
"Dave Airlie" <airlied@redhat.com>,
"Simona Vetter" <simona.vetter@ffwll.ch>,
"Viresh Kumar" <viresh.kumar@linaro.org>
Subject: Re: [PATCH 2/4] rust: devres: replace Devres::new_foreign_owned()
Date: Sun, 22 Jun 2025 09:42:03 +0200 [thread overview]
Message-ID: <DASW5JYFRE2K.1E5T6FI6KNRQJ@kernel.org> (raw)
In-Reply-To: <aFcn51EPcWlDG_YW@pollux>
On Sat Jun 21, 2025 at 11:45 PM CEST, Danilo Krummrich wrote:
> On Sat, Jun 21, 2025 at 11:10:14PM +0200, Benno Lossin wrote:
>> On Thu Jun 12, 2025 at 4:51 PM CEST, Danilo Krummrich wrote:
>> > diff --git a/rust/kernel/cpufreq.rs b/rust/kernel/cpufreq.rs
>> > index b0a9c6182aec..f20636079f7a 100644
>> > --- a/rust/kernel/cpufreq.rs
>> > +++ b/rust/kernel/cpufreq.rs
>> > @@ -12,7 +12,7 @@
>> > clk::Hertz,
>> > cpumask,
>> > device::{Bound, Device},
>> > - devres::Devres,
>> > + devres,
>> > error::{code::*, from_err_ptr, from_result, to_result, Result, VTABLE_DEFAULT_ERROR},
>> > ffi::{c_char, c_ulong},
>> > prelude::*,
>> > @@ -910,7 +910,7 @@ unsafe impl<T: Driver> Sync for Registration<T> {}
>> > /// thread.
>> > unsafe impl<T: Driver> Send for Registration<T> {}
>> >
>> > -impl<T: Driver> Registration<T> {
>> > +impl<T: Driver + 'static> Registration<T> {
>>
>> This change should probably be its own patch? If not, then it should be
>> mentioned in the commit message.
>
> It's a consequence of register_foreign_boxed() requiring T: 'static.
Then let's put the bound on that function, since putting it on the impl
block also affects `Registration::new()`.
>> > const VTABLE: bindings::cpufreq_driver = bindings::cpufreq_driver {
>> > name: Self::copy_name(T::NAME),
>> > boost_enabled: T::BOOST_ENABLED,
>> > @@ -1044,10 +1044,10 @@ pub fn new() -> Result<Self> {
>> >
>> > /// Same as [`Registration::new`], but does not return a [`Registration`] instance.
>> > ///
>> > - /// Instead the [`Registration`] is owned by [`Devres`] and will be revoked / dropped, once the
>> > + /// Instead the [`Registration`] is owned by [`kernel::devres`] and will be dropped, once the
>> > /// device is detached.
>> > pub fn new_foreign_owned(dev: &Device<Bound>) -> Result {
>>
>> I think we can improve the names here. How about `new_attached`? See
>> more below.
>
> I feel like the name pretty much nails it: it's a new instance that is not
> owned, by the Rust side, but by the C devres implementation (i.e. foreign
> owned), which automatically drops it when the device is unbound.
Yeah, but `foreign` is so unspecific... With `ForeignOwnable`, it makes
sense, since it could be anything.
> Maybe Registration::new_devres_owned() instead?
I like that one better, let's go with that.
>> > - Devres::new_foreign_owned(dev, Self::new()?, GFP_KERNEL)
>> > + devres::register_foreign_boxed(dev, Self::new()?, GFP_KERNEL)
>> > }
>> > }
>>
>> > +/// Encapsulate `data` in a [`KBox`] and [`Drop::drop`] `data` once `dev` is unbound.
>> > +///
>> > +/// # Examples
>> > +///
>> > +/// ```no_run
>> > +/// use kernel::{device::{Bound, Device}, devres};
>> > +///
>> > +/// struct Registration;
>> > +///
>> > +/// impl Registration {
>> > +/// fn new() -> Self {
>> > +/// // register (e.g. class device, IRQ, etc.)
>> > +///
>> > +/// Self
>> > +/// }
>> > +/// }
>> > +///
>> > +/// impl Drop for Registration {
>> > +/// fn drop(&mut self) {
>> > +/// // unregister
>> > +/// }
>> > +/// }
>> > +///
>> > +/// fn from_bound_context(dev: &Device<Bound>) -> Result {
>> > +/// devres::register_foreign_boxed(dev, Registration::new(), GFP_KERNEL)
>> > +/// }
>> > +/// ```
>> > +pub fn register_foreign_boxed<T, E>(
>>
>> I don't really get the name of this function. The data isn't really
>> foreign and that the user also shouldn't really care about the fact that
>> you use `KBox` under the hood.
>>
>> How about we call this something like `attach_data`?
>
> Hm, I think attach_data() doesn't quite hit the point. Maybe just
> devres::register_owned() instead. I agree that 'boxed' is an unnecessary
> implementation detail.
I like `register_owned` better, but I'm not 100% convinced by the
`owned` part... The regular devres creation is called `Devres::new`,
right? How about we just call this `register`?
---
Cheers,
Benno
next prev parent reply other threads:[~2025-06-22 7:42 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-12 14:51 [PATCH 0/4] Improvements for Devres Danilo Krummrich
2025-06-12 14:51 ` [PATCH 1/4] rust: revocable: support fallible PinInit types Danilo Krummrich
2025-06-12 15:48 ` Benno Lossin
2025-06-12 15:58 ` Danilo Krummrich
2025-06-12 16:17 ` Benno Lossin
2025-06-12 16:20 ` Danilo Krummrich
2025-06-12 14:51 ` [PATCH 2/4] rust: devres: replace Devres::new_foreign_owned() Danilo Krummrich
2025-06-13 3:14 ` Viresh Kumar
2025-06-21 21:10 ` Benno Lossin
2025-06-21 21:45 ` Danilo Krummrich
2025-06-22 7:42 ` Benno Lossin [this message]
2025-06-22 9:55 ` Danilo Krummrich
2025-06-22 20:18 ` Benno Lossin
2025-06-12 14:51 ` [PATCH 3/4] rust: devres: get rid of Devres' inner Arc Danilo Krummrich
2025-06-22 7:05 ` Benno Lossin
2025-06-22 12:08 ` Danilo Krummrich
2025-06-22 20:16 ` Benno Lossin
2025-06-22 15:45 ` Danilo Krummrich
2025-06-22 20:15 ` Benno Lossin
2025-06-12 14:51 ` [PATCH 4/4] rust: devres: implement register_foreign_release() Danilo Krummrich
2025-06-22 7:26 ` Benno Lossin
2025-06-22 12:46 ` Danilo Krummrich
2025-06-22 20:14 ` Benno Lossin
2025-06-22 20:25 ` Danilo Krummrich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DASW5JYFRE2K.1E5T6FI6KNRQJ@kernel.org \
--to=lossin@kernel.org \
--cc=a.hindborg@kernel.org \
--cc=airlied@redhat.com \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=benno.lossin@proton.me \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=gary@garyguo.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=ojeda@kernel.org \
--cc=rafael@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=simona.vetter@ffwll.ch \
--cc=tmgross@umich.edu \
--cc=viresh.kumar@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®