On Wed Jul 9, 2025 at 1:05 PM CEST, Krzysztof Kozlowski wrote: > On 09/07/2025 12:57, Diederik de Haas wrote: >> + gpio-keys { >> + compatible = "gpio-keys"; >> + pinctrl-0 = <&gpio4_a0_k1>; >> + pinctrl-names = "default"; >> + >> + button-reset { >> + debounce-interval = <50>; >> + gpios = <&gpio4 RK_PA0 GPIO_ACTIVE_LOW>; >> + label = "RESET"; >> + linux,code = ; >> + }; >> + }; >> + >> gpio-leds { >> compatible = "gpio-leds"; >> pinctrl-names = "default"; >> @@ -127,6 +140,12 @@ eth_phy0_reset_pin: eth-phy0-reset-pin { >> }; >> }; >> >> + gpio-keys { >> + gpio4_a0_k1: gpio4-a0-k1 { > > Are you sure that this passes checks? I did the following: ```sh export PATH=~/dev/kernel.org/dt-schema-venv/bin/:$PATH CROSS_COMPILE=aarch64-linux-gnu- ARCH=arm64 make distclean make debarm64_defconfig make CHECK_DTBS=y W=1 rockchip/rk3568-nanopi-r5s.dtb ``` And it did not report any issues. Then booted up my NanoPi R5S and verified that with the updated dtb the reset button worked. If it's about the 'weird' name/label, it is what is used in the schematic document I have and I asked Heiko (on IRC) if using ``reset_button_pin: gpio4-a0-k1`` would not be better. That would make it more descriptive while also having the schematic traceability in it. The answer was no, use the form I used in this patch. Am I missing checks I should've done as well? Cheers, Diederik