From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "Benno Lossin" <lossin@kernel.org>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Alex Gaynor" <alex.gaynor@gmail.com>,
"Boqun Feng" <boqun.feng@gmail.com>,
"Gary Guo" <gary@garyguo.net>,
"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Alice Ryhl" <aliceryhl@google.com>,
"Trevor Gross" <tmgross@umich.edu>,
"Danilo Krummrich" <dakr@kernel.org>
Cc: <linux-kernel@vger.kernel.org>, <rust-for-linux@vger.kernel.org>,
<nouveau@lists.freedesktop.org>
Subject: Re: [PATCH 1/3] rust: add `num` module with `PowerOfTwo` type
Date: Fri, 25 Jul 2025 12:38:57 +0900 [thread overview]
Message-ID: <DBKTNE4OF0IB.3C32NVHQ9UKQ3@nvidia.com> (raw)
In-Reply-To: <DASWS1A63LYM.399CKUDL4Z7UC@kernel.org>
Hi Benno,
Sorry, took some time to come back to this!
On Sun Jun 22, 2025 at 5:11 PM JST, Benno Lossin wrote:
> On Fri Jun 20, 2025 at 3:14 PM CEST, Alexandre Courbot wrote:
>> +/// An unsigned integer which is guaranteed to be a power of 2.
>> +///
>> +/// # Invariants
>> +///
>> +/// The stored value is guaranteed to be a power of two.
>> +#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord, Hash)]
>> +#[repr(transparent)]
>> +pub struct PowerOfTwo<T>(T);
>> +
>> +macro_rules! power_of_two_impl {
>> + ($($t:ty),+) => {
>> + $(
>> + impl PowerOfTwo<$t> {
>
> I tried to use this type in a doctest like this:
>
> use kernel::num::PowerOfTwo;
>
> fn new(x: usize) -> PowerOfTwo<usize> {
> PowerOfTwo::new(1 << x)
> }
>
> And it doesn't compile :(
>
> error[E0034]: multiple applicable items in scope
> --> rust/doctests_kernel_generated.rs:4930:17
> |
> 4930 | PowerOfTwo::new(1 << x)
> | ^^^ multiple `new` found
> |
> = note: candidate #1 is defined in an impl for the type `PowerOfTwo<u128>`
> = note: candidate #2 is defined in an impl for the type `PowerOfTwo<u16>`
> = note: candidate #3 is defined in an impl for the type `PowerOfTwo<u32>`
> = note: candidate #4 is defined in an impl for the type `PowerOfTwo<u64>`
> = note: and 2 others
>
> error: aborting due to 1 previous error
>
> The problem is that the function `new` exists 6 times for each of the
> integer types. You can write `PowerOfTwo::<usize>::new()` instead, but
> that's annoying...
This should go away as we switch to the non-generic `Alignment` type
thankfully.
>
> We probably need an `Integer` trait and then do
>
> impl<I: Integer> PowerOfTwo<I> {
> pub const fn new(value: I) -> Self;
> }
>
>> + /// Validates that `v` is a power of two at build-time, and returns it wrapped into
>> + /// [`PowerOfTwo`].
>> + ///
>> + /// A build error is triggered if `v` cannot be asserted to be a power of two.
>> + ///
>> + /// # Examples
>> + ///
>> + /// ```
>> + /// use kernel::num::PowerOfTwo;
>> + ///
>> + #[doc = concat!("let v = PowerOfTwo::<", stringify!($t), ">::new(16);")]
>> + /// assert_eq!(v.value(), 16);
>> + /// ```
>> + #[inline(always)]
>> + pub const fn new(v: $t) -> Self {
>> + build_assert!(v.count_ones() == 1);
>
> Why not `v.is_power_of_two()`?
Why not indeed. :) Fixed.
>
>> + Self(v)
>
> Missing `// INVARIANT` comment.
Added (and in other places as well).
>
>> + }
>> +
>> + /// Validates that `v` is a power of two at runtime, and returns it wrapped into
>> + /// [`PowerOfTwo`].
>> + ///
>> + /// [`None`] is returned if `v` was not a power of two.
>> + ///
>> + /// # Examples
>> + ///
>> + /// ```
>> + /// use kernel::num::PowerOfTwo;
>> + ///
>> + #[doc = concat!(
>> + "assert_eq!(PowerOfTwo::<",
>> + stringify!($t),
>> + ">::try_new(16), Some(PowerOfTwo::<",
>> + stringify!($t),
>> + ">::new(16)));"
>> + )]
>> + #[doc = concat!(
>> + "assert_eq!(PowerOfTwo::<",
>> + stringify!($t),
>> + ">::try_new(15), None);"
>> + )]
>> + /// ```
>> + #[inline(always)]
>> + pub const fn try_new(v: $t) -> Option<Self> {
>
> Maybe `new_checked` is a better name, since it doesn't return a result?
Definitely.
>
>> + match v.count_ones() {
>
> Why not `is_power_of_two()`?
Fixed, thanks.
>
>> + 1 => Some(Self(v)),
>
> Missing `// INVARIANT` comment.
>
>> + _ => None,
>> + }
>> + }
>> +
>> + /// Returns the value of this instance.
>> + ///
>> + /// It is guaranteed to be a power of two.
>> + ///
>> + /// # Examples
>> + ///
>> + /// ```
>> + /// use kernel::num::PowerOfTwo;
>> + ///
>> + #[doc = concat!("let v = PowerOfTwo::<", stringify!($t), ">::new(16);")]
>> + /// assert_eq!(v.value(), 16);
>> + /// ```
>> + #[inline(always)]
>> + pub const fn value(self) -> $t {
>> + self.0
>
> Let's add:
>
> if !self.0.is_power_of_two() {
> core::hint::unreachable_unchecked()
> }
> self.0
Sure. Is it to enable compiler optimizations by making assumptions about
the returned value?
>
>> + }
>> +
>> + /// Returns the mask corresponding to `self.value() - 1`.
>> + ///
>> + /// # Examples
>> + ///
>> + /// ```
>> + /// use kernel::num::PowerOfTwo;
>> + ///
>> + #[doc = concat!("let v = PowerOfTwo::<", stringify!($t), ">::new(0x10);")]
>> + /// assert_eq!(v.mask(), 0xf);
>> + /// ```
>> + #[inline(always)]
>> + pub const fn mask(self) -> $t {
>> + self.0.wrapping_sub(1)
>
> Then use `self.value().wrapping_sub(1)` here instead to also propagate
> the information.
Ack.
next prev parent reply other threads:[~2025-07-25 3:39 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-20 13:14 [PATCH 0/3] rust: add `num` module Alexandre Courbot
2025-06-20 13:14 ` [PATCH 1/3] rust: add `num` module with `PowerOfTwo` type Alexandre Courbot
2025-06-20 13:35 ` Miguel Ojeda
2025-06-20 13:59 ` Alexandre Courbot
2025-06-20 14:02 ` Alice Ryhl
2025-08-02 14:02 ` Alexandre Courbot
2025-08-02 14:18 ` Miguel Ojeda
2025-08-03 13:13 ` Alexandre Courbot
2025-08-03 15:15 ` Miguel Ojeda
2025-08-04 7:32 ` Alexandre Courbot
2025-08-06 5:02 ` Alexandre Courbot
2026-04-14 9:45 ` Miguel Ojeda
2025-06-20 17:06 ` Miguel Ojeda
2025-06-22 8:11 ` Benno Lossin
2025-07-25 3:38 ` Alexandre Courbot [this message]
2025-07-25 10:10 ` Benno Lossin
2025-06-20 13:14 ` [PATCH 2/3] rust: num: add the `last_set_bit` operation Alexandre Courbot
2025-06-22 8:12 ` Benno Lossin
2025-06-23 11:42 ` Alice Ryhl
2025-06-20 13:14 ` [PATCH 3/3] nova-core: use `num` module Alexandre Courbot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DBKTNE4OF0IB.3C32NVHQ9UKQ3@nvidia.com \
--to=acourbot@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=gary@garyguo.net \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=nouveau@lists.freedesktop.org \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=tmgross@umich.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome