mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "Rhys Lloyd" <krakow20@gmail.com>, <dakr@kernel.org>
Cc: <rust-for-linux@vger.kernel.org>, <airlied@gmail.com>,
	<simona@ffwll.ch>, <nouveau@lists.freedesktop.org>,
	<dri-devel@lists.freedesktop.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3] gpu: nova-core: vbios: change PmuLookupTableEntry to use size_of
Date: Fri, 25 Jul 2025 22:30:03 +0900	[thread overview]
Message-ID: <DBL67Z2JPGOH.2ZMUNUYVQO7E4@nvidia.com> (raw)
In-Reply-To: <20250718073633.194032-3-krakow20@gmail.com>

On Fri Jul 18, 2025 at 4:36 PM JST, Rhys Lloyd wrote:
> Annotate the PmuLookupTableEntry with an `#[repr(C, packed)]` attribute.
> Removes another magic number by making the struct the same size as
> the data it needs to read, allowing the use of
> `size_of::<PmuLookupTableEntry>()`
>
> Signed-off-by: Rhys Lloyd <krakow20@gmail.com>

Looking good - I'll also push this one after a short grace period. Thanks!

  reply	other threads:[~2025-07-25 13:30 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-18  7:36 [PATCH] gpu: nova-core: vbios: use offset_of in PmuLookupTableHeader::new Rhys Lloyd
2025-07-18  7:36 ` [PATCH v2] gpu: nova-core: vbios: use size_of instead of magic number Rhys Lloyd
2025-07-25 13:29   ` Alexandre Courbot
2025-07-18  7:36 ` [PATCH v3] gpu: nova-core: vbios: change PmuLookupTableEntry to use size_of Rhys Lloyd
2025-07-25 13:30   ` Alexandre Courbot [this message]
2025-07-25 13:35 ` [PATCH] gpu: nova-core: vbios: use offset_of in PmuLookupTableHeader::new Alexandre Courbot
2025-07-25 14:04   ` Danilo Krummrich
2025-07-27  9:51     ` Rhys Lloyd

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DBL67Z2JPGOH.2ZMUNUYVQO7E4@nvidia.com \
    --to=acourbot@nvidia.com \
    --cc=airlied@gmail.com \
    --cc=dakr@kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=krakow20@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nouveau@lists.freedesktop.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=simona@ffwll.ch \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®