From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "Joel Fernandes" <joelagnelf@nvidia.com>,
"Alexandre Courbot" <acourbot@nvidia.com>,
<linux-kernel@vger.kernel.org>, <rust-for-linux@vger.kernel.org>,
<dri-devel@lists.freedesktop.org>, <dakr@kernel.org>
Cc: "Alistair Popple" <apopple@nvidia.com>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Alex Gaynor" <alex.gaynor@gmail.com>,
"Boqun Feng" <boqun.feng@gmail.com>,
"Gary Guo" <gary@garyguo.net>, <bjorn3_gh@protonmail.com>,
"Benno Lossin" <lossin@kernel.org>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Alice Ryhl" <aliceryhl@google.com>,
"Trevor Gross" <tmgross@umich.edu>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"John Hubbard" <jhubbard@nvidia.com>,
"Timur Tabi" <ttabi@nvidia.com>, <joel@joelfernandes.org>,
"Elle Rhumsaa" <elle@weathered-steel.dev>,
"Yury Norov" <yury.norov@gmail.com>,
"Daniel Almeida" <daniel.almeida@collabora.com>,
"Andrea Righi" <arighi@nvidia.com>,
<nouveau@lists.freedesktop.org>
Subject: Re: [PATCH v5 6/9] rust: bitfield: Add KUNIT tests for bitfield
Date: Sat, 04 Oct 2025 09:38:12 +0900 [thread overview]
Message-ID: <DD949OHGD5WP.1X9TCLIEKSHGB@nvidia.com> (raw)
In-Reply-To: <81490b32-6ea2-400f-a97e-ad2e33e6daab@nvidia.com>
On Sat Oct 4, 2025 at 12:23 AM JST, Joel Fernandes wrote:
>> - The right field is actually written (i.e. if the offset is off by one,
>> the getter will return the expected result even though the bitfield
>> has the wrong value),
>> - No other field has been affected.
>>
>> So something like:
>>
>> pte = pte.set_present(true);
>> assert!(pte.present());
>> assert(pte.into(), 0x1u64);
>>
>> pte = pte.set_writable(true);
>> assert!(pte.writable());
>> assert(pte.into(), 0x3u64);
>>
>> It might look a bit gross, but it is ok since these are not doctests
>> that users are going to take as a reference, so we case improve test
>> coverage at the detriment of readability.
>>
>
> Ack. I will add these.
>
> Thanks for the review! (I am assuming with these changes you're Ok with me
> carrying your Reviewed-by tag on this patch as well, but please let me know if
> there is a concern.)
Please do not add tags that haven't been explicitly given. If we start
assuming one another's stance about patches, the trust we can have in
these tags is significantly reduced.
Doing so also doesn't achieve anything in terms of efficiency; if I am
ok with v3 I can give my Reviewed-by on it, and the tag can be picked up
along with the patch when it is applied.
next prev parent reply other threads:[~2025-10-04 0:38 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-30 14:45 [PATCH v5 0/9] Introduce bitfield and move register macro to rust/kernel/ Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 1/9] nova-core: bitfield: Move bitfield-specific code from register! into new macro Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 2/9] nova-core: bitfield: Add support for different storage widths Joel Fernandes
2025-09-30 17:18 ` Joel Fernandes
2025-10-02 1:17 ` Alexandre Courbot
2025-09-30 14:45 ` [PATCH v5 3/9] nova-core: bitfield: Add support for custom visiblity Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 4/9] rust: Move register and bitfield macros out of Nova Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 5/9] rust: bitfield: Add a new() constructor and raw() accessor Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 6/9] rust: bitfield: Add KUNIT tests for bitfield Joel Fernandes
2025-10-02 1:41 ` Alexandre Courbot
2025-10-02 2:16 ` Elle Rhumsaa
2025-10-02 2:51 ` Alexandre Courbot
2025-10-02 3:35 ` Elle Rhumsaa
2025-10-03 15:23 ` Joel Fernandes
2025-10-04 0:38 ` Alexandre Courbot [this message]
2025-10-04 16:14 ` Joel Fernandes
2025-10-06 16:40 ` Miguel Ojeda
2025-10-06 19:50 ` Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 7/9] rust: bitfield: Use 'as' operator for setter type conversion Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 8/9] rust: bitfield: Add hardening for out of bounds access Joel Fernandes
2025-09-30 18:03 ` Yury Norov
2025-09-30 22:06 ` Joel Fernandes
2025-09-30 14:45 ` [PATCH v5 9/9] rust: bitfield: Add hardening for undefined bits Joel Fernandes
2025-09-30 15:08 ` [PATCH v5 0/9] Introduce bitfield and move register macro to rust/kernel/ Danilo Krummrich
2025-10-02 1:24 ` Alexandre Courbot
2025-10-02 1:26 ` Alexandre Courbot
2025-10-03 15:26 ` Joel Fernandes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DD949OHGD5WP.1X9TCLIEKSHGB@nvidia.com \
--to=acourbot@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=airlied@gmail.com \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=apopple@nvidia.com \
--cc=arighi@nvidia.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=daniel.almeida@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=elle@weathered-steel.dev \
--cc=gary@garyguo.net \
--cc=jhubbard@nvidia.com \
--cc=joel@joelfernandes.org \
--cc=joelagnelf@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=nouveau@lists.freedesktop.org \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=simona@ffwll.ch \
--cc=tmgross@umich.edu \
--cc=ttabi@nvidia.com \
--cc=tzimmermann@suse.de \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome