From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "Lyude Paul" <lyude@redhat.com>,
"Joel Fernandes" <joelagnelf@nvidia.com>,
<linux-kernel@vger.kernel.org>, <rust-for-linux@vger.kernel.org>,
<dri-devel@lists.freedesktop.org>,
"Danilo Krummrich" <dakr@kernel.org>,
"Alexandre Courbot" <acourbot@nvidia.com>
Cc: "Alistair Popple" <apopple@nvidia.com>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Alex Gaynor" <alex.gaynor@gmail.com>,
"Boqun Feng" <boqun.feng@gmail.com>,
"Gary Guo" <gary@garyguo.net>, <bjorn3_gh@protonmail.com>,
"Benno Lossin" <lossin@kernel.org>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Alice Ryhl" <aliceryhl@google.com>,
"Trevor Gross" <tmgross@umich.edu>,
"David Airlie" <airlied@gmail.com>,
"Simona Vetter" <simona@ffwll.ch>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"John Hubbard" <jhubbard@nvidia.com>,
"Timur Tabi" <ttabi@nvidia.com>, <joel@joelfernandes.org>,
"Daniel Almeida" <daniel.almeida@collabora.com>,
<nouveau@lists.freedesktop.org>,
"Nouveau" <nouveau-bounces@lists.freedesktop.org>
Subject: Re: [PATCH v5 08/13] gpu: nova-core: sequencer: Add register opcodes
Date: Sat, 15 Nov 2025 21:37:05 +0900 [thread overview]
Message-ID: <DE99UZ5ONZ4G.13Y7574M0YYHU@nvidia.com> (raw)
In-Reply-To: <8436e9b42b897c044c253e3e99f260b5a62fb0d5.camel@redhat.com>
Hi Lyude,
On Sat Nov 15, 2025 at 6:55 AM JST, Lyude Paul wrote:
> We're very close! I see a few things we still need to fix though
>
> On Fri, 2025-11-14 at 14:55 -0500, Joel Fernandes wrote:
>> ...
>> -impl GspSeqCmdRunner for GspSeqCmd {
>> - fn run(&self, _seq: &GspSequencer<'_>) -> Result {
>> +impl GspSeqCmdRunner for fw::RegWritePayload {
>> + fn run(&self, sequencer: &GspSequencer<'_>) -> Result {
>> + let addr = self.addr() as usize;
>> + let val = self.val();
>> + let _ = sequencer.bar.try_write32(val, addr);
>
> We're still not handling the possible error from try_write32() here
> Also - addr/val seem a bit superfluous
I wonder whether this could be on purpose? As in, the register sequence
might try to write to non-existing registers on some models but this is
not necessarily a fatal error. Still, I can complete initialization even
when handling the error, so let's err on the side or correctness unless
Joel signals that this is indeed what we want (in which case a comment
would ensure there cannot be any confusion as to the purpose).
For now, changed this to:
let addr = usize::from_safe_cast(self.addr());
sequencer.bar.try_write32(self.val(), addr)
>
>> Ok(())
>> }
>> }
>>
>> +impl GspSeqCmdRunner for fw::RegModifyPayload {
>> + fn run(&self, sequencer: &GspSequencer<'_>) -> Result {
>> + let addr = self.addr() as usize;
>> + if let Ok(temp) = sequencer.bar.try_read32(addr) {
>> + let _ = sequencer
>> + .bar
>> + .try_write32((temp & !self.mask()) | self.val(), addr);
>
> Same here
This is now:
let addr = usize::from_safe_cast(self.addr());
sequencer.bar.try_read32(addr).and_then(|val| {
sequencer
.bar
.try_write32((val & !self.mask()) | self.val(), addr)
})
>
>> + }
>> + Ok(())
>> + }
>> +}
>> +
>> +impl GspSeqCmdRunner for fw::RegPollPayload {
>> + fn run(&self, sequencer: &GspSequencer<'_>) -> Result {
>> + let addr = self.addr() as usize;
>> +
>> + // Default timeout to 4 seconds.
>> + let timeout_us = if self.timeout() == 0 {
>> + 4_000_000
>> + } else {
>> + i64::from(self.timeout())
>> + };
>> +
>> + // First read.
>> + sequencer.bar.try_read32(addr)?;
>> +
>> + // Poll the requested register with requested timeout.
>> + read_poll_timeout(
>> + || sequencer.bar.try_read32(addr),
>> + |current| (current & self.mask()) == self.val(),
>> + Delta::ZERO,
>> + Delta::from_micros(timeout_us),
>> + )
>> + .map(|_| ())
>> + }
>> +}
>> +
>> +impl GspSeqCmdRunner for fw::RegStorePayload {
>> + fn run(&self, sequencer: &GspSequencer<'_>) -> Result {
>> + let addr = self.addr() as usize;
>> + let _index = self.index();
>> +
>> + let _val = sequencer.bar.try_read32(addr)?;
>> +
>> + Ok(())
>
> These variables still seem superfluous - we don't use _index at all.
>
> This function should just be rewritten as:
>
> fn run(&self, sequencer: &GspSequencer<'_>) -> Result {
> sequencer.bar.try_read32(self.addr() as usize)?;
Actually I thought this is also a good opportunity to replace the `as`
with the safer `FromSafeCast` interface we introduced recently precisely
for that (you probably have already noticed from the previous fixes :)).
Only this would look a bit heavy if done inline, so for readability I'll
keep the temporary variable and change this to:
let addr = usize::from_safe_cast(self.addr());
sequencer.bar.try_read32(addr).map(|_| ())
This makes me wonder about the `index` member of this op - it is not
used at all! Joel, do you know what it is for?
Thanks for spotting these!
next prev parent reply other threads:[~2025-11-15 12:37 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-14 19:55 [PATCH v5 00/13] nova-core: Complete GSP boot and begin RPC communication Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 01/13] gpu: nova-core: falcon: Move waiting until halted to a helper Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 02/13] gpu: nova-core: falcon: Move start functionality into separate helper Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 03/13] gpu: nova-core: falcon: Move mbox functionalities into helper Joel Fernandes
2025-11-15 11:27 ` Alexandre Courbot
2025-11-14 19:55 ` [PATCH v5 04/13] gpu: nova-core: falcon: Move dma_reset functionality " Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 05/13] gpu: nova-core: gsp: Add support for checking if GSP reloaded Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 06/13] gpu: nova-core: Add bindings required by GSP sequencer Joel Fernandes
2025-11-14 19:55 ` [PATCH v5 07/13] gpu: nova-core: Implement the " Joel Fernandes
2025-11-14 21:41 ` Lyude Paul
2025-11-14 22:04 ` Lyude Paul
2025-11-14 19:55 ` [PATCH v5 08/13] gpu: nova-core: sequencer: Add register opcodes Joel Fernandes
2025-11-14 21:55 ` Lyude Paul
2025-11-15 12:37 ` Alexandre Courbot [this message]
2025-11-14 19:55 ` [PATCH v5 09/13] gpu: nova-core: sequencer: Add delay opcode support Joel Fernandes
2025-11-14 21:56 ` Lyude Paul
2025-11-14 19:55 ` [PATCH v5 10/13] gpu: nova-core: sequencer: Implement basic core operations Joel Fernandes
2025-11-14 21:56 ` Lyude Paul
2025-11-14 19:55 ` [PATCH v5 11/13] gpu: nova-core: sequencer: Implement core resume operation Joel Fernandes
2025-11-14 21:58 ` Lyude Paul
2025-11-14 19:55 ` [PATCH v5 12/13] gpu: nova-core: gsp: Wait for gsp initialization to complete Joel Fernandes
2025-11-14 21:59 ` Lyude Paul
2025-11-14 19:55 ` [PATCH v5 13/13] gpu: nova-core: gsp: Retrieve GSP static info to gather GPU information Joel Fernandes
2025-11-14 22:06 ` Lyude Paul
2025-11-15 12:38 ` Alexandre Courbot
2025-11-15 21:03 ` John Hubbard
2025-11-15 13:31 ` [PATCH v5 00/13] nova-core: Complete GSP boot and begin RPC communication Alexandre Courbot
2025-11-16 2:32 ` John Hubbard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DE99UZ5ONZ4G.13Y7574M0YYHU@nvidia.com \
--to=acourbot@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=airlied@gmail.com \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=apopple@nvidia.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=daniel.almeida@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=gary@garyguo.net \
--cc=jhubbard@nvidia.com \
--cc=joel@joelfernandes.org \
--cc=joelagnelf@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=lyude@redhat.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=nouveau-bounces@lists.freedesktop.org \
--cc=nouveau@lists.freedesktop.org \
--cc=ojeda@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=simona@ffwll.ch \
--cc=tmgross@umich.edu \
--cc=ttabi@nvidia.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®