From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 049433E9F76 for ; Tue, 17 Mar 2026 15:34:11 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773761651; cv=none; b=s06UYN0KiRofSt7hyB/Y+ZnYTAx3VlwcFxgzRipMat+eBfJerz5wGt6I3weIHC1NGnu/m+FRsDl/nXPOoS+1szhh0wv26SHROdXYD32oPwTcVDWpCRXAMYvWvEgDFQe3m4j1e3Vr5gIuZVlAgK/U2i6wyxzF1WpVWe496F1VB7Q= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773761651; c=relaxed/simple; bh=K88ELa4YxbOs7MjkjeqZu/qU8bBxF2QdgopZVhmZDuo=; h=Mime-Version:Content-Type:Date:Message-Id:Subject:Cc:To:From: References:In-Reply-To; b=M7W2rUuBxl56fYXNsjV8Qi5xggK4Jji9N4XJxxm0HJLaLrlXOK1vwitZXp8YEmXGZe2rOAmnKTIPcuTty48Z1Sj8wzNOFFE3sD4eI2TqsBOQqF11qFb/K43vOZkKx/d2KLgL2mreKUuGeSGtEdLpGuVT3FdlwlMQzeEOHd3Rbe0= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=lloHfF9u; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="lloHfF9u" Received: by smtp.kernel.org (Postfix) with ESMTPSA id E16ADC4CEF7; Tue, 17 Mar 2026 15:34:08 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1773761650; bh=K88ELa4YxbOs7MjkjeqZu/qU8bBxF2QdgopZVhmZDuo=; h=Date:Subject:Cc:To:From:References:In-Reply-To:From; b=lloHfF9uR2+D9irKZ+QqRQ3bjpmX1CItoqdE7Pr1fEySw6jkQA+8XV0knu2uMMdP6 b32te5vMsjUovTfWxXubXftgV6wAT26VtyACVcwzFo6iJgyG406C7UqEyh+0hGme+8 0dtyhidxBKuhOPZay1TUALmi+NwAQmLkOxi9N4cnrDhIBzxE6E5aSShiMniQ9WXBrR aLhuQJjTPYVV8e2aLp/EDAYkrjRVCJr6/tAY4bqtJPwmAa3FlTXNS7aJ0B2fjDkfIw TDLeW1bPsVvz4EBA8zPGh3Hy01VXWo8P0ux8oOWEGfHbxt8dbzwXiODpkON3iEeVcT K1845x970s2+A== Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: Mime-Version: 1.0 Content-Transfer-Encoding: quoted-printable Content-Type: text/plain; charset=UTF-8 Date: Tue, 17 Mar 2026 16:34:07 +0100 Message-Id: Subject: Re: [PATCH v3 2/2] gpu: nova-drm: rename nova to nova-drm Cc: "Cheng-Yang Chou" , , , , , , , , To: "Alexandre Courbot" From: "Danilo Krummrich" References: <20260317092304.424377-1-yphbchou0911@gmail.com> In-Reply-To: On Tue Mar 17, 2026 at 4:22 PM CET, Alexandre Courbot wrote: > On Tue Mar 17, 2026 at 10:53 PM JST, Danilo Krummrich wrote: >> On Tue Mar 17, 2026 at 2:20 PM CET, Alexandre Courbot wrote: >>> On Tue Mar 17, 2026 at 6:23 PM JST, Cheng-Yang Chou wrote: >>>> Rename the nova-drm driver directory from drivers/gpu/drm/nova/ to >>>> drivers/gpu/drm/nova-drm/ and the top-level source file from nova.rs >>>> to nova_drm.rs (matching the object name nova_drm.o) to follow the >>>> kebab-case naming convention already used by the auxiliary device name= . >>>> >>>> Update MAINTAINERS, Kconfig, and Makefile references accordingly. >>>> Update the Kconfig help text to reflect the new module name nova-drm. >>>> >>>> Link: https://github.com/Rust-for-Linux/linux/issues/1228 >>>> Signed-off-by: Cheng-Yang Chou >>>> Reviewed-by: John Hubbard >>>> --- >>>> Changes in v3: >>>> - Rename subject line (John Hubbard) >>>> >>>> MAINTAINERS | 6 +++--- >>>> drivers/gpu/drm/Kconfig | 2 +- >>>> drivers/gpu/drm/Makefile | 2 +- >>>> drivers/gpu/drm/{nova =3D> nova-drm}/Kconfig | 2 +- >>>> drivers/gpu/drm/nova-drm/Makefile | 3 +++ >>>> drivers/gpu/drm/{nova =3D> nova-drm}/driver.rs | 0 >>>> drivers/gpu/drm/{nova =3D> nova-drm}/file.rs | 0 >>>> drivers/gpu/drm/{nova =3D> nova-drm}/gem.rs | 0 >>> >>> That `drm/nova-drm` reads a bit awkwardly to me and feels unnecessary. >>> Even `tegra-drm` is in `drm/tegra`. >> >> Well, that's why I named it "nova" in the first place, but I don't want >> KBUILD_MODNAME to diverge from the directory name and I also don't want = the >> driver name to diverge from KBUILD_MODNAME. > > What is the rationale for that? I like consistency too, but also think > it is not particularly difficult to figure out that "nova-drm" resides > in "drm/nova". It is consistency. But why are we discussing this, what is the concern bein= g consistent here?