mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Gary Guo" <gary@garyguo.net>
To: "Nathan Chancellor" <nathan@kernel.org>, "Gary Guo" <gary@garyguo.net>
Cc: "Alice Ryhl" <aliceryhl@google.com>, "Rong Xu" <xur@google.com>,
	"Han Shen" <shenhan@google.com>,
	"Nicolas Schier" <nsc@kernel.org>,
	"Miguel Ojeda" <ojeda@kernel.org>,
	"Boqun Feng" <boqun@kernel.org>,
	"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
	"Benno Lossin" <lossin@kernel.org>,
	"Andreas Hindborg" <a.hindborg@kernel.org>,
	"Trevor Gross" <tmgross@umich.edu>,
	"Danilo Krummrich" <dakr@kernel.org>,
	"Matthew Maurer" <mmaurer@google.com>,
	linux-kbuild@vger.kernel.org, linux-kernel@vger.kernel.org,
	rust-for-linux@vger.kernel.org
Subject: Re: [PATCH] kbuild: rust: add AutoFDO support
Date: Fri, 20 Mar 2026 21:48:37 +0000	[thread overview]
Message-ID: <DH7XVDAUF5JT.2U3SPHXDFH8PS@garyguo.net> (raw)
In-Reply-To: <20260319235443.GB769346@ax162>

On Thu Mar 19, 2026 at 11:54 PM GMT, Nathan Chancellor wrote:
> On Thu, Mar 19, 2026 at 07:09:22PM +0000, Gary Guo wrote:
>> On Thu Mar 19, 2026 at 4:33 PM GMT, Alice Ryhl wrote:
>> > On Thu, Mar 19, 2026 at 12:47 PM Gary Guo <gary@garyguo.net> wrote:
>> >> On Thu Mar 19, 2026 at 11:44 AM GMT, Alice Ryhl wrote:
>> >> > Do you think it's worth having Rust not match the CFLAGS here?
>> >> >
>> >>
>> >> I think the C flags should probably be renamed AUTOFDO_LLVM too. After call, all
>> >> the perf tools involved here are called llvm-foobar as well.
>> >
>> > But isn't it just called this because the config option is
>> > CONFIG_AUTOFDO_CLANG? So it's the CFLAGS or RUSTFLAGS related to that
>> > particular config option. It may make sense to rename
>> > CONFIG_AUTOFDO_CLANG to CONFIG_AUTOFDO, but that's out-of-scope for
>> > this change, in my opinion.
>> 
>> I get that it's an existing config name, but previously it is a correct
>> description, while after this change it is no longer accurate.
>> 
>> I don't know if there's an established practice on renaming CONFIG options when
>> this sort thing happens though. Perhaps one way is to have add
>> CONFIG_AUTOFDO_CLANG that selects CONFIG_AUTOFDO.
>
> As Miguel mentioned, there is the transitional keyword for Kconfig to
> handle renames now but I would really like there to be a compelling
> reason for the rename other than LLVM is a little more accurate than
> CLANG. The kernel has never really done a great job of referring to
> Clang when it means the C compiler vs. the whole LLVM toolchain (like
> LTO_CLANG and all its derivatives should be LTO_LLVM since it requires
> ld.lld, llvm-nm, and llvm-ar in addition to clang). Additionally, aside
> from the configuration, there is the user facing Make variable
> CLANG_AUTOFDO_PROFILE that would presumably need to be changed for
> consistency.

If you think the config name should be kept as CONFIG_AUTOFDO_CLANG, then I
think there is no real benefit in changing the variable name.

Reviewed-by: Gary Guo <gary@garyguo.net>

Best,
Gary

  parent reply	other threads:[~2026-03-20 21:48 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-03-19 11:22 Alice Ryhl
2026-03-19 11:31 ` Gary Guo
2026-03-19 11:44   ` Alice Ryhl
2026-03-19 11:47     ` Gary Guo
2026-03-19 16:33       ` Alice Ryhl
2026-03-19 19:09         ` Gary Guo
2026-03-19 20:37           ` Miguel Ojeda
2026-03-19 23:54           ` Nathan Chancellor
2026-03-20  6:47             ` Alice Ryhl
2026-03-20 21:18               ` Nathan Chancellor
2026-03-20 21:48             ` Gary Guo [this message]
     [not found]               ` <CAF1bQ=T8-tWaB5Sf2eqWSodMgp=Pf9Guut-JavV62dczHpGNBg@mail.gmail.com>
2026-03-25 17:08                 ` Rong Xu
2026-03-25 17:10               ` Rong Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DH7XVDAUF5JT.2U3SPHXDFH8PS@garyguo.net \
    --to=gary@garyguo.net \
    --cc=a.hindborg@kernel.org \
    --cc=aliceryhl@google.com \
    --cc=bjorn3_gh@protonmail.com \
    --cc=boqun@kernel.org \
    --cc=dakr@kernel.org \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lossin@kernel.org \
    --cc=mmaurer@google.com \
    --cc=nathan@kernel.org \
    --cc=nsc@kernel.org \
    --cc=ojeda@kernel.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=shenhan@google.com \
    --cc=tmgross@umich.edu \
    --cc=xur@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®