From: "Alexandre Courbot" <acourbot@nvidia.com>
To: "Zhi Wang" <zhiw@nvidia.com>
Cc: <dakr@kernel.org>, <airlied@gmail.com>, <simona@ffwll.ch>,
<ojeda@kernel.org>, <alex.gaynor@gmail.com>,
<boqun.feng@gmail.com>, <gary@garyguo.net>,
<bjorn3_gh@protonmail.com>, <lossin@kernel.org>,
<a.hindborg@kernel.org>, <aliceryhl@google.com>,
<tmgross@umich.edu>, <jhubbard@nvidia.com>,
<ecourtney@nvidia.com>, <joelagnelf@nvidia.com>,
<apopple@nvidia.com>, <cjia@nvidia.com>, <smitra@nvidia.com>,
<kjaju@nvidia.com>, <alkumar@nvidia.com>, <ankita@nvidia.com>,
<aniketa@nvidia.com>, <kwankhede@nvidia.com>,
<targupta@nvidia.com>, <nova-gpu@lists.linux.dev>,
<linux-kernel@vger.kernel.org>, <zhiwang@kernel.org>
Subject: Re: [PATCH] gpu: nova-core: reserve a larger GSP WPR2 heap when vGPU is enabled
Date: Wed, 17 Jun 2026 12:09:46 +0900 [thread overview]
Message-ID: <DJAZT6ZNLZYZ.OJE0UIR4OOBQ@nvidia.com> (raw)
In-Reply-To: <DJAJGC4LLOK3.YAX75103O00O@nvidia.com>
On Tue Jun 16, 2026 at 11:20 PM JST, Alexandre Courbot wrote:
> On Thu Jun 4, 2026 at 8:43 PM JST, Zhi Wang wrote:
>> GSP-RM allocates independent RM sub-heaps for each VF partition inside
>> the WPR2 region. The default baremetal heap sizing is far too small for
>> vGPU instance, causing GSP-RM to hit out-of-memory failures during VF
>> initialization.
>>
>> The host driver must reserve the correct heap size before GSP boots,
>> because the WPR2 region is locked down by the hardware after boot and
>> cannot be resized at runtime. The firmware determines the per-VF carve
>> from the gspFwHeapVfPartitionCount field in the WPR2 metadata header.
>>
>> Select a pre-calibrated static heap size based on total_vfs (174 MB for
>> 1 VM, 581 MB for 2-32 VFs, 1370 MB for 48 VFs) and set
>> vf_partition_count accordingly. Extend FbLayout::new() and
>> GspBootContext to propagate total_vfs through the boot path.
>>
>> Signed-off-by: Zhi Wang <zhiw@nvidia.com>
>> ---
>> drivers/gpu/nova-core/fb.rs | 17 +++++++++++++----
>> drivers/gpu/nova-core/gsp.rs | 2 +-
>> drivers/gpu/nova-core/gsp/boot.rs | 14 +++++++++++---
>> drivers/gpu/nova-core/gsp/fw.rs | 12 ++++++++++++
>> 4 files changed, 37 insertions(+), 8 deletions(-)
>>
>> diff --git a/drivers/gpu/nova-core/fb.rs b/drivers/gpu/nova-core/fb.rs
>> index 725e428154cf..fb4e6aa9fda4 100644
>> --- a/drivers/gpu/nova-core/fb.rs
>> +++ b/drivers/gpu/nova-core/fb.rs
>> @@ -171,7 +171,13 @@ pub(crate) struct FbLayout {
>>
>> impl FbLayout {
>> /// Computes the FB layout for `chipset` required to run the `gsp_fw` GSP firmware.
>> - pub(crate) fn new(chipset: Chipset, bar: Bar0<'_>, gsp_fw: &GspFirmware) -> Result<Self> {
>> + pub(crate) fn new(
>> + chipset: Chipset,
>> + bar: Bar0<'_>,
>> + gsp_fw: &GspFirmware,
>> + vgpu_requested: bool,
>> + total_vfs: u16,
>
> `total_vfs` is only meaningful if `vgpu_requested` is true. So these two
> parameters would be better modeled using an `Option`, or maybe even
> better a dedicated parameter type for vGPU settings? Something like
> (please pick a better name if any):
>
> enum VgpuRequest {
> Disabled,
> Requested {
> total_vfs: u16,
> }
> }
If we can implement my suggestion of moving `Fsp` into `Gpu` of patch
7, then this can take a `&VgpuManager` and not require any new type to
express the vGPU state.
next prev parent reply other threads:[~2026-06-17 3:09 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-04 11:43 [PATCH 0/9] gpu: nova-core: boot GSP with vGPU enabled on Zhi Wang
2026-06-04 11:43 ` [PATCH 1/9] rust: pci: expose sriov_get_totalvfs() helper Zhi Wang
2026-06-05 14:08 ` Alexandre Courbot
2026-06-17 7:51 ` Zhi Wang
2026-06-04 11:43 ` [PATCH 2/9] gpu: nova-core: factor out common FSP message header Zhi Wang
2026-06-05 13:21 ` Alexandre Courbot
2026-06-04 11:43 ` [PATCH 3/9] gpu: nova-core: return FSP response buffer to caller Zhi Wang
2026-06-05 13:25 ` Alexandre Courbot
2026-06-05 16:04 ` Zhi Wang
2026-06-09 6:07 ` Alexandre Courbot
2026-06-17 7:52 ` Zhi Wang
2026-06-04 11:43 ` [PATCH 4/9] gpu: nova-core: read vGPU mode from FSP via PRC protocol Zhi Wang
2026-06-16 8:35 ` Alexandre Courbot
2026-06-17 8:01 ` Zhi Wang
2026-06-04 11:43 ` [PATCH 5/9] gpu: nova-core: add FSP and PRC protocol documentation Zhi Wang
2026-06-16 8:17 ` Alexandre Courbot
2026-06-17 7:51 ` Zhi Wang
2026-06-17 13:21 ` Alexandre Courbot
2026-06-04 11:43 ` [PATCH 6/9] gpu: nova-core: consolidate GSP boot parameters into GspBootContext Zhi Wang
2026-06-16 14:13 ` Alexandre Courbot
2026-06-17 13:22 ` Alexandre Courbot
2026-06-04 11:43 ` [PATCH 7/9] gpu: nova-core: add vGPU preludes Zhi Wang
2026-06-17 3:08 ` Alexandre Courbot
2026-06-04 11:43 ` [PATCH 8/9] gpu: nova-core: set RMSetSriovMode when NVIDIA vGPU is enabled Zhi Wang
2026-06-17 3:13 ` Alexandre Courbot
2026-06-04 11:43 ` [PATCH] gpu: nova-core: reserve a larger GSP WPR2 heap when " Zhi Wang
2026-06-16 14:20 ` Alexandre Courbot
2026-06-17 3:09 ` Alexandre Courbot [this message]
2026-06-17 8:07 ` Zhi Wang
2026-06-17 12:02 ` Alexandre Courbot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DJAZT6ZNLZYZ.OJE0UIR4OOBQ@nvidia.com \
--to=acourbot@nvidia.com \
--cc=a.hindborg@kernel.org \
--cc=airlied@gmail.com \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=alkumar@nvidia.com \
--cc=aniketa@nvidia.com \
--cc=ankita@nvidia.com \
--cc=apopple@nvidia.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=cjia@nvidia.com \
--cc=dakr@kernel.org \
--cc=ecourtney@nvidia.com \
--cc=gary@garyguo.net \
--cc=jhubbard@nvidia.com \
--cc=joelagnelf@nvidia.com \
--cc=kjaju@nvidia.com \
--cc=kwankhede@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lossin@kernel.org \
--cc=nova-gpu@lists.linux.dev \
--cc=ojeda@kernel.org \
--cc=simona@ffwll.ch \
--cc=smitra@nvidia.com \
--cc=targupta@nvidia.com \
--cc=tmgross@umich.edu \
--cc=zhiw@nvidia.com \
--cc=zhiwang@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox