From: "Zi Yan" <ziy@nvidia.com>
To: "Kiryl Shutsemau" <kirill@shutemov.name>,
"Andrew Morton" <akpm@linux-foundation.org>,
"David Hildenbrand" <david@kernel.org>,
"Lorenzo Stoakes" <ljs@kernel.org>
Cc: <linux-mm@kvack.org>, <linux-kernel@vger.kernel.org>,
<kernel-team@meta.com>,
"Baolin Wang" <baolin.wang@linux.alibaba.com>,
"Liam R . Howlett" <liam@infradead.org>,
"Nico Pache" <nico.pache@linux.dev>,
"Ryan Roberts" <ryan.roberts@arm.com>,
"Dev Jain" <dev.jain@arm.com>, "Barry Song" <baohua@kernel.org>,
"Lance Yang" <lance.yang@linux.dev>,
"Usama Arif" <usama.arif@linux.dev>,
"Vlastimil Babka" <vbabka@kernel.org>,
"Jann Horn" <jannh@google.com>,
"Kiryl Shutsemau (Meta)" <kas@kernel.org>
Subject: Re: [PATCH 04/12] mm/collapse: add collapse.h for the collapse interface
Date: Fri, 04 Sep 2026 22:36:58 -0400 [thread overview]
Message-ID: <DL717O23OZOA.2UYSFURHZH0H2@nvidia.com> (raw)
In-Reply-To: <ec5230f43af7153e18aed02c6ee38f010106d8e8.1788533997.git.kas@kernel.org>
On Fri Sep 4, 2026 at 11:10 AM EDT, Kiryl Shutsemau wrote:
> From: "Kiryl Shutsemau (Meta)" <kas@kernel.org>
>
> khugepaged.c holds both the users of collapse and the machinery that
> performs it. The daemon's scan loop, the sysfs tunables, MADV_COLLAPSE's
> entry point and the collapse itself all sit in one file and reach into
> each other freely. Nothing marks where a user ends and the engine
> begins.
>
> Start drawing that line.
>
> Add mm/collapse.h for what the two sides have to agree on:
>
> - enum scan_result - what the engine hands back;
> - struct collapse_control - the state a request carries.
>
> And two constants move with them:
>
> - KHUGEPAGED_MAX_PTES_LIMIT -> COLLAPSE_MAX_PTES_LIMIT;
> - KHUGEPAGED_MIN_MTHP_ORDER -> COLLAPSE_MIN_MTHP_ORDER.
>
> Neither is a fact about the daemon, so both lose the KHUGEPAGED_ prefix.
>
> No functional change.
>
> Assisted-by: Claude-Code:claude-opus-5
> Signed-off-by: Kiryl Shutsemau (Meta) <kas@kernel.org>
> ---
> MAINTAINERS | 1 +
> mm/collapse.h | 67 +++++++++++++++++++++++++++++++++++++++++
> mm/khugepaged.c | 79 ++++++++-----------------------------------------
> 3 files changed, 81 insertions(+), 66 deletions(-)
> create mode 100644 mm/collapse.h
>
<snip>
> +
> +enum scan_result {
> + SCAN_FAIL,
> + SCAN_SUCCEED,
> + SCAN_NO_PTE_TABLE,
> + SCAN_PMD_MAPPED,
> + SCAN_EXCEED_NONE_PTE,
> + SCAN_EXCEED_SWAP_PTE,
> + SCAN_EXCEED_SHARED_PTE,
> + SCAN_PTE_NON_PRESENT,
> + SCAN_PTE_UFFD,
> + SCAN_PTE_MAPPED_HUGEPAGE,
> + SCAN_LACK_REFERENCED_PAGE,
> + SCAN_PAGE_NULL,
> + SCAN_SCAN_ABORT,
> + SCAN_PAGE_COUNT,
> + SCAN_PAGE_LRU,
> + SCAN_PAGE_LOCK,
> + SCAN_PAGE_ANON,
> + SCAN_PAGE_LAZYFREE,
> + SCAN_PAGE_COMPOUND,
> + SCAN_ANY_PROCESS,
> + SCAN_VMA_NULL,
> + SCAN_VMA_CHECK,
> + SCAN_ADDRESS_RANGE,
> + SCAN_DEL_PAGE_LRU,
> + SCAN_ALLOC_HUGE_PAGE_FAIL,
> + SCAN_CGROUP_CHARGE_FAIL,
> + SCAN_TRUNCATED,
> + SCAN_PAGE_HAS_PRIVATE,
> + SCAN_STORE_FAILED,
> + SCAN_COPY_MC,
> + SCAN_PAGE_FILLED,
> + SCAN_PAGE_DIRTY_OR_WRITEBACK,
> +};
Are you planning to clean up scan_result? SCAN_SCAN_ABORT sounds funny,
SCAN_ANY_PROCESS means nothing, SCAN_COPY_MC might better be
COLLAPSE_COPY_MC.
Anyway, for this patch,
Reviewed-by: Zi Yan <ziy@nvidia.com>
--
Best Regards,
Yan, Zi
next prev parent reply other threads:[~2026-09-05 2:37 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-04 15:10 [PATCH 00/12] mm/collapse: separate a collapse from its callers Kiryl Shutsemau
2026-09-04 15:10 ` [PATCH 01/12] mm/khugepaged: drop redundant mm_struct pin in madvise_collapse() Kiryl Shutsemau
2026-09-04 15:58 ` Zi Yan
2026-09-04 15:10 ` [PATCH 02/12] mm/khugepaged: count collapses where khugepaged makes them Kiryl Shutsemau
2026-09-05 2:25 ` Zi Yan
2026-09-04 15:10 ` [PATCH 03/12] mm/khugepaged: rename mthp_present_ptes bitmap to eligible_ptes Kiryl Shutsemau
2026-09-05 2:28 ` Zi Yan
2026-09-04 15:10 ` [PATCH 04/12] mm/collapse: add collapse.h for the collapse interface Kiryl Shutsemau
2026-09-05 2:36 ` Zi Yan [this message]
2026-09-04 15:10 ` [PATCH 05/12] mm/collapse: state what a collapse may do in the policy Kiryl Shutsemau
2026-09-05 2:44 ` Zi Yan
2026-09-04 15:10 ` [PATCH 06/12] mm/collapse: drop the collapse_possible() wrapper Kiryl Shutsemau
2026-09-05 2:45 ` Zi Yan
2026-09-04 15:10 ` [PATCH 07/12] mm/collapse: name the per-table scan reset for what it resets Kiryl Shutsemau
2026-09-05 18:05 ` Zi Yan
2026-09-04 15:10 ` [PATCH 08/12] mm/collapse: separate scanning a PTE table from collapsing it Kiryl Shutsemau
2026-09-04 15:10 ` [PATCH 09/12] mm/collapse: open-code collapse_single_pmd() in its two callers Kiryl Shutsemau
2026-09-04 15:10 ` [PATCH 10/12] mm/collapse: work out the orders a VMA allows once per VMA Kiryl Shutsemau
2026-09-04 15:10 ` [PATCH 11/12] mm/collapse: declare the collapse interface in collapse.h Kiryl Shutsemau
2026-09-04 15:10 ` [PATCH 12/12] mm/collapse: implement MADV_COLLAPSE in madvise.c Kiryl Shutsemau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DL717O23OZOA.2UYSFURHZH0H2@nvidia.com \
--to=ziy@nvidia.com \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=jannh@google.com \
--cc=kas@kernel.org \
--cc=kernel-team@meta.com \
--cc=kirill@shutemov.name \
--cc=lance.yang@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=nico.pache@linux.dev \
--cc=ryan.roberts@arm.com \
--cc=usama.arif@linux.dev \
--cc=vbabka@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®