From: Daniel Phillips <phillips@arcor.de>
To: Anton Altaparmakov <aia21@cantab.net>
Cc: torvalds@transmeta.com (Linus Torvalds),
linux-kernel@vger.kernel.org (Linux Kernel),
viro@math.psu.edu (Alexander Viro)
Subject: Re: [BK-PATCH 1/3] Introduce fs/inode.c::ilookup().
Date: Mon, 9 Sep 2002 18:04:38 +0200 [thread overview]
Message-ID: <E17oR1i-0006pD-00@starship> (raw)
In-Reply-To: <5.1.0.14.2.20020909092430.00b14460@pop.cus.cam.ac.uk>
On Monday 09 September 2002 10:51, Anton Altaparmakov wrote:
> At 17:25 08/09/02, Daniel Phillips wrote:
> >On Saturday 07 September 2002 16:27, Anton Altaparmakov wrote:
> > > Linus,
> > >
> > > This is the first of three patches implementing ilookup(), a function
> > > to search the inode cache for an inode and if not found just return NULL.
> > >
> > > All response about ilookup() / ilookup5() was positive and several
> > > file systems would like to have such a function available.
> >
> >Well, one person thought it should be called ifind.
>
> Yes, you did. But that is too confusing with find_inode and friends IMHO
> and lookups are often termed _lookup and not _find, e.g.
> radix_tree_lookup(), simple_lookup(), d_lookup(), path_lookup(),
> cached_lookup()...
>
> Whereas there is not a single function in fs/ or mm/ ending in _find...
> They are all called find_blah and find_inode already exists... Having both
> find_inode and inode_find aka ifind seems weird, at least to me...
Why is ifind->find_inode weirder than iget->__iget?
> There was another suggestion on #kernel and that was to do:
>
> s/ilookup/ilookup_fast/
> s/ilookup5/ilookup/
>
> But if we do that we might as well carry on and also do:
>
> s/iget_locked/iget_locked_fast/
> s/iget5_locked/iget_locked/
>
> And another one was:
>
> s/ilookup5/ilookup_hash/
>
> and by extension / for consistency one could add:
>
> s/iget5_locked/iget_hash_locked/
> s/find_inode/find_inode_hash/
> s/find_inode_fast/find_inode/
> s/get_new_inode_fast/get_new_inode/
> s/get_new_inode/get_new_inode_hash/
>
> How about those?
Unless we're planning to break with tradition completely it should be
isomething, where something E {find, lookup, search}.
On another front, hash desperately wants to be ihash.
--
Daniel
next prev parent reply other threads:[~2002-09-09 15:57 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-09-07 14:27 Anton Altaparmakov
2002-09-08 16:25 ` Daniel Phillips
2002-09-09 8:51 ` Anton Altaparmakov
2002-09-09 16:04 ` Daniel Phillips [this message]
2002-09-08 17:04 ` Daniel Phillips
2002-09-09 8:59 ` Anton Altaparmakov
2002-09-09 15:55 ` Daniel Phillips
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=E17oR1i-0006pD-00@starship \
--to=phillips@arcor.de \
--cc=aia21@cantab.net \
--cc=linux-kernel@vger.kernel.org \
--cc=torvalds@transmeta.com \
--cc=viro@math.psu.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®