From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1762326AbYDPKYY (ORCPT ); Wed, 16 Apr 2008 06:24:24 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1756908AbYDPKYQ (ORCPT ); Wed, 16 Apr 2008 06:24:16 -0400 Received: from moutng.kundenserver.de ([212.227.126.174]:61081 "EHLO moutng.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756854AbYDPKYQ (ORCPT ); Wed, 16 Apr 2008 06:24:16 -0400 From: Bodo Eggert <7eggert@gmx.de> Subject: Re: [PATCH] Replace completions with semaphores To: Bart Van Assche , Andi Kleen , Peter Zijlstra , Roland Dreier , Ingo Molnar , Matthew Wilcox , Ingo Oeser , Daniel Walker , linux-kernel@vger.kernel.org, Linus Torvalds Reply-To: 7eggert@gmx.de Date: Wed, 16 Apr 2008 12:22:46 +0200 References: User-Agent: KNode/0.10.4 MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 7Bit Message-Id: X-be10.7eggert.dyndns.org-MailScanner-Information: See www.mailscanner.info for information X-be10.7eggert.dyndns.org-MailScanner: Found to be clean X-be10.7eggert.dyndns.org-MailScanner-From: 7eggert@gmx.de X-Provags-ID: V01U2FsdGVkX1/+6y2Yhd518ha8fAOwjEcOi/l1aB+E3rww37R Np6SzHuy7yk2/CaBsDA1e7cbgwHuNuQY10tjk+EN9D25LXCT7e jUpe2m5JJSo7ZbGMnnQTg== Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Bart Van Assche wrote: > On Mon, Apr 14, 2008 at 9:16 PM, Andi Kleen wrote: >> For me it sounds like you just want to rename semaphores to some other >> name that people don't use them for normal locking? > > Would it really be a good idea to give a synchronization concept that > behaves exactly like a semaphore another name than "semaphore" ? The > semaphore concept is well known and is taught in every computer > science course. What about calling it counting_semaphore, if it's to be used for this purpose?