From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756010Ab1GEQzD (ORCPT ); Tue, 5 Jul 2011 12:55:03 -0400 Received: from devils.ext.ti.com ([198.47.26.153]:37638 "EHLO devils.ext.ti.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754017Ab1GEQzA convert rfc822-to-8bit (ORCPT ); Tue, 5 Jul 2011 12:55:00 -0400 From: "Grosen, Mark" To: "Nori, Sekhar" , Sergei Shtylyov CC: Ohad Ben-Cohen , davinci-linux-open-source , Arnd Bergmann , Brian Swetland , Rusty Russell , "linux-kernel@vger.kernel.org" , Grant Likely , "akpm@linux-foundation.org" , "linux-omap@vger.kernel.org" , "linux-arm-kernel@lists.infradead.org" Subject: RE: [RFC 5/8] remoteproc: add davinci implementation Thread-Topic: [RFC 5/8] remoteproc: add davinci implementation Thread-Index: AQHML+P0Hfr3a08OpEW7Q/TK8TF6jpTLaEUAgAB6tVCAARO0AIAACGCAgASPneCAC7mBkIAAv+Jw Date: Tue, 5 Jul 2011 16:54:14 +0000 Message-ID: References: <1308640714-17961-1-git-send-email-ohad@wizery.com> <1308640714-17961-6-git-send-email-ohad@wizery.com> <4E035B78.3080200@mvista.com> <4E04A9AE.3030801@mvista.com> In-Reply-To: Accept-Language: en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [128.247.5.50] Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > From: Nori, Sekhar > Sent: Monday, July 04, 2011 10:30 PM ... > > > https://patchwork.kernel.org/patch/662941/ > > > > Yes, I like this idea - much cleaner. For example, the start() method > > becomes (pseudo-code): > > > > start() > > { > > /* bootaddrreg derived from platform data */ > > bootaddrreg = boot_address; > > > > clk_enable(); > > } > > > > Referring to your patch above, would it be better to just pass > > the flags into the davinci_psc_config() function rather than breaking > out more > > arguments for each flag? > > I did dwell on this quite a bit while writing that > patch, but finally decided on passing an argument > instead since I was not sure if there are going > to be more modifiers required. > > Now that you have the need for one more flag, I > think we should go ahead and pass the flags directly > to davinci_psc_config(). My original patch is not > upstream yet. I will re-spin it and you can build > on top of it. Thanks, Sekhar, this sounds good. I'll look for your patch and utilize it in the next rev of this patch. Mark