From: "Per Persson" <per.persson@gnosjo.pp.se>
To: <linux-kernel@vger.kernel.org>
Subject: [PATCH] triple_down in fs.h
Date: Thu, 18 Oct 2001 15:10:34 +0200 [thread overview]
Message-ID: <NDBBJMOHILCIIKFHCBHAAELPCAAA.per.persson@gnosjo.pp.se> (raw)
[-- Attachment #1: Type: text/plain, Size: 704 bytes --]
First, I'd like to send a thank to the Linux community from my father who
passed away this morning. He was very impressed by Linux and other free or
semi-free software like Samba, MySQL, GIMP and StarOffice.
Now to the patch:
I've made a couple of minor (but important?) changes in my patch of
{double,triple}_down in include/linux/fs.h.
Changes:
1) Added #undef's of my macros.
Thanks to Mitchell Blank Jr who proposed this change.
Also thanks to Yaroslav Popovitch who told me he had got an error caused
by the lack of #undef's.
2) Changed the names of the macros to further minimize the risk for name
collision; exch -> exch_vars, sort -> sort_vars.
Per Persson
per.persson@gnosjo.pp.se
[-- Attachment #2: fs.h.patch --]
[-- Type: application/octet-stream, Size: 2667 bytes --]
--- include/linux/fs.h.orig Sat Sep 29 22:10:21 2001
+++ include/linux/fs.h Mon Oct 8 13:03:24 2001
@@ -1476,14 +1476,27 @@
/*
* Whee.. Deadlock country. Happily there are only two VFS
* operations that does this..
+ *
+ * {double,triple}_down modified by Per Persson in September, 2001
*/
+
+#define exch_vars(x,y) \
+do { \
+ typeof(x) __tmp__ = (x); \
+ (x) = (y); \
+ (y) = __tmp__; \
+ \
+ (void)(&(x) == &(y)) /* typecheck */ \
+} while(0)
+
+#define sort_vars(x,y) \
+if((x) > (y)) \
+ exch_vars((x), (y))
+
static inline void double_down(struct semaphore *s1, struct semaphore *s2)
{
if (s1 != s2) {
- if ((unsigned long) s1 < (unsigned long) s2) {
- struct semaphore *tmp = s2;
- s2 = s1; s1 = tmp;
- }
+ sort_vars((ulong) s2, (ulong) s1); // s2 < s1
down(s1);
}
down(s2);
@@ -1493,9 +1506,11 @@
* Ewwwwwwww... _triple_ lock. We are guaranteed that the 3rd argument is
* not equal to 1st and not equal to 2nd - the first case (target is parent of
* source) would be already caught, the second is plain impossible (target is
- * its own parent and that case would be caught even earlier). Very messy.
- * I _think_ that it works, but no warranties - please, look it through.
- * Pox on bloody lusers who mandated overwriting rename() for directories...
+ * its own parent and that case would be caught even earlier).
+ *
+ * Hopefully it does the same thing as the old code,
+ * but in a cleaner and more efficient way.
+ * /Per
*/
static inline void triple_down(struct semaphore *s1,
@@ -1503,33 +1518,17 @@
struct semaphore *s3)
{
if (s1 != s2) {
- if ((unsigned long) s1 < (unsigned long) s2) {
- if ((unsigned long) s1 < (unsigned long) s3) {
- struct semaphore *tmp = s3;
- s3 = s1; s1 = tmp;
- }
- if ((unsigned long) s1 < (unsigned long) s2) {
- struct semaphore *tmp = s2;
- s2 = s1; s1 = tmp;
- }
- } else {
- if ((unsigned long) s1 < (unsigned long) s3) {
- struct semaphore *tmp = s3;
- s3 = s1; s1 = tmp;
- }
- if ((unsigned long) s2 < (unsigned long) s3) {
- struct semaphore *tmp = s3;
- s3 = s2; s2 = tmp;
- }
- }
+ sort_vars((ulong) s2, (ulong) s1); // s2 < s1
+ sort_vars((ulong) s3, (ulong) s1); // s3 < s1
down(s1);
- } else if ((unsigned long) s2 < (unsigned long) s3) {
- struct semaphore *tmp = s3;
- s3 = s2; s2 = tmp;
}
+ sort_vars((ulong) s3, (ulong) s2); // s2 > s3
down(s2);
down(s3);
}
+
+#undef exch_vars
+#undef sort_vars
static inline void double_up(struct semaphore *s1, struct semaphore *s2)
{
next reply other threads:[~2001-10-18 13:17 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2001-10-18 13:10 Per Persson [this message]
-- strict thread matches above, loose matches on Subject: below --
2001-10-02 19:42 Per Persson
2001-09-24 14:50 Per Persson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=NDBBJMOHILCIIKFHCBHAAELPCAAA.per.persson@gnosjo.pp.se \
--to=per.persson@gnosjo.pp.se \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®