Hi, I got strange thing with kernel 2.4.22-pre2; 2.4.22-pre6-ac1. When running from cdrom use initrd. With some boxes it works as normal but for some I got the message FAT: bogus logical sector size 40511 Unable to mount root fs on 01:00 of course the system halted. It is not an oop but nothing it can do :-) The problem did not happen with 2.4.19, so I tried to boot my cd wiht that version and get dmesg for system hardware information attached to this email. Best regard, Steve Kieu PGP Key http://skieu.myftp.org/pub/steve-pub.key