From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1161210AbWFVTpM (ORCPT ); Thu, 22 Jun 2006 15:45:12 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1161211AbWFVTpL (ORCPT ); Thu, 22 Jun 2006 15:45:11 -0400 Received: from omx1-ext.sgi.com ([192.48.179.11]:62904 "EHLO omx1.americas.sgi.com") by vger.kernel.org with ESMTP id S1030355AbWFVTpH (ORCPT ); Thu, 22 Jun 2006 15:45:07 -0400 Date: Thu, 22 Jun 2006 12:44:51 -0700 (PDT) From: Christoph Lameter To: Pekka J Enberg cc: linux-kernel@vger.kernel.org, Marcelo Tosatti , "Paul E. McKenney" , Nick Piggin , Theodore Tso , Dave Chinner , Andi Kleen Subject: Re: [PATCH 4/4] Slab Reclaim logic In-Reply-To: Message-ID: References: <20060619184651.23130.62875.sendpatchset@schroedinger.engr.sgi.com> <20060619184712.23130.65271.sendpatchset@schroedinger.engr.sgi.com> MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 22 Jun 2006, Pekka J Enberg wrote: > Some coding style comments below. > > > +extern long kmem_cache_reclaim(struct kmem_cache *, gfp_t flags, unsigned long); > > The parameter name is redundant. Ok. > > > +static int try_reclaim_one(kmem_cache_t *cachep, struct kmem_list3 *l3, > > + struct list_head *list, unsigned short marker) > > Please use struct kmem_cache instead of the typedef. Better name for l3 > would be nice. l3 is a very good name. > > +{ > > + int nr_freed = 0; > > s/nr_freed/ret/ ret is non descriptive. nr_freed is describing what the purpose of the variable is. > > + while (nr_freed < slabs_to_free) { > > + int x; > > s/x/nr_freed/ Would shadow variable.