mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Randy Dunlap <randy.dunlap@oracle.com>
Cc: Tim Schmielau <tim@physik3.uni-rostock.de>,
	Jan Engelhardt <jengelh@linux01.gwdg.de>,
	Stefan Richter <stefanr@s5r6.in-berlin.de>,
	Zach Brown <zach.brown@oracle.com>,
	Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()
Date: Sun, 17 Dec 2006 13:25:16 -0500 (EST)	[thread overview]
Message-ID: <Pine.LNX.4.64.0612171324350.30593@localhost.localdomain> (raw)
In-Reply-To: <20061217102741.58d2c425.randy.dunlap@oracle.com>

On Sun, 17 Dec 2006, Randy Dunlap wrote:

> On Sun, 17 Dec 2006 13:13:59 -0500 (EST) Robert P. J. Day wrote:
>
> >
> >   so here's the end result of my experiment to replace unnecessary
> > code snippets with an invocation of the ARRAY_SIZE() macro from
> > include/linux/kernel.h.  i've attached the script that i ran on the
> > entire tree, then (after adding al viro's connector patch), did:
> >
> >   $ make allyesconfig	# for the stress factor
> >   $ make
> >
> > to see what would happen.
> >
> >   amazingly, the compile worked all the way down to:
> >
> >   AS      arch/i386/boot/bootsect.o
> >   LD      arch/i386/boot/bootsect
> >   AS      arch/i386/boot/setup.o
> >   LD      arch/i386/boot/setup
> >   AS      arch/i386/boot/compressed/head.o
> >   CC      arch/i386/boot/compressed/misc.o
> >   OBJCOPY arch/i386/boot/compressed/vmlinux.bin
> >   HOSTCC  arch/i386/boot/compressed/relocs
> > arch/i386/boot/compressed/relocs.c: In function 'sym_type':
> > arch/i386/boot/compressed/relocs.c:72: warning: implicit declaration of function 'ARRAY_SIZE'
>
> That's a userspace program and shouldn't use kernel.h.

ah, quite right, my bad.  eggnog hangover.

rday

  reply	other threads:[~2006-12-17 18:30 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-12-13 19:58 Robert P. J. Day
     [not found] ` <2F8F687E-C5E5-4F7D-9585-97DA97AE1376@oracle.com>
2006-12-14 22:27   ` Robert P. J. Day
2006-12-14 23:13     ` Stefan Richter
2006-12-15 10:36       ` Jan Engelhardt
2006-12-15 20:48         ` Robert P. J. Day
2006-12-15 22:54           ` Tim Schmielau
2006-12-16 11:59             ` Robert P. J. Day
2006-12-16 13:30               ` Tim Schmielau
2006-12-16 13:55                 ` Robert P. J. Day
2006-12-17 18:13             ` Robert P. J. Day
2006-12-17 18:27               ` Randy Dunlap
2006-12-17 18:25                 ` Robert P. J. Day [this message]
2006-12-14 23:16 ` Miguel Ojeda
2006-12-15  0:12   ` Robert P. J. Day
2006-12-16  8:40 ` Pavel Machek
2006-12-16 13:09   ` Robert P. J. Day
2006-12-16 18:14     ` Jan Engelhardt
2006-12-17 11:44       ` Stefan Richter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.64.0612171324350.30593@localhost.localdomain \
    --to=rpjday@mindspring.com \
    --cc=jengelh@linux01.gwdg.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=randy.dunlap@oracle.com \
    --cc=stefanr@s5r6.in-berlin.de \
    --cc=tim@physik3.uni-rostock.de \
    --cc=zach.brown@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®