From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Randy Dunlap <rdunlap@xenotime.net>
Cc: Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] Rename FIELD_SIZEOF to MEMBER_SIZE and use in source tree.
Date: Fri, 22 Dec 2006 12:36:41 -0500 (EST) [thread overview]
Message-ID: <Pine.LNX.4.64.0612221236360.7893@localhost.localdomain> (raw)
In-Reply-To: <20061222092752.76af799b.rdunlap@xenotime.net>
On Fri, 22 Dec 2006, Randy Dunlap wrote:
> On Fri, 22 Dec 2006 10:34:09 -0500 (EST) Robert P. J. Day wrote:
>
> >
> > Rename the macro FIELD_SIZEOF() in include/linux/kernel.h to
> > MEMBER_SIZE(), and make a number of replacements in the source tree
> > where that macro simplified the code.
>
> Hi,
>
> Your CodingStyle ch. 17 additions also need to be updated
> if/when they are merged (since they refer to FIELD_SIZEOF()).
> Did Andrew add that to -mm? I don't recall.
yes, that went in already. re-reading christopher's recent posting,
he seems fairly convinced that that macro should be called either
SIZEOF_FIELD or FIELD_SIZE. i'm happy with either choice, so someone
else can make the decision and i'll go with it.
rday
next prev parent reply other threads:[~2006-12-22 17:43 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-22 15:34 Robert P. J. Day
2006-12-22 17:27 ` Randy Dunlap
2006-12-22 17:36 ` Robert P. J. Day [this message]
2006-12-22 23:21 ` Jan Engelhardt
2006-12-22 23:31 ` Gene Heskett
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0612221236360.7893@localhost.localdomain \
--to=rpjday@mindspring.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rdunlap@xenotime.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®