From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933175AbXDFWb0 (ORCPT ); Fri, 6 Apr 2007 18:31:26 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S933176AbXDFWb0 (ORCPT ); Fri, 6 Apr 2007 18:31:26 -0400 Received: from x35.xmailserver.org ([64.71.152.41]:53154 "EHLO x35.xmailserver.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933175AbXDFWbY (ORCPT ); Fri, 6 Apr 2007 18:31:24 -0400 X-AuthUser: davidel@xmailserver.org Date: Fri, 6 Apr 2007 15:31:22 -0700 (PDT) From: Davide Libenzi X-X-Sender: davide@alien.or.mcafeemobile.com To: Linus Torvalds cc: Ingo Molnar , "Eric W. Biederman" , Oleg Nesterov , Robin Holt , Chris Snook , Linux Kernel Mailing List , Jack Steiner Subject: Re: init's children list is long and slows reaping children. In-Reply-To: Message-ID: References: <46159987.6090006@redhat.com> <20070406104301.GB19755@lnx-holt.americas.sgi.com> <20070406163100.GA554@tv-sign.ru> <20070406191945.GA18255@elte.hu> X-GPG-FINGRPRINT: CFAE 5BEE FD36 F65E E640 56FE 0974 BF23 270F 474E X-GPG-PUBLIC_KEY: http://www.xmailserver.org/davidel.asc MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 6 Apr 2007, Linus Torvalds wrote: > On Fri, 6 Apr 2007, Davide Libenzi wrote: > > > > > > or lets just face it and name it what it is: process_struct ;-) > > > > That'd be fine too! Wonder if Linus would swallow a rename patch like > > that... > > I don't really see the point. It's not even *true*. A "process" includes > more than the shared signal-handling - it would include files and fs etc > too. > > So it's actually *more* correct to call it the shared signal state than it > would be to call it "process" state. But "signal" has *nothing* to do with what the structure store nowadays, really. It's a pool of "things" that are not Linux task specific. IMO something like "struct task_shared_ctx" or simply "struct task_shared" would better fit the nature of the thing. - Davide