From: "Robert P. J. Day" <rpjday@mindspring.com>
To: David Miller <davem@davemloft.net>
Cc: linux-kernel@vger.kernel.org
Subject: Re: dead CONFIG_ variables: net/ipv4/
Date: Tue, 29 May 2007 16:14:30 -0400 (EDT) [thread overview]
Message-ID: <Pine.LNX.4.64.0705291611460.6478@localhost.localdomain> (raw)
In-Reply-To: <20070529.131013.97289989.davem@davemloft.net>
On Tue, 29 May 2007, David Miller wrote:
> From: "Robert P. J. Day" <rpjday@mindspring.com>
> Date: Wed, 2 May 2007 17:15:01 -0400 (EDT)
>
> >
> > again, this list contains some CONFIG_ variables that aren't
> > technically dead, but *really* should be renamed to not be confused
> > with Kconfig variables. there are, however, legitimately dead ones in
> > the following in places:
> >
> > $ ../dead_config.sh net/ipv4
> > ========== IP_FIB_TRIE_STATS ==========
> > net/ipv4/fib_trie.c:#undef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#ifdef CONFIG_IP_FIB_TRIE_STATS
> > net/ipv4/fib_trie.c:#endif /* CONFIG_IP_FIB_TRIE_STATS */
>
> Robert Olsson uses this for statistics collection by turning
> that #undef there into a #define and other developers could
> use this too.
>
> Therefore I'm reluctant to remove this for now.
there's lots of that sort of thing in the kernel -- the only point i'd
make is that it seems typical to reserve the prefix "CONFIG_" strictly
for those variables that are set via Kconfig files. it just makes the
namespace cleaner, that's all. otherwise, that variable is going to
come up continually in any script like mine that's searching for
possible dead Kconfig variables.
> > ========== IP_PIMSM ==========
> > net/ipv4/ipmr.c:#define CONFIG_IP_PIMSM 1
as is this one, etc, etc.
rday
--
========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA
http://fsdev.net/wiki/index.php?title=Main_Page
========================================================================
prev parent reply other threads:[~2007-05-29 20:15 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-05-02 21:15 Robert P. J. Day
2007-05-03 3:23 ` Patrick McHardy
2007-05-29 20:10 ` David Miller
2007-05-29 20:14 ` Robert P. J. Day [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0705291611460.6478@localhost.localdomain \
--to=rpjday@mindspring.com \
--cc=davem@davemloft.net \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®