From: Hugh Dickins <hugh@veritas.com>
To: Jens Axboe <jens.axboe@oracle.com>
Cc: Sitsofe Wheeler <sitsofe@yahoo.com>,
Kay Sievers <kay.sievers@vrfy.org>,
Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>,
linux-kernel@vger.kernel.org, linux-ide@vger.kernel.org,
Alan Cox <alan@lxorguk.ukuu.org.uk>
Subject: Re: [PATCH] block: export SSD/non-rotational queue flag through sysfs
Date: Tue, 6 Jan 2009 19:46:54 +0000 (GMT) [thread overview]
Message-ID: <Pine.LNX.4.64.0901061920540.4888@blonde.anvils> (raw)
In-Reply-To: <49628720.6050101@yahoo.com>
On Mon, 5 Jan 2009, Sitsofe Wheeler wrote:
> Kay Sievers wrote:
> > On Mon, Jan 5, 2009 at 19:54, Jens Axboe <jens.axboe@oracle.com> wrote:
> > > On Mon, Jan 05 2009, Bartlomiej Zolnierkiewicz wrote:
> >
> > > > +static struct queue_sysfs_entry queue_nonrot_entry = {
> > > > + .attr = {.name = "nonrot", .mode = S_IRUGO | S_IWUSR },
> > > > + .show = queue_nonrot_show,
> > > > + .store = queue_nonrot_store,
> > > > +};
> > > > +
> > > Lets please use a better name for export reasons, non-rotational is a
> > > lot better. Nobody will know what nonrot means :-)
> >
> > What's that negation good for? Can't we just have "rotational", like
> > we have "removable" and not "non-removable"? :)
>
> How about cheapseek? fastrandom? flash? ssd? However the internal flag is
> called QUEUE_FLAG_NONROT so it kind of makes sense just to leave it as
> nonrot...
Many thanks to Bart (and Alan) for this patch:
just what I'd been hoping for when I wrote (25 Nov)
But how to get my SD card, accessed by USB card reader, reported as NONROT?
However, may I join Kai in protesting the negative boolean flag?
I've never quite recovered from CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER;
and while this is obviously nowhere near the same league, I'd much
rather stay well away.
I don't like the "nonrot" or "rotational" at all myself: though you
may be able to advance convincing arguments why it's not accidental,
isn't the rotationality pretty much incidental to whether the seeks
are cheap? I imagine a long bar loaded with data, which zips back
and forth through the reader: nothing rotational, but expensive seeks.
(I had been going to propose magnetic tape, but the rotation of the
spools muddies that argument.)
When doing the swap patch, though I toed the line with SWP_NONROT
for quite a while (I do dislike using different names for the same
notion at different levels), I couldn't stomach it in the end, and
went for SWP_SOLIDSTATE.
But I particularly like Sitsofe's "cheapseek". Is that is an accurate
representation of how the I/O schedulers treat it? then please can we
name the user-visible sysfs file accordingly?
The kernel-internal name is much less important, though I'd be pretty
happy to have CHEAPSEEK instead of NONROT throughout there too.
Oh, another problem with NONROT: flash rots a lot sooner than disk,
doesn't it?
Hugh
next prev parent reply other threads:[~2009-01-06 19:47 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <fa.+H1UnEqOmFht/vMPmVy8ellbQi0@ifi.uio.no>
[not found] ` <fa.RLz5WOGorLui5GRkc963Ww1kXqg@ifi.uio.no>
[not found] ` <fa.x4ejZ7Kj7ZZRu88Sond1Cap6XxY@ifi.uio.no>
2009-01-05 22:18 ` Sitsofe Wheeler
2009-01-06 1:25 ` Stefan Richter
2009-01-06 19:46 ` Hugh Dickins [this message]
2009-01-05 18:52 Bartlomiej Zolnierkiewicz
2009-01-05 18:54 ` Jens Axboe
2009-01-05 19:02 ` Bartlomiej Zolnierkiewicz
2009-01-05 19:08 ` James Bottomley
2009-01-05 19:10 ` Jens Axboe
2009-01-05 19:08 ` Jens Axboe
2009-01-05 21:47 ` Kay Sievers
2009-01-06 7:35 ` Jens Axboe
2009-01-07 10:39 ` Michael Tokarev
2009-01-07 11:19 ` Jens Axboe
2009-01-07 15:34 ` James Bottomley
2009-01-15 5:37 ` Tejun Heo
2009-01-15 15:07 ` Greg Freemyer
2009-01-15 15:46 ` Tejun Heo
2009-01-15 16:06 ` James Bottomley
2009-01-15 18:55 ` Grant Grundler
2009-01-15 19:00 ` James Bottomley
2009-01-15 22:45 ` Grant Grundler
2009-01-15 23:17 ` James Bottomley
2009-01-15 23:50 ` Hugh Dickins
2009-01-15 23:57 ` Michael Tokarev
2009-01-16 0:36 ` James Bottomley
2009-01-16 3:52 ` Dongjun Shin
2009-01-16 6:48 ` Jens Axboe
2009-01-16 6:48 ` Jens Axboe
2009-02-03 12:32 ` Pierre Ossman
2009-01-16 6:43 ` Jens Axboe
2009-01-05 18:58 ` Alan Cox
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0901061920540.4888@blonde.anvils \
--to=hugh@veritas.com \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=bzolnier@gmail.com \
--cc=jens.axboe@oracle.com \
--cc=kay.sievers@vrfy.org \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sitsofe@yahoo.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®