From: Guennadi Liakhovetski <g.liakhovetski@gmx.de>
To: Henrique Camargo <henrique@henriquecamargo.com>
Cc: "Aguirre, Sergio" <saaguirre@ti.com>,
Mauro Carvalho Chehab <mchehab@infradead.org>,
"Karicheri, Muralidharan" <m-karicheri2@ti.com>,
"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] mt9t031: Fixes field names that changed
Date: Wed, 25 Aug 2010 00:23:20 +0200 (CEST) [thread overview]
Message-ID: <Pine.LNX.4.64.1008250020540.19669@axis700.grange> (raw)
In-Reply-To: <1282243015.2213.13.camel@lemming>
On Thu, 19 Aug 2010, Henrique Camargo wrote:
> If CONFIG_VIDEO_ADV_DEBUG was set, the driver failed to compile
> because the fields get_register and set_register changed names to
> g_register and s_register in the struct v4l2_subdev_core_ops.
>
> Signed-off-by: Henrique Camargo <henrique@henriquecamargo.com>
> ---
> drivers/media/video/mt9t031.c | 4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/media/video/mt9t031.c b/drivers/media/video/mt9t031.c
> index 716fea6..f3d1995 100644
> --- a/drivers/media/video/mt9t031.c
> +++ b/drivers/media/video/mt9t031.c
> @@ -499,8 +499,8 @@ static const struct v4l2_subdev_core_ops mt9t031_core_ops = {
> .g_ctrl = mt9t031_get_control,
> .s_ctrl = mt9t031_set_control,
> #ifdef CONFIG_VIDEO_ADV_DEBUG
> - .get_register = mt9t031_get_register,
> - .set_register = mt9t031_set_register,
> + .g_register = mt9t031_get_register,
> + .s_register = mt9t031_set_register,
> #endif
> };
>
> --
> 1.7.0.4
I might be missing something obvious, but I do not understand against
which tree / version is this patch? I don't see this problem in the
mainline.
Thanks
Guennadi
---
Guennadi Liakhovetski, Ph.D.
Freelance Open-Source Software Developer
http://www.open-technology.de/
prev parent reply other threads:[~2010-08-24 22:23 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-08-19 18:36 Henrique Camargo
2010-08-24 22:23 ` Guennadi Liakhovetski [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.1008250020540.19669@axis700.grange \
--to=g.liakhovetski@gmx.de \
--cc=henrique@henriquecamargo.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=m-karicheri2@ti.com \
--cc=mchehab@infradead.org \
--cc=saaguirre@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®