mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sean Christopherson <seanjc@google.com>
To: Borislav Petkov <bp@alien8.de>
Cc: Andy Lutomirski <luto@amacapital.net>,
	Masami Hiramatsu <mhiramat@kernel.org>, X86 ML <x86@kernel.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v1 01/19] x86/insn: Rename insn_decode() to insn_decode_regs()
Date: Mon, 28 Dec 2020 09:16:50 -0800	[thread overview]
Message-ID: <X+oTAiMqfoDe1GBg@google.com> (raw)
In-Reply-To: <20201223174233.28638-2-bp@alien8.de>

On Wed, Dec 23, 2020, Borislav Petkov wrote:
> From: Borislav Petkov <bp@suse.de>
> 
> Rename insn_decode() to insn_decode_regs() to denote that it receives
> regs as param and free the name for a more generic version of the
> function.

Can we add a preposition in there, e.g. insn_decode_from_regs() or
insn_decode_with_regs()?  For me, "decode_regs" means "decode the register
operands of the instruction".

  reply	other threads:[~2020-12-28 17:18 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-23 17:42 [PATCH v1 00/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 01/19] x86/insn: Rename insn_decode() to insn_decode_regs() Borislav Petkov
2020-12-28 17:16   ` Sean Christopherson [this message]
2020-12-29 19:36     ` Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 02/19] x86/insn: Add @buf_len param to insn_init() kernel-doc comment Borislav Petkov
2020-12-28  1:44   ` Masami Hiramatsu
2020-12-23 17:42 ` [PATCH v1 03/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-12-28  1:15   ` Masami Hiramatsu
2020-12-29 20:06     ` Borislav Petkov
2020-12-30  9:00       ` Masami Hiramatsu
2020-12-30  9:28         ` Borislav Petkov
2021-01-06  5:21           ` Masami Hiramatsu
2021-01-08 18:59             ` Borislav Petkov
2021-01-12 11:34               ` Masami Hiramatsu
2021-01-13 18:06                 ` Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 04/19] x86/insn-eval: Handle return values from the decoder Borislav Petkov
2020-12-28 18:51   ` Sean Christopherson
2020-12-28 19:06     ` Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 05/19] x86/boot/compressed/sev-es: Convert to insn_decode() Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 06/19] perf/x86/intel/ds: Check insn_get_length() retval Borislav Petkov
2021-01-04 13:19   ` Peter Zijlstra
2021-01-19 10:40     ` Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 07/19] perf/x86/intel/ds: Check return values of insn decoder functions Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 08/19] x86/alternative: Use insn_decode() Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 09/19] x86/mce: Convert to insn_decode() Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 10/19] x86/kprobes: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 11/19] x86/sev-es: " Borislav Petkov
2020-12-25 10:50   ` kernel test robot
2020-12-25 12:33     ` Borislav Petkov
2020-12-28 19:15       ` Sean Christopherson
2021-01-21 16:58         ` Borislav Petkov
2021-01-21 22:35           ` Sean Christopherson
2020-12-23 17:42 ` [PATCH v1 12/19] x86/traps: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 13/19] x86/uprobes: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 14/19] x86/tools/insn_decoder_test: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 15/19] tools/objtool: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 16/19] x86/tools/insn_sanity: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 17/19] tools/perf: " Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 18/19] x86/insn: Remove kernel_insn_init() Borislav Petkov
2020-12-23 17:42 ` [PATCH v1 19/19] x86/insn: Make insn_complete() static Borislav Petkov
2020-12-27 15:26 ` [PATCH v1 00/19] x86/insn: Add an insn_decode() API Tom Lendacky
2021-02-03 12:00   ` Borislav Petkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=X+oTAiMqfoDe1GBg@google.com \
    --to=seanjc@google.com \
    --cc=bp@alien8.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=mhiramat@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome