mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Lee Jones <lee@kernel.org>
To: Neil Armstrong <neil.armstrong@linaro.org>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [PATCH] mfd: rk808: permit having multiple PMIC instances
Date: Mon, 31 Oct 2022 15:22:02 +0000	[thread overview]
Message-ID: <Y1/oGhqPZNvyVTkY@google.com> (raw)
In-Reply-To: <20221025-rk808-multi-v1-0-c07b7cf3fd67@linaro.org>

On Tue, 25 Oct 2022, Neil Armstrong wrote:

> This set each cells id to -1 to allow multiple instances of
> each cell in case multiple PMICs handled by the rk808 driver
> are probed.
> 
> This fixes probing a RK818 and a RK817 on the Odroid Go Ultra
> devices.

No issue with the premise Neil, but would you be kind enough to use
the define provided (PLATFORM_DEVID_NONE) instead of the magic number
please?

> Signed-off-by: Neil Armstrong <neil.armstrong@linaro.org>
> ---
> Cc: Lee Jones <lee@kernel.org>
> Cc: linux-kernel@vger.kernel.org
> ---
>  drivers/mfd/rk808.c | 26 ++++++++++++++++----------
>  1 file changed, 16 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/mfd/rk808.c b/drivers/mfd/rk808.c
> index e00da7c7e3b1..b9cfd249912d 100644
> --- a/drivers/mfd/rk808.c
> +++ b/drivers/mfd/rk808.c
> @@ -137,58 +137,64 @@ static const struct resource rk817_charger_resources[] = {
>  };
>  
>  static const struct mfd_cell rk805s[] = {
> -	{ .name = "rk808-clkout", },
> -	{ .name = "rk808-regulator", },
> -	{ .name = "rk805-pinctrl", },
> +	{ .name = "rk808-clkout", .id = -1, },
> +	{ .name = "rk808-regulator", .id = -1, },
> +	{ .name = "rk805-pinctrl", .id = -1, },
>  	{
>  		.name = "rk808-rtc",
>  		.num_resources = ARRAY_SIZE(rtc_resources),
>  		.resources = &rtc_resources[0],
> +		.id = -1,
>  	},
>  	{	.name = "rk805-pwrkey",
>  		.num_resources = ARRAY_SIZE(rk805_key_resources),
>  		.resources = &rk805_key_resources[0],
> +		.id = -1,
>  	},
>  };
>  
>  static const struct mfd_cell rk808s[] = {
> -	{ .name = "rk808-clkout", },
> -	{ .name = "rk808-regulator", },
> +	{ .name = "rk808-clkout", .id = -1, },
> +	{ .name = "rk808-regulator", .id = -1, },
>  	{
>  		.name = "rk808-rtc",
>  		.num_resources = ARRAY_SIZE(rtc_resources),
>  		.resources = rtc_resources,
> +		.id = -1,
>  	},
>  };
>  
>  static const struct mfd_cell rk817s[] = {
> -	{ .name = "rk808-clkout",},
> -	{ .name = "rk808-regulator",},
> +	{ .name = "rk808-clkout", .id = -1, },
> +	{ .name = "rk808-regulator", .id = -1, },
>  	{
>  		.name = "rk805-pwrkey",
>  		.num_resources = ARRAY_SIZE(rk817_pwrkey_resources),
>  		.resources = &rk817_pwrkey_resources[0],
> +		.id = -1,
>  	},
>  	{
>  		.name = "rk808-rtc",
>  		.num_resources = ARRAY_SIZE(rk817_rtc_resources),
>  		.resources = &rk817_rtc_resources[0],
> +		.id = -1,
>  	},
> -	{ .name = "rk817-codec",},
> +	{ .name = "rk817-codec", .id = -1, },
>  	{
>  		.name = "rk817-charger",
>  		.num_resources = ARRAY_SIZE(rk817_charger_resources),
>  		.resources = &rk817_charger_resources[0],
> +		.id = -1,
>  	},
>  };
>  
>  static const struct mfd_cell rk818s[] = {
> -	{ .name = "rk808-clkout", },
> -	{ .name = "rk808-regulator", },
> +	{ .name = "rk808-regulator", .id = -1, },
>  	{
>  		.name = "rk808-rtc",
>  		.num_resources = ARRAY_SIZE(rtc_resources),
>  		.resources = rtc_resources,
> +		.id = -1,
>  	},
>  };
>  
> 
> ---
> base-commit: 247f34f7b80357943234f93f247a1ae6b6c3a740
> change-id: 20221025-rk808-multi-65dd03a92705
> 
> Best regards,

-- 
Lee Jones [李琼斯]

  reply	other threads:[~2022-10-31 15:22 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-10-25  9:54 Neil Armstrong
2022-10-31 15:22 ` Lee Jones [this message]
2022-10-31 15:30   ` Neil Armstrong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y1/oGhqPZNvyVTkY@google.com \
    --to=lee@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=neil.armstrong@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®