From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 3964EC10F1B for ; Tue, 27 Dec 2022 07:26:15 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S229540AbiL0H0O (ORCPT ); Tue, 27 Dec 2022 02:26:14 -0500 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:44616 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229564AbiL0H0L (ORCPT ); Tue, 27 Dec 2022 02:26:11 -0500 Received: from dfw.source.kernel.org (dfw.source.kernel.org [139.178.84.217]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 0B392C2F for ; Mon, 26 Dec 2022 23:26:09 -0800 (PST) Received: from smtp.kernel.org (relay.kernel.org [52.25.139.140]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by dfw.source.kernel.org (Postfix) with ESMTPS id 2D40D60F90 for ; Tue, 27 Dec 2022 07:26:09 +0000 (UTC) Received: by smtp.kernel.org (Postfix) with ESMTPSA id E30EEC433D2; Tue, 27 Dec 2022 07:26:07 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=linuxfoundation.org; s=korg; t=1672125968; bh=AOJFSwK9Q17i4sr9UnfKIJSKmUMHPVexbzEarKXsvMQ=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=P/w5mhDcdIAH77uRl7RtHJKT+KjtNTdjhnUihc/mLaWbli7qk50UKHyjDcGPkl/iE jkES39zqQrfk5fmGg08eZNzMl3chLLOrqunLoGm/0ty6H6bgQCwUOQVb5BCAjMT0xg WYIeApbGSoj+LGX9tNEuGqOMJdQkq3IaF4h0MZZo= Date: Tue, 27 Dec 2022 08:26:05 +0100 From: Greg KH To: Oded Gabbay Cc: airlied@gmail.com, linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org Subject: Re: [PATCH 1/2] habanalabs/uapi: move uapi file to drm Message-ID: References: <20221226213227.26953-1-ogabbay@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20221226213227.26953-1-ogabbay@kernel.org> Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Dec 26, 2022 at 11:32:26PM +0200, Oded Gabbay wrote: > Move the habanalabs.h uapi file from include/uapi/misc to > include/uapi/drm, and rename it to habanalabs_accel.h. > > This is required before moving the actual driver to the accel > subsystem. What requires this? Isn't this going to break userspace code? thanks, greg k-h