From: Deepak R Varma <drv@mailo.com>
To: Rodrigo Vivi <rodrigo.vivi@intel.com>
Cc: Jani Nikula <jani.nikula@linux.intel.com>,
Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>,
David Airlie <airlied@gmail.com>, Daniel Vetter <daniel@ffwll.ch>,
intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org,
Praveen Kumar <kumarpraveen@linux.microsoft.com>,
Saurabh Singh Sengar <ssengar@microsoft.com>
Subject: Re: [PATCH v2 2/2] drm/i915/fbc: Avoid full proxy f_ops for FBC debug attributes
Date: Wed, 11 Jan 2023 20:33:57 +0530 [thread overview]
Message-ID: <Y77P3Qt7P9BRMlco@ubun2204.myguest.virtualbox.org> (raw)
In-Reply-To: <Y72z1T1bifo3YpSR@intel.com>
On Tue, Jan 10, 2023 at 01:52:05PM -0500, Rodrigo Vivi wrote:
> On Tue, Jan 10, 2023 at 11:45:40PM +0530, Deepak R Varma wrote:
> > Using DEFINE_SIMPLE_ATTRIBUTE macro with the debugfs_create_file()
> > function adds the overhead of introducing a proxy file operation
> > functions to wrap the original read/write inside file removal protection
> > functions. This adds significant overhead in terms of introducing and
> > managing the proxy factory file operations structure and function
> > wrapping at runtime.
> > As a replacement, a combination of DEFINE_DEBUGFS_ATTRIBUTE macro paired
> > with debugfs_create_file_unsafe() is suggested to be used instead. The
> > DEFINE_DEBUGFS_ATTRIBUTE utilises debugfs_file_get() and
> > debugfs_file_put() wrappers to protect the original read and write
> > function calls for the debug attributes. There is no need for any
> > runtime proxy file operations to be managed by the debugfs core.
> > Following coccicheck make command helped identify this change:
> >
> > make coccicheck M=drivers/gpu/drm/i915/ MODE=patch COCCI=./scripts/coccinelle/api/debugfs/debugfs_simple_attr.cocci
> >
> > Signed-off-by: Deepak R Varma <drv@mailo.com>
>
> Reviewed-by: Rodrigo Vivi <rodrigo.vivi@intel.com>
>
> (Are you planning to send the one for pxp file?)
Hello Rodrigo,
The pxp file is implemented differently using a common function for another SHOW
attribute file. I am exploring how to best handle that and would send in a patch
if feasible. See the simplified code snip below:
static const struct intel_gt_debugfs_file files[] = {
{ "info", &pxp_info_fops, NULL },
{ "terminate_state", &pxp_terminate_fops, NULL },
};
...
intel_gt_debugfs_register_files(root, files, ARRAY_SIZE(files), pxp);
Thank you.
./drv
>
> > ---
> > Changes in v2:
> > - Include coccicheck make command in the patch log message for clarity.
> > Suggested by Rodrigo Vivi <rodrigo.vivi@intel.com>
> >
> >
> > drivers/gpu/drm/i915/display/intel_fbc.c | 12 ++++++------
> > 1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/i915/display/intel_fbc.c b/drivers/gpu/drm/i915/display/intel_fbc.c
> > index 5e69d3c11d21..c508dcf415b4 100644
> > --- a/drivers/gpu/drm/i915/display/intel_fbc.c
> > +++ b/drivers/gpu/drm/i915/display/intel_fbc.c
> > @@ -1807,10 +1807,10 @@ static int intel_fbc_debugfs_false_color_set(void *data, u64 val)
> > return 0;
> > }
> >
> > -DEFINE_SIMPLE_ATTRIBUTE(intel_fbc_debugfs_false_color_fops,
> > - intel_fbc_debugfs_false_color_get,
> > - intel_fbc_debugfs_false_color_set,
> > - "%llu\n");
> > +DEFINE_DEBUGFS_ATTRIBUTE(intel_fbc_debugfs_false_color_fops,
> > + intel_fbc_debugfs_false_color_get,
> > + intel_fbc_debugfs_false_color_set,
> > + "%llu\n");
> >
> > static void intel_fbc_debugfs_add(struct intel_fbc *fbc,
> > struct dentry *parent)
> > @@ -1819,8 +1819,8 @@ static void intel_fbc_debugfs_add(struct intel_fbc *fbc,
> > fbc, &intel_fbc_debugfs_status_fops);
> >
> > if (fbc->funcs->set_false_color)
> > - debugfs_create_file("i915_fbc_false_color", 0644, parent,
> > - fbc, &intel_fbc_debugfs_false_color_fops);
> > + debugfs_create_file_unsafe("i915_fbc_false_color", 0644, parent,
> > + fbc, &intel_fbc_debugfs_false_color_fops);
> > }
> >
> > void intel_fbc_crtc_debugfs_add(struct intel_crtc *crtc)
> > --
> > 2.34.1
> >
> >
> >
prev parent reply other threads:[~2023-01-11 15:05 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-10 18:14 [PATCH 0/2 v2] drm/i915: Avoid full proxy f_ops " Deepak R Varma
2023-01-10 18:15 ` [PATCH v2 1/2] drm/i915/display: Avoid full proxy f_ops for DRRS " Deepak R Varma
2023-01-10 18:51 ` [Intel-gfx] " Rodrigo Vivi
2023-01-10 18:15 ` [PATCH v2 2/2] drm/i915/fbc: Avoid full proxy f_ops for FBC " Deepak R Varma
2023-01-10 18:52 ` Rodrigo Vivi
2023-01-11 15:03 ` Deepak R Varma [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Y77P3Qt7P9BRMlco@ubun2204.myguest.virtualbox.org \
--to=drv@mailo.com \
--cc=airlied@gmail.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=joonas.lahtinen@linux.intel.com \
--cc=kumarpraveen@linux.microsoft.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rodrigo.vivi@intel.com \
--cc=ssengar@microsoft.com \
--cc=tvrtko.ursulin@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®