From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 67757C46467 for ; Sat, 7 Jan 2023 20:10:08 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S232661AbjAGUKG (ORCPT ); Sat, 7 Jan 2023 15:10:06 -0500 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:54580 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S232634AbjAGUJs (ORCPT ); Sat, 7 Jan 2023 15:09:48 -0500 Received: from msg-2.mailo.com (msg-2.mailo.com [213.182.54.12]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 5D4E21AD8D for ; Sat, 7 Jan 2023 12:09:47 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=mailo.com; s=mailo; t=1673122179; bh=YLQN1N9pihHAMf/zPpPhdNCRrp7JZhMqhZrFNGqFCOA=; h=X-EA-Auth:Date:From:To:Cc:Subject:Message-ID:References: MIME-Version:Content-Type:In-Reply-To; b=WPlK/TzmPkFIKvCTSw0gvRo8HkMakaZ02kRqbma1ZjobJwvMLIGby59M6lE7iE55b 4a5O7gsRybdrrEDP8l2C5z+scr+WoPZc0Kzge1PGGFQgUrqoA/uxMlKN5kA4+m4mQv G2tst9k8cOe8deQBx1uA9lJjv4xLf1WuhZ/bkJ9A= Received: by b-3.in.mailobj.net [192.168.90.13] with ESMTP via ip-206.mailobj.net [213.182.55.206] Sat, 7 Jan 2023 21:09:38 +0100 (CET) X-EA-Auth: OKIrZ39R0cxkfSoB8rZ3cbEymhSiYYRsf2Ge4ZAJPNVBogv6yPdBfIWwKDQ+fcdWWcucLzl1+F3zAqBv1n32/7nTHA8/h5BJ Date: Sun, 8 Jan 2023 01:39:25 +0530 From: Deepak R Varma To: Felix Kuehling , Alex Deucher , Christian =?iso-8859-1?Q?K=F6nig?= , "Pan, Xinhui" , David Airlie , Daniel Vetter , amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org Cc: Saurabh Singh Sengar , Praveen Kumar , Deepak R Varma Subject: Re: [PATCH] drm/amdkfd: Use resource_size() helper function Message-ID: References: MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Dec 23, 2022 at 02:45:00AM +0530, Deepak R Varma wrote: > Use the resource_size() function instead of a open coded computation > resource size. It makes the code more readable. > > Issue identified using resource_size.cocci coccinelle semantic patch. > > Signed-off-by: Deepak R Varma > --- Hello, Requesting a review and feedback on this patch proposal? Thank you, ./drv