From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Jon Hunter <jonathanh@nvidia.com>
Cc: linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org,
Andrzej Pietrasiewicz <andrzej.p@collabora.com>
Subject: Re: [PATCH V3 2/2] usb: gadget: u_ether: Don't warn in gether_setup_name_default()
Date: Thu, 19 Jan 2023 16:26:51 +0100 [thread overview]
Message-ID: <Y8lhOxIwz6dZlNnz@kroah.com> (raw)
In-Reply-To: <e0e3fb48-1c7a-f012-5308-4897bab01dfc@nvidia.com>
On Thu, Jan 19, 2023 at 01:38:15PM +0000, Jon Hunter wrote:
>
> On 19/01/2023 10:46, Greg Kroah-Hartman wrote:
>
> ...
>
> > In looking at this further, you are right, the structures are not
> > initialized properly yet.
> >
> > So move these to a different function entirely, they should be in
> > gether_register_netdev() instead, after the device is registered with
> > the system.
>
>
> I wonder if this is even necessary. Looking at gether_register_netdev() it
> already has ...
>
> status = register_netdev(net);
> if (status < 0) {
> dev_dbg(&g->dev, "register_netdev failed, %d\n", status);
> return status;
> } else {
> INFO(dev, "HOST MAC %pM\n", dev->host_mac);
> INFO(dev, "MAC %pM\n", dev->dev_mac);
Those need to be moved to be dev_info() and then I'll stop complaining :)
Or dev_dbg() if you want to make it debug only.
> ...
> }
>
>
> Any objection to just removing completely from gether_setup_name_default()?
Nope!
Remove them and change the above lines and then all should be good.
thanks,
greg k-h
next prev parent reply other threads:[~2023-01-20 5:37 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-19 10:25 [PATCH V3 1/2] usb: gadget: u_ether: Improve print " Jon Hunter
2023-01-19 10:25 ` [PATCH V3 2/2] usb: gadget: u_ether: Don't warn " Jon Hunter
2023-01-19 10:46 ` Greg Kroah-Hartman
2023-01-19 13:38 ` Jon Hunter
2023-01-19 15:26 ` Greg Kroah-Hartman [this message]
2023-02-09 12:53 [PATCH V3 1/2] usb: gadget: u_ether: Convert prints to device prints Jon Hunter
2023-02-09 12:53 ` [PATCH V3 2/2] usb: gadget: u_ether: Don't warn in gether_setup_name_default() Jon Hunter
2023-02-13 13:16 ` Andrzej Pietrasiewicz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Y8lhOxIwz6dZlNnz@kroah.com \
--to=gregkh@linuxfoundation.org \
--cc=andrzej.p@collabora.com \
--cc=jonathanh@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®