From: Peter Zijlstra <peterz@infradead.org>
To: Christophe Leroy <christophe.leroy@csgroup.eu>
Cc: Song Liu <song@kernel.org>,
"linux-modules@vger.kernel.org" <linux-modules@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"hch@lst.de" <hch@lst.de>,
"kernel-team@meta.com" <kernel-team@meta.com>,
Luis Chamberlain <mcgrof@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Guenter Roeck <linux@roeck-us.net>
Subject: Re: [PATCH v4] module: replace module_layout with module_memory
Date: Tue, 31 Jan 2023 13:04:25 +0100 [thread overview]
Message-ID: <Y9kDyUaOe57IL/yF@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <1302e2b6-8980-e6e5-7433-6754634c98f3@csgroup.eu>
On Tue, Jan 31, 2023 at 10:58:56AM +0000, Christophe Leroy wrote:
>
>
> Le 31/01/2023 à 10:09, Peter Zijlstra a écrit :
>
> >> @@ -573,23 +574,33 @@ bool __is_module_percpu_address(unsigned long addr, unsigned long *can_addr);
> >> bool is_module_percpu_address(unsigned long addr);
> >> bool is_module_text_address(unsigned long addr);
> >>
> >> +static inline bool within_module_mem_type(unsigned long addr,
> >> + const struct module *mod,
> >> + enum mod_mem_type type)
> >> +{
> >> + unsigned long base, size;
> >> +
> >> + base = (unsigned long)mod->mem[type].base;
> >> + size = mod->mem[type].size;
> >> +
> >> + return base <= addr && addr < base + size;
> >
> > Possible (as inspired by all the above is_{init,core}() etc..
> >
> > return addr - base < size;
> >
>
> In kernel/module/main.c we have a function called within(). Maybe that
> function could be lifted in module.h and used.
More sharing more good. But I don't think we can lift a 'within'
function to the global namespace, that's just asking for pain.
> > static inline bool within_module_mem_types(unsigned long addr,
> > const struct module *mod,
> > enum mod_mem_type first,
> > enum mod_mem_type last)
> > {
> > for (enum mod_mem_type type = first; type <= last; type++) {
> > if (within_module_mem_type(addr, mod, type))
> > return true;
> > }
> > return false;
> > }
>
> Well, ok but what garanties it will always be contiguous types ?
> And you can't anymore see at first look what types it is.
>
> I prefer it to be explicit with within_module_mem_type(TYPE1) ||
> within_module_mem_type(TYPE2) || within_module_mem_type(TYPE3). By the
> way we could make the function name shorter, even within() may be a
> better name as it is used only inside module code.
>
> Something like
>
> return within(addr, mod, MOD_TEXT) || within(addr, mod, MOD_DATA) ||
> within(addr, mod, MOD_RODATA) || within(addr, mod,
> MOD_RO_AFTER_INIT);
Urgh, how about?
for_each_mod_mem_type(type) {
if (!mod_mem_type_is_init(type) && within(addr, mod, type))
return true;
}
return false;
Then you have have a bunch of mod_mem_type_id_foo() filter functions
that are non-contiguous without having to endlessly repeat stuff
manually.
next prev parent reply other threads:[~2023-01-31 12:04 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-30 18:21 Song Liu
2023-01-31 9:09 ` Peter Zijlstra
2023-01-31 10:58 ` Christophe Leroy
2023-01-31 12:04 ` Peter Zijlstra [this message]
2023-01-31 12:14 ` Christophe Leroy
2023-01-31 14:06 ` Peter Zijlstra
2023-01-31 17:41 ` Christophe Leroy
2023-01-31 11:14 ` Peter Zijlstra
2023-02-01 0:37 ` Song Liu
2023-01-31 11:26 ` Peter Zijlstra
2023-01-31 11:36 ` Peter Zijlstra
2023-01-31 16:11 ` Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Y9kDyUaOe57IL/yF@hirez.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=christophe.leroy@csgroup.eu \
--cc=hch@lst.de \
--cc=kernel-team@meta.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-modules@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mcgrof@kernel.org \
--cc=song@kernel.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®