From: Phil Auld <pauld@redhat.com>
To: Valentin Schneider <valentin.schneider@arm.com>
Cc: Rik van Riel <riel@surriel.com>,
linux-kernel@vger.kernel.org,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@kernel.org>,
Vincent Guittot <vincent.guittot@linaro.org>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Morten Rasmussen <morten.rasmussen@arm.com>,
Qais Yousef <qais.yousef@arm.com>,
Quentin Perret <qperret@google.com>,
Pavan Kondeti <pkondeti@codeaurora.org>,
Lingutla Chandrasekhar <clingutla@codeaurora.org>
Subject: Re: [PATCH 2/2] sched/fair: Relax task_hot() for misfit tasks
Date: Mon, 19 Apr 2021 08:59:58 -0400 [thread overview]
Message-ID: <YH1+zpzUdJeTk0Z3@lorien.usersys.redhat.com> (raw)
In-Reply-To: <87tuo6lg39.mognet@arm.com>
On Fri, Apr 16, 2021 at 10:43:38AM +0100 Valentin Schneider wrote:
> On 15/04/21 16:39, Rik van Riel wrote:
> > On Thu, 2021-04-15 at 18:58 +0100, Valentin Schneider wrote:
> >> Consider the following topology:
> >>
> >> Long story short, preempted misfit tasks are affected by task_hot(),
> >> while
> >> currently running misfit tasks are intentionally preempted by the
> >> stopper
> >> task to migrate them over to a higher-capacity CPU.
> >>
> >> Align detach_tasks() with the active-balance logic and let it pick a
> >> cache-hot misfit task when the destination CPU can provide a capacity
> >> uplift.
> >>
> >> Signed-off-by: Valentin Schneider <valentin.schneider@arm.com>
> >
> > Reviewed-by: Rik van Riel <riel@surriel.com>
> >
>
> Thanks!
>
> >
> > This patch looks good, but...
> >
> >> @@ -7672,6 +7698,15 @@ int can_migrate_task(struct task_struct *p,
> >> struct lb_env *env)
> >> if (tsk_cache_hot == -1)
> >> tsk_cache_hot = task_hot(p, env);
> >>
> >> + /*
> >> + * On a (sane) asymmetric CPU capacity system, the increase in
> >> compute
> >> + * capacity should offset any potential performance hit caused
> >> by a
> >> + * migration.
> >> + */
> >> + if ((env->dst_grp_type == group_has_spare) &&
> >> + !migrate_degrades_capacity(p, env))
> >> + tsk_cache_hot = 0;
> >
> > ... I'm starting to wonder if we should not rename the
> > tsk_cache_hot variable to something else to make this
> > code more readable. Probably in another patch :)
> >
>
> I'd tend to agree, but naming is hard. "migration_harmful" ?
I thought Rik meant tsk_cache_hot, for which I'd suggest at least
buying a vowel and putting an 'a' in there :)
Cheers,
Phil
>
> > --
> > All Rights Reversed.
>
--
next prev parent reply other threads:[~2021-04-19 13:00 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-04-15 17:58 [PATCH 0/2] sched/fair: (The return of) misfit task load-balance tweaks Valentin Schneider
2021-04-15 17:58 ` [PATCH 1/2] sched/fair: Filter out locally-unsolvable misfit imbalances Valentin Schneider
2021-04-15 18:47 ` Rik van Riel
2021-04-16 13:29 ` Vincent Guittot
2021-04-19 17:13 ` Valentin Schneider
2021-04-22 9:48 ` Dietmar Eggemann
2021-04-22 19:19 ` Valentin Schneider
2021-04-15 17:58 ` [PATCH 2/2] sched/fair: Relax task_hot() for misfit tasks Valentin Schneider
2021-04-15 20:39 ` Rik van Riel
2021-04-16 9:43 ` Valentin Schneider
2021-04-19 12:59 ` Phil Auld [this message]
2021-04-19 17:17 ` Valentin Schneider
2021-04-19 20:23 ` Phil Auld
2021-04-16 13:51 ` Vincent Guittot
2021-04-19 17:13 ` Valentin Schneider
2021-04-20 14:33 ` Vincent Guittot
2021-04-21 10:52 ` Valentin Schneider
2021-04-22 17:29 ` Dietmar Eggemann
2021-04-22 19:19 ` Valentin Schneider
2021-04-30 6:58 ` Vincent Guittot
2021-05-07 13:46 ` Valentin Schneider
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YH1+zpzUdJeTk0Z3@lorien.usersys.redhat.com \
--to=pauld@redhat.com \
--cc=clingutla@codeaurora.org \
--cc=dietmar.eggemann@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=morten.rasmussen@arm.com \
--cc=peterz@infradead.org \
--cc=pkondeti@codeaurora.org \
--cc=qais.yousef@arm.com \
--cc=qperret@google.com \
--cc=riel@surriel.com \
--cc=valentin.schneider@arm.com \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®