From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-3.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id BF8BDC6377A for ; Mon, 19 Jul 2021 20:47:20 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 925FF6113C for ; Mon, 19 Jul 2021 20:47:19 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1358747AbhGSUAG (ORCPT ); Mon, 19 Jul 2021 16:00:06 -0400 Received: from zeniv-ca.linux.org.uk ([142.44.231.140]:50894 "EHLO zeniv-ca.linux.org.uk" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1386854AbhGSTlp (ORCPT ); Mon, 19 Jul 2021 15:41:45 -0400 Received: from viro by zeniv-ca.linux.org.uk with local (Exim 4.94.2 #2 (Red Hat Linux)) id 1m5Zhu-0027kw-64; Mon, 19 Jul 2021 20:17:42 +0000 Date: Mon, 19 Jul 2021 20:17:42 +0000 From: Al Viro To: Linus Torvalds Cc: Andreas Gruenbacher , Jan Kara , Matthew Wilcox , Christoph Hellwig , cluster-devel , linux-fsdevel , Linux Kernel Mailing List , ocfs2-devel@oss.oracle.com Subject: Re: [PATCH v2 5/6] iov_iter: Introduce ITER_FLAG_FAST_ONLY flag Message-ID: References: <20210718223932.2703330-1-agruenba@redhat.com> <20210718223932.2703330-6-agruenba@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Sender: Al Viro Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Jul 19, 2021 at 12:29:35PM -0700, Linus Torvalds wrote: > On Sun, Jul 18, 2021 at 3:40 PM Andreas Gruenbacher wrote: > > > > Introduce a new ITER_FLAG_FAST_ONLY flag > > I think the code is fine, but I think it might be best to call this > "ITER_FLAG_NOIO" or something like that. > > The "FAST_ONLY" name makes sense in the context of > "get_user_pages_fast()" where we have that "fast" naming (and the long > history too). But I don't think it makes much sense as a name in the > context of iov_iter. This code has never been tested with current lib/iov_iter.c as it is in mainline. Or had been in -next during the last cycle. It won't apply at all. Sure, I can try to port that series over to the current mainline, but I'd rather see that done (and tested) by the series author...