From: "Gautham R. Shenoy" <gautham.shenoy@amd.com>
To: Vincent Guittot <vincent.guittot@linaro.org>
Cc: Barry Song <21cnbao@gmail.com>,
Yicong Yang <yangyicong@hisilicon.com>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@redhat.com>,
Juri Lelli <juri.lelli@redhat.com>,
Tim Chen <tim.c.chen@linux.intel.com>,
LKML <linux-kernel@vger.kernel.org>,
LAK <linux-arm-kernel@lists.infradead.org>,
Dietmar Eggemann <dietmar.eggemann@arm.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ben Segall <bsegall@google.com>,
Daniel Bristot de Oliveira <bristot@redhat.com>,
prime.zeng@huawei.com,
Jonathan Cameron <jonathan.cameron@huawei.com>,
ego@linux.vnet.ibm.com,
Srikar Dronamraju <srikar@linux.vnet.ibm.com>,
Linuxarm <linuxarm@huawei.com>,
Barry Song <song.bao.hua@hisilicon.com>,
Guodong Xu <guodong.xu@linaro.org>
Subject: Re: [PATCH 1/2] sched: Add per_cpu cluster domain info and cpus_share_cluster API
Date: Thu, 23 Dec 2021 20:09:46 +0530 [thread overview]
Message-ID: <YcSKMsCysRtHz1aC@BLR-5CG11610CF.amd.com> (raw)
In-Reply-To: <CAKfTPtBKLDyNPXg7uLbQ3jUnEwppfC+E29=oJ1tWzzqHsNpApw@mail.gmail.com>
Hello Vincent, Barry,
On Wed, Dec 22, 2021 at 02:33:37PM +0100, Vincent Guittot wrote:
> On Wed, 22 Dec 2021 at 14:14, Vincent Guittot
[..snip..]
> > > > > @@ -669,6 +671,12 @@ static void update_top_cache_domain(int cpu)
> > > > > per_cpu(sd_llc_id, cpu) = id;
> > > > > rcu_assign_pointer(per_cpu(sd_llc_shared, cpu), sds);
> > > > >
> > > > > + sd = lowest_flag_domain(cpu, SD_CLUSTER);
> > > > > + if (sd)
> > > > > + id = cpumask_first(sched_domain_span(sd));
> > > > > + rcu_assign_pointer(per_cpu(sd_cluster, cpu), sd);
> > > > > + per_cpu(sd_cluster_id, cpu) = id;
> > > > > +
> >
> > This deserves a large comment to highlight that the new code above is
> > not self contained and relies on the fact that it is done just after
> > looking for LLC and sd and that id and sd must not be changed in
> > between inorder to ensures that per_cpu(sd_cluster_id, cpu) equals
> > per_cpu(sd_llc_id, cpu) if there is no domain with SD_CLUSTER.
> >
> > and per_cpu(sd_cluster_id, cpu) might not be cluster but llc
>
> Maybe you should not name this sd_cluster_id at all but
> per_cpu(sd_share_id, cpu) = id;
>
> Then you have a function named
>
> +bool cpus_share_resources(int this_cpu, int that_cpu)
> +{
> + if (this_cpu == that_cpu)
> + return true;
> +
> + return per_cpu(sd_share_id, this_cpu) == per_cpu(sd_share_id, that_cpu);
> +}
> +
> which returns true when cpu shares resources which can be LLC or cluster
+1. This would make it more readable than overloading the meaning of cluster itself.
--
Thanks and Regards
gautham.
next prev parent reply other threads:[~2021-12-23 14:40 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-15 4:11 [PATCH 0/2] sched/fair: Wake task within the cluster when possible Yicong Yang
2021-12-15 4:11 ` [PATCH 1/2] sched: Add per_cpu cluster domain info and cpus_share_cluster API Yicong Yang
2021-12-22 10:24 ` Gautham R. Shenoy
2021-12-22 11:06 ` Barry Song
2021-12-22 13:14 ` Vincent Guittot
2021-12-22 13:33 ` Vincent Guittot
2021-12-23 14:39 ` Gautham R. Shenoy [this message]
2021-12-15 4:11 ` [PATCH 2/2] sched/fair: Scan cluster before scanning LLC in wake-up path Yicong Yang
2021-12-22 13:26 ` Vincent Guittot
2021-12-22 22:36 ` Barry Song
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YcSKMsCysRtHz1aC@BLR-5CG11610CF.amd.com \
--to=gautham.shenoy@amd.com \
--cc=21cnbao@gmail.com \
--cc=bristot@redhat.com \
--cc=bsegall@google.com \
--cc=dietmar.eggemann@arm.com \
--cc=ego@linux.vnet.ibm.com \
--cc=guodong.xu@linaro.org \
--cc=jonathan.cameron@huawei.com \
--cc=juri.lelli@redhat.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=prime.zeng@huawei.com \
--cc=rostedt@goodmis.org \
--cc=song.bao.hua@hisilicon.com \
--cc=srikar@linux.vnet.ibm.com \
--cc=tim.c.chen@linux.intel.com \
--cc=vincent.guittot@linaro.org \
--cc=yangyicong@hisilicon.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®