From: Greg KH <gregkh@linuxfoundation.org>
To: Gaston Gonzalez <gascoar@gmail.com>
Cc: linux-staging@lists.linux.dev, nsaenz@kernel.org,
f.fainelli@gmail.com, rjui@broadcom.com, sbranden@broadcom.com,
juerg.haefliger@canonical.com, rdunlap@infradead.org,
dave.stevenson@raspberrypi.com, stefan.wahren@i2se.com,
unixbhaskar@gmail.com, mitaliborkar810@gmail.com,
phil@raspberrypi.com, len.baker@gmx.com,
linux-rpi-kernel@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
bcm-kernel-feedback-list@broadcom.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/6] staging: vc04_services: rename macros BM2835_MMAL_VERSION and BM2835_MMAL_MODULE_NAME
Date: Thu, 6 Jan 2022 14:48:25 +0100 [thread overview]
Message-ID: <YdbzKaKQW7N04QgA@kroah.com> (raw)
In-Reply-To: <d450b9e22e5ab335a61591dbf0d2104031c9fc46.1641414449.git.gascoar@gmail.com>
On Wed, Jan 05, 2022 at 05:35:47PM -0300, Gaston Gonzalez wrote:
> In the kernel, all names related to the chip BCM2835 are always named
> bcm2835_*. To avoid confusion, and to make things more consistent,
> rename the macros BM2835_MMAL_VERSION and BM2835_MMAL_MODULE_NAME
> accordingly.
>
> While at it, some realignments were made to improve readability.
>
> Suggested-by: Stefan Wahren <stefan.wahren@i2se.com>
> Signed-off-by: Gaston Gonzalez <gascoar@gmail.com>
> ---
> .../vc04_services/bcm2835-camera/bcm2835-camera.c | 14 ++++++--------
> 1 file changed, 6 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c b/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c
> index aaf529f2186c..c729b1b7de71 100644
> --- a/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c
> +++ b/drivers/staging/vc04_services/bcm2835-camera/bcm2835-camera.c
> @@ -33,8 +33,8 @@
> #include "mmal-parameters.h"
> #include "bcm2835-camera.h"
>
> -#define BM2835_MMAL_VERSION "0.0.2"
> -#define BM2835_MMAL_MODULE_NAME "bcm2835-v4l2"
> +#define BCM2835_MMAL_VERSION "0.0.2"
MODULE_VERSION means nothing when the code is in the kernel tree, this
shold just be removed entirely.
> +#define BCM2835_MMAL_MODULE_NAME "bcm2835-v4l2"
KBUILD_MODULE_NAME provides this, please delete this and just use that
instead.
This can be 2 different commits because of this.
thanks,
greg k-h
next prev parent reply other threads:[~2022-01-06 13:48 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-01-05 20:35 [PATCH 0/6] staging: vc04_services: rename ocurrences of 'bm2835*' to 'bcm2835*' Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 1/6] staging: vc04_services: rename structures bm2835_mmal_dev and bm2835_mmal_v4l2_ctrl Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 2/6] staging: vc04_services: rename functions containing bm2835_* to bcm2835_* Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 3/6] staging: vc04_services: rename variables " Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 4/6] staging: vc04_services: rename string literal containing bm2835_* to bcm2835*_ Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 5/6] staging: vc04_services: rename macros BM2835_MMAL_VERSION and BM2835_MMAL_MODULE_NAME Gaston Gonzalez
2022-01-06 13:48 ` Greg KH [this message]
2022-01-07 10:36 ` Gaston Gonzalez
2022-01-05 20:35 ` [PATCH 6/6] staging: vc04_services: rename BM2835 to BCM2835 in headers comments Gaston Gonzalez
2022-01-06 13:49 ` [PATCH 0/6] staging: vc04_services: rename ocurrences of 'bm2835*' to 'bcm2835*' Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YdbzKaKQW7N04QgA@kroah.com \
--to=gregkh@linuxfoundation.org \
--cc=bcm-kernel-feedback-list@broadcom.com \
--cc=dave.stevenson@raspberrypi.com \
--cc=f.fainelli@gmail.com \
--cc=gascoar@gmail.com \
--cc=juerg.haefliger@canonical.com \
--cc=len.baker@gmx.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rpi-kernel@lists.infradead.org \
--cc=linux-staging@lists.linux.dev \
--cc=mitaliborkar810@gmail.com \
--cc=nsaenz@kernel.org \
--cc=phil@raspberrypi.com \
--cc=rdunlap@infradead.org \
--cc=rjui@broadcom.com \
--cc=sbranden@broadcom.com \
--cc=stefan.wahren@i2se.com \
--cc=unixbhaskar@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome