From: Yury Norov <yury.norov@gmail.com>
To: Max Filippov <jcmvbkbc@gmail.com>
Cc: "Andy Shevchenko" <andriy.shevchenko@linux.intel.com>,
"David Laight" <David.Laight@aculab.com>,
"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"Joe Perches" <joe@perches.com>,
"Julia Lawall" <Julia.Lawall@inria.fr>,
"Michał Mirosław" <mirq-linux@rere.qmqm.pl>,
"Nicholas Piggin" <npiggin@gmail.com>,
"Nicolas Palix" <nicolas.palix@imag.fr>,
"Peter Zijlstra" <peterz@infradead.org>,
"Rasmus Villemoes" <linux@rasmusvillemoes.dk>,
"Matti Vaittinen" <Matti.Vaittinen@fi.rohmeurope.com>,
LKML <linux-kernel@vger.kernel.org>,
"Alexei Starovoitov" <ast@kernel.org>,
"Andrew Morton" <akpm@linux-foundation.org>,
"Chris Zankel" <chris@zankel.net>,
"Christophe Leroy" <christophe.leroy@csgroup.eu>,
"Eric W . Biederman" <ebiederm@xmission.com>,
"Kumar Kartikeya Dwivedi" <memxor@gmail.com>,
"Toke Høiland-Jørgensen" <toke@redhat.com>,
"open list:TENSILICA XTENSA PORT (xtensa)"
<linux-xtensa@linux-xtensa.org>
Subject: Re: [PATCH 08/22] bitops: introduce MANY_BITS() macro
Date: Tue, 10 May 2022 12:16:55 -0700 [thread overview]
Message-ID: <Ynq6JxyfBKK4SMZj@yury-laptop> (raw)
In-Reply-To: <CAMo8Bf+JiyKD=g00whNOYGynx_0KjC_wJtpEBCB2ynFZ3U+e_Q@mail.gmail.com>
Hi Max,
On Tue, May 10, 2022 at 10:57:25AM -0700, Max Filippov wrote:
> Hi Yury,
>
> On Tue, May 10, 2022 at 8:48 AM Yury Norov <yury.norov@gmail.com> wrote:
> > arch/xtensa/kernel/traps.c and include/linux/log2.h define very similar
> > functions with different behaviour. XTENSA defines IS_POW2(), and
> > log2.h defines is_power_of_2(). The difference is that IS_POW2()
> > considers 0 as power of 2, while is_power_of_2() - does not.
>
> IS_POW2 is constructed this way because we know that there is at least
> one non-zero bit in the value that it tests.
>
> > This discrepancy may confuse reader. From mathematical point of view,
> > 0 is not a power of 2.
>
> If it would reduce the confusion we can add a check that the value is
> non-zero in the IS_POW2 macro.
>
> I'd really like to not introduce the local macro and just use something
> standard,
This patch introduces a macro MANY_BITS() in include/linux/bitops.h, which
is a full analogue of IS_POW2(). Would it work for you to switch to
MANY_BITS()?
> but I can't use is_power_of_2 in a preprocessor condition, can I?
I believe you can't.
Thanks,
Yury
next prev parent reply other threads:[~2022-05-10 19:17 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-05-10 15:47 [PATCH 00/21] add coccinelle scripts for {bitmap,cpumask,nodes}_empty() Yury Norov
2022-05-10 15:47 ` [PATCH 01/22] introduce bitmap.cocci Yury Norov
2022-05-10 15:47 ` [PATCH 02/22] introduce cpumask.cocci Yury Norov
2022-05-10 15:47 ` [PATCH 03/22] introduce nodemask.cocci Yury Norov
2022-05-10 15:47 ` [PATCH 04/22] ice: use bitmap_empty() in ice_vf_has_no_qs_ena() Yury Norov
2022-05-10 15:47 ` [PATCH 05/22] iio: replace bitmap_weight with bitmap_weitght_{eq,le} where appropriate Yury Norov
2022-05-14 15:53 ` Jonathan Cameron
2022-05-14 16:31 ` Joe Perches
2022-05-15 16:40 ` Jonathan Cameron
2022-05-10 15:47 ` [PATCH 06/22] octeontx2: use bitmap_empty() instead of bitmap_weight() Yury Norov
2022-05-10 21:31 ` Jakub Kicinski
2022-05-10 15:47 ` [PATCH 07/22] risc-v: replace bitmap_weight with bitmap_empty in riscv_fill_hwcap() Yury Norov
2022-05-10 16:31 ` Anup Patel
2022-05-10 15:47 ` [PATCH 08/22] bitops: introduce MANY_BITS() macro Yury Norov
2022-05-10 16:50 ` Alexei Starovoitov
2022-05-10 17:54 ` David Laight
2022-05-10 19:11 ` Yury Norov
2022-05-11 10:59 ` Rasmus Villemoes
2022-05-10 17:57 ` Max Filippov
2022-05-10 19:16 ` Yury Norov [this message]
2022-05-11 4:55 ` Max Filippov
2022-05-10 15:47 ` [PATCH 09/22] qed: replace bitmap_weight() with MANY_BITS() Yury Norov
2022-05-10 15:47 ` [PATCH 10/22] net/mlx5e: simplify mlx5e_set_fecparam() Yury Norov
2022-05-10 15:47 ` [PATCH 11/22] KVM: x86: hyper-v: replace bitmap_weight() with hweight64() Yury Norov
2022-05-16 13:08 ` Vitaly Kuznetsov
2022-05-22 14:53 ` Guenter Roeck
2022-05-22 17:39 ` Yury Norov
2022-05-10 15:47 ` [PATCH 12/22] ia64: cleanup remove_siblinginfo() Yury Norov
2022-05-10 22:33 ` Andrew Morton
2022-05-10 15:47 ` [PATCH 13/22] x86: smp: move cpumask_weight() out of for-loop in remove_siblinginfo Yury Norov
2022-05-11 9:47 ` Thomas Gleixner
2022-05-10 15:47 ` [PATCH 14/22] x86: smp: use cpumask_weight_eq() " Yury Norov
2022-05-10 15:47 ` [PATCH 15/22] net/mlx5: use cpumask_weight_gt() in irq_pool_request_irq() Yury Norov
2022-05-10 15:47 ` [PATCH 16/22] x86/tsc: use cpumask_weight_gt() in loop_timeout() Yury Norov
2022-05-10 15:47 ` [PATCH 17/22] sched/core: fix opencoded cpumask_any_but() Yury Norov
2022-05-10 16:37 ` Peter Zijlstra
2022-05-10 17:21 ` Valentin Schneider
2022-05-10 15:47 ` [PATCH 18/22] sched/core: remove unneeded cpumask_weight() in sched_core_cpu_{starting,deactivate} Yury Norov
2022-05-10 15:47 ` [PATCH 19/22] sched/core: replace cpumask_weight() with cpumask_weight_eq() where appropriate Yury Norov
2022-05-10 15:47 ` [PATCH 20/22] sched/topology: " Yury Norov
2022-05-10 15:47 ` [PATCH 21/22] cpufreq: use cpumask_weight_gt() in policy_is_shared() Yury Norov
2022-05-11 3:16 ` Viresh Kumar
2022-05-10 15:47 ` [PATCH 22/22] clockevents: use cpumask_weight_eq() in tick_cleanup_dead_cpu() Yury Norov
2022-05-11 8:18 ` Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Ynq6JxyfBKK4SMZj@yury-laptop \
--to=yury.norov@gmail.com \
--cc=David.Laight@aculab.com \
--cc=Julia.Lawall@inria.fr \
--cc=Matti.Vaittinen@fi.rohmeurope.com \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=ast@kernel.org \
--cc=chris@zankel.net \
--cc=christophe.leroy@csgroup.eu \
--cc=ebiederm@xmission.com \
--cc=gregkh@linuxfoundation.org \
--cc=jcmvbkbc@gmail.com \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-xtensa@linux-xtensa.org \
--cc=linux@rasmusvillemoes.dk \
--cc=memxor@gmail.com \
--cc=mirq-linux@rere.qmqm.pl \
--cc=nicolas.palix@imag.fr \
--cc=npiggin@gmail.com \
--cc=peterz@infradead.org \
--cc=toke@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®