mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Cc: Naga Sureshkumar Relli <nagasuresh.relli@microchip.com>,
	robh+dt@kernel.org, krzysztof.kozlowski+dt@linaro.org,
	conor.dooley@microchip.com, linux-spi@vger.kernel.org,
	devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] spi: dt-binding: add Microchip CoreQSPI compatible
Date: Thu, 4 Aug 2022 13:13:00 +0100	[thread overview]
Message-ID: <Yuu3zKmFZm+BJpGD@sirena.org.uk> (raw)
In-Reply-To: <b9cc3290-f0cb-0423-7ff0-dae40b52a379@linaro.org>

[-- Attachment #1: Type: text/plain, Size: 1483 bytes --]

On Thu, Aug 04, 2022 at 01:31:34PM +0200, Krzysztof Kozlowski wrote:
> On 03/08/2022 15:29, Mark Brown wrote:
> > On Wed, Aug 03, 2022 at 08:11:03AM +0200, Krzysztof Kozlowski wrote:

> >> Then it should be explained in title/description of the binding, not in
> >> compatible. This is the usual way of providing some text description,
> >> not for each compatible by repeating the compatible text.

> > I'm not convinced this is a useful rule to try to enforce, and I'm not
> > sure how well it will work if the same IP is used in several different
> > places.  It's not clear to me what the benefit is intended to be.

> First, the description here is really not adding any useful information.

> "description: Microchip's Polarfire SoC SPI controller."
> Microchip - already in comaptible
> SPI controller - already in compatible and in device description

> The only useful piece could be extending pfs to Polarfire SoC.

That was the main bit I was thinking of TBH.

> into double-sized oneOf with additional descriptions each one explaining
> "mpfs".

>   oneOf:
>     - description: Microchip's Polarfire SoC SPI controller.
>       const: microchip,mpfs-spi

If the YAML binding format is hard to read when people add comments that
does seem like something that should be addressed on the format side
rather than the binding side TBH.

> Just keep it simple and small. We all have too much code to look at...

Excessively clear documentation hasn't typically been our issue.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

  parent reply	other threads:[~2022-08-04 12:13 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-08-01  9:42 [PATCH 0/2] Add support for Microchip QSPI controller Naga Sureshkumar Relli
2022-08-01  9:42 ` [PATCH 1/2] spi: dt-binding: add Microchip CoreQSPI compatible Naga Sureshkumar Relli
2022-08-01 10:17   ` Conor.Dooley
2022-08-01 10:52     ` naga sureshkumar
2022-08-02  8:52   ` Krzysztof Kozlowski
2022-08-02 13:13     ` Mark Brown
2022-08-03  6:11       ` Krzysztof Kozlowski
2022-08-03  6:59         ` naga sureshkumar
2022-08-03  7:48           ` Krzysztof Kozlowski
2022-08-03 13:29         ` Mark Brown
2022-08-04 11:31           ` Krzysztof Kozlowski
2022-08-04 11:35             ` Krzysztof Kozlowski
2022-08-04 12:13             ` Mark Brown [this message]
2022-08-01  9:42 ` [PATCH 2/2] spi: microchip-core-qspi: Add support for microchip fpga qspi controllers Naga Sureshkumar Relli
2022-08-01 10:40   ` Conor.Dooley
2022-08-01 11:09     ` naga sureshkumar
2022-08-01 12:33     ` Mark Brown
2022-08-01 12:56       ` Conor.Dooley
2022-08-02  8:54   ` Krzysztof Kozlowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Yuu3zKmFZm+BJpGD@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=conor.dooley@microchip.com \
    --cc=devicetree@vger.kernel.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-spi@vger.kernel.org \
    --cc=nagasuresh.relli@microchip.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®