From: Yury Norov <yury.norov@gmail.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Guenter Roeck <linux@roeck-us.net>,
Dennis Zhou <dennis@kernel.org>,
Russell King <linux@armlinux.org.uk>,
Catalin Marinas <catalin.marinas@arm.com>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>,
Alexey Klimov <aklimov@redhat.com>,
Kees Cook <keescook@chromium.org>,
Andy Whitcroft <apw@canonical.com>
Subject: Re: [PATCH v2 1/3] lib/find_bit: introduce FIND_FIRST_BIT() macro
Date: Wed, 24 Aug 2022 06:19:22 -0700 [thread overview]
Message-ID: <YwYlWjlWO3fFrtQp@yury-laptop> (raw)
In-Reply-To: <CAHp75VcB08oTrB8R9Zyo4Ja=c_XqybqdCw46fY4_MNqvSSCtLQ@mail.gmail.com>
On Wed, Aug 24, 2022 at 12:10:02PM +0300, Andy Shevchenko wrote:
> On Wed, Aug 24, 2022 at 4:51 AM Yury Norov <yury.norov@gmail.com> wrote:
> >
> > Now that we have many flavors of find_first_bit(), and expect even more,
> > it's better to have one macro that generates optimal code for all and makes
> > maintaining of slightly different functions simpler.
> >
> > The logic common to all versions is moved to the new macro, and all the
> > flavors are generated by providing an EXPRESSION macro-parameter, like
> > in this example:
> >
> > #define FIND_FIRST_BIT(EXPRESSION, size) ...
> >
> > find_first_ornot_and_bit(addr1, addr2, addr3, size)
> > {
> > return FIND_NEXT_BIT(addr1[idx] | ~addr2[idx] & addr3[idx], size);
> > }
> >
> > The EXPRESSION may be of any complexity, as soon as it only refers
> > the bitmap(s) and an iterator idx.
> >
> > The 'word_op' is here to allow the macro to generate code for _le
> > versions on big-endian machines; used in the following patches.
>
> ...
>
> > +#ifndef word_op
> > +#define word_op
> > +#endif
>
> Not sure about the naming without namespace. Perhaps __ffs_word_op?
>
> > +#define FIND_FIRST_BIT(EXPRESSION, size) \
> > +({ \
> > + unsigned long idx, val, sz = (size); \
> > + \
> > + for (idx = 0; idx * BITS_PER_LONG < sz; idx++) { \
>
> I think we can do slightly better:
>
> for (unsigned long idx = 0; idx < sz; idx += BITS_PER_LONG) {
> unsigned long val;
This will blow up the EXPRESSION. We can mitigate it on user side:
find_first_bit(addr, size)
{
return FIND_FIRST_BIT(addr[idx/BITS_PER_LONG], size);
}
But to me it's a wtf++.
And generated code looks almost the same, except that
on x86_64 your version is bigger. Compare before:
0000000000000000 <_find_first_bit>:
0: mov %rsi,%rax
3: test %rsi,%rsi
6: je 35 <_find_first_bit+0x35>
8: xor %edx,%edx
a: jmp 19 <_find_first_bit+0x19>
c: add $0x40,%rdx // Track bits and
10: add $0x8,%rdi // index separately
14: cmp %rax,%rdx
17: jae 35 <_find_first_bit+0x35>
19: mov (%rdi),%rcx
1c: test %rcx,%rcx
1f: je c <_find_first_bit+0xc>
21: tzcnt %rcx,%rcx
26: add %rdx,%rcx
29: cmp %rcx,%rax
2c: cmova %rcx,%rax
30: jmp 35 <_find_first_bit+0x35>
35: jmp 3a <_find_first_bit+0x3a>
3a: nopw 0x0(%rax,%rax,1)
And after:
0000000000000000 <_find_first_bit>:
0: mov %rsi,%rax
3: test %rsi,%rsi
6: je 39 <_find_first_bit+0x39>
8: xor %edx,%edx
a: jmp 15 <_find_first_bit+0x15>
c: add $0x40,%rdx // Track bits only
10: cmp %rdx,%rax
13: jbe 39 <_find_first_bit+0x39>
15: mov %rdx,%rcx
18: shr $0x6,%rcx // But divide here
1c: mov (%rdi,%rcx,8),%rcx
20: test %rcx,%rcx
23: je c <_find_first_bit+0xc>
25: tzcnt %rcx,%rcx
2a: add %rcx,%rdx
2d: cmp %rdx,%rax
30: cmova %rdx,%rax
34: jmp 39 <_find_first_bit+0x39>
39: jmp 3e <_find_first_bit+0x3e>
3e: xchg %ax,%ax // Which adds 4 bytes to .text
Thanks,
Yury
> > + val = (EXPRESSION); \
> > + if (val) { \
> > + sz = min(idx * BITS_PER_LONG + __ffs(word_op(val)), sz);\
>
> sz = min(idx + __ffs(...));
>
> > + break; \
> > + } \
> > + } \
> > + \
> > + sz; \
> > +})
>
>
> --
> With Best Regards,
> Andy Shevchenko
next prev parent reply other threads:[~2022-08-24 13:19 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-08-24 1:26 [PATCH v2 0/4] lib: optimize find_bit() functions Yury Norov
2022-08-24 1:26 ` [PATCH v2 1/3] lib/find_bit: introduce FIND_FIRST_BIT() macro Yury Norov
2022-08-24 9:10 ` Andy Shevchenko
2022-08-24 13:19 ` Yury Norov [this message]
2022-08-24 14:18 ` David Laight
2022-08-24 17:45 ` Andy Shevchenko
2022-08-24 17:59 ` Linus Torvalds
2022-08-24 1:26 ` [PATCH v2 2/3] lib/find_bit: create find_first_zero_bit_le() Yury Norov
2022-08-24 9:22 ` Andy Shevchenko
2022-08-24 9:24 ` Andy Shevchenko
2022-08-24 13:37 ` Yury Norov
2022-08-24 17:50 ` Andy Shevchenko
2022-08-24 17:58 ` Russell King (Oracle)
2022-08-24 20:03 ` Yury Norov
2022-08-24 18:11 ` Linus Torvalds
2022-08-24 22:09 ` Yury Norov
2022-08-24 1:26 ` [PATCH v2 3/3] lib/find_bit: optimize find_next_bit() functions Yury Norov
2022-08-24 9:19 ` Andy Shevchenko
2022-08-24 13:53 ` Yury Norov
2022-08-24 17:54 ` Andy Shevchenko
2022-08-24 17:56 ` Andy Shevchenko
2022-08-24 21:27 ` Yury Norov
2022-08-24 9:00 ` [PATCH v2 0/4] lib: optimize find_bit() functions Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YwYlWjlWO3fFrtQp@yury-laptop \
--to=yury.norov@gmail.com \
--cc=aklimov@redhat.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=apw@canonical.com \
--cc=catalin.marinas@arm.com \
--cc=dennis@kernel.org \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=linux@rasmusvillemoes.dk \
--cc=linux@roeck-us.net \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®