From: Sean Christopherson <seanjc@google.com>
To: paul@xen.org
Cc: Paolo Bonzini <pbonzini@redhat.com>,
David Woodhouse <dwmw2@infradead.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
syzbot+352e553a86e0d75f5120@syzkaller.appspotmail.com,
Paul Durrant <pdurrant@amazon.com>,
David Woodhouse <dwmw@amazon.co.uk>,
Vitaly Kuznetsov <vkuznets@redhat.com>
Subject: Re: [PATCH v2 08/11] KVM: x86: Pass reference pvclock as a param to kvm_setup_guest_pvclock()
Date: Tue, 4 Feb 2025 11:23:36 -0800 [thread overview]
Message-ID: <Z6JpOOP1-GpFw7lR@google.com> (raw)
In-Reply-To: <6b2d960c-1340-4e91-ad17-0ccadd378a81@xen.org>
On Tue, Feb 04, 2025, Paul Durrant wrote:
> On 04/02/2025 09:33, Paul Durrant wrote:
> > On 01/02/2025 01:38, Sean Christopherson wrote:
> > > -static void kvm_setup_guest_pvclock(struct kvm_vcpu *v,
> > > +static void kvm_setup_guest_pvclock(struct pvclock_vcpu_time_info
> > > *ref_hv_clock,
> > > + struct kvm_vcpu *vcpu,
> >
> > So, here 'v' becomes 'vcpu'
> >
> > > struct gfn_to_pfn_cache *gpc,
> > > unsigned int offset,
> > > bool force_tsc_unstable)
> > > {
> > > - struct kvm_vcpu_arch *vcpu = &v->arch;
> > > struct pvclock_vcpu_time_info *guest_hv_clock;
> > > struct pvclock_vcpu_time_info hv_clock;
> > > unsigned long flags;
> > > - memcpy(&hv_clock, &vcpu->hv_clock, sizeof(hv_clock));
> > > + memcpy(&hv_clock, ref_hv_clock, sizeof(hv_clock));
> > > read_lock_irqsave(&gpc->lock, flags);
> > > while (!kvm_gpc_check(gpc, offset + sizeof(*guest_hv_clock))) {
...
> > > @@ -3272,18 +3272,18 @@ static int kvm_guest_time_update(struct
> > > kvm_vcpu *v)
> > > vcpu->hv_clock.flags |= PVCLOCK_GUEST_STOPPED;
> > > vcpu->pvclock_set_guest_stopped_request = false;
> > > }
> > > - kvm_setup_guest_pvclock(v, &vcpu->pv_time, 0, false);
> > > + kvm_setup_guest_pvclock(&vcpu->hv_clock, v, &vcpu->pv_time,
> > > 0, false);
> >
> > Yet here an below you still use 'v'. Does this actually compile?
> >
>
> Sorry, my misreading of the patch... this is in caller context so no
> problem. The inconsistent naming was misleading me.
I feel your pain, the use of "vcpu" for kvm_vcpu_arch in kvm_guest_time_update()
kills me. I forget if David's rework of kvm_guest_time_update() fixes that wart.
If it doesn't, I'll suggest that addition. The only reason I haven't posted a
patch was to avoid a bunch of churn for a rename, but if the function is getting
ripped apart anyways...
next prev parent reply other threads:[~2025-02-04 19:23 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-01 1:38 [PATCH v2 00/11] KVM: x86: pvclock fixes and cleanups Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 01/11] KVM: x86: Don't take kvm->lock when iterating over vCPUs in suspend notifier Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 02/11] KVM: x86: Eliminate "handling" of impossible errors during SUSPEND Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 03/11] KVM: x86: Drop local pvclock_flags variable in kvm_guest_time_update() Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 04/11] KVM: x86: Process "guest stopped request" once per guest time update Sean Christopherson
2025-02-04 9:19 ` Paul Durrant
2025-02-01 1:38 ` [PATCH v2 05/11] KVM: x86/xen: Use guest's copy of pvclock when starting timer Sean Christopherson
2025-02-04 9:26 ` Paul Durrant
2025-02-01 1:38 ` [PATCH v2 06/11] KVM: x86: Don't bleed PVCLOCK_GUEST_STOPPED across PV clocks Sean Christopherson
2025-02-04 9:28 ` Paul Durrant
2025-02-01 1:38 ` [PATCH v2 07/11] KVM: x86: Set PVCLOCK_GUEST_STOPPED only for kvmclock, not for Xen PV clock Sean Christopherson
2025-02-04 9:31 ` Paul Durrant
2025-02-01 1:38 ` [PATCH v2 08/11] KVM: x86: Pass reference pvclock as a param to kvm_setup_guest_pvclock() Sean Christopherson
2025-02-04 9:33 ` Paul Durrant
2025-02-04 9:38 ` Paul Durrant
2025-02-04 19:23 ` Sean Christopherson [this message]
2025-02-01 1:38 ` [PATCH v2 09/11] KVM: x86: Remove per-vCPU "cache" of its reference pvclock Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 10/11] KVM: x86: Setup Hyper-V TSC page before Xen PV clocks (during clock update) Sean Christopherson
2025-02-01 1:38 ` [PATCH v2 11/11] KVM: x86: Override TSC_STABLE flag for Xen PV clocks in kvm_guest_time_update() Sean Christopherson
2025-02-15 0:50 ` [PATCH v2 00/11] KVM: x86: pvclock fixes and cleanups Sean Christopherson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z6JpOOP1-GpFw7lR@google.com \
--to=seanjc@google.com \
--cc=dwmw2@infradead.org \
--cc=dwmw@amazon.co.uk \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=paul@xen.org \
--cc=pbonzini@redhat.com \
--cc=pdurrant@amazon.com \
--cc=syzbot+352e553a86e0d75f5120@syzkaller.appspotmail.com \
--cc=vkuznets@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®