mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Johan Hovold <johan@kernel.org>
To: Konrad Dybcio <konrad.dybcio@linaro.org>
Cc: Bjorn Andersson <andersson@kernel.org>,
	Andy Gross <agross@kernel.org>,
	Michael Turquette <mturquette@baylibre.com>,
	Stephen Boyd <sboyd@kernel.org>, Rob Herring <robh+dt@kernel.org>,
	Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Marijn Suijten <marijn.suijten@somainline.org>,
	linux-arm-msm@vger.kernel.org, linux-clk@vger.kernel.org,
	linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
	Bryan O'Donoghue <bryan.odonoghue@linaro.org>
Subject: Re: [PATCH v4 02/12] clk: qcom: Use qcom_branch_set_clk_en()
Date: Wed, 3 Jan 2024 11:18:34 +0100	[thread overview]
Message-ID: <ZZU0eiw_1qSOklRN@hovoldconsulting.com> (raw)
In-Reply-To: <90749db5-a803-4bf0-8543-f049249b1df0@linaro.org>

On Tue, Jan 02, 2024 at 03:27:29PM +0100, Konrad Dybcio wrote:
> On 2.01.2024 11:35, Johan Hovold wrote:
> > On Sat, Dec 30, 2023 at 02:04:04PM +0100, Konrad Dybcio wrote:

> >> @@ -3010,10 +3010,8 @@ static int camcc_sc8280xp_probe(struct platform_device *pdev)
> >>  	clk_lucid_pll_configure(&camcc_pll6, regmap, &camcc_pll6_config);
> >>  	clk_lucid_pll_configure(&camcc_pll7, regmap, &camcc_pll7_config);
> >>  
> >> -	/*
> >> -	 * Keep camcc_gdsc_clk always enabled:
> >> -	 */
> >> -	regmap_update_bits(regmap, 0xc1e4, BIT(0), 1);
> >> +	/* Keep the critical clocks always-on */
> >> +	qcom_branch_set_clk_en(regmap, 0xc1e4); /* CAMCC_GDSC_CLK */
> > 
> > I still think something along the lines of
> > 
> > 	/* Keep some clocks always on */
> > 
> > is preferred as it is far from obvious why a camera clock would be
> > considered "critical".
> > 
> > Or perhaps you can come up with a better description of why we've
> > decided not to model these clocks and just leave them ungated.

> Technically they're not really super critical if the hardware is
> not in use.. It's just that at one point Qualcomm decided to take
> the lazy decision to keep them always-on downstream and we seem to
> have agreed on going with that, instead of pm_clk (remember my old
> attempt at getting rid of this on dispcc-sc8280xp?)..
> 
> For now, I was just trying to clean this up a bit before looking
> into a better solution for this (probably a whole lot of pm_clks
> with some clever handle-getting due to different ways of grabbing
> clock sources.. by-name vs by-index vs global lookup that we've
> accumulated over the years).

Yeah, that's fine. I'm not saying you have to come up with a better way
of describing these for this series, but I find calling them "critical"
throughout is more confusing than the current unspecified comments about
leaving some clocks on (i.e. without a proper motivation or even hint
about why they are being kept always on).

Johan

  reply	other threads:[~2024-01-03 10:18 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-30 13:04 [PATCH v4 00/12] Unregister critical branch clocks + some RPM Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 01/12] clk: qcom: branch: Add a helper for setting the enable bit Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 02/12] clk: qcom: Use qcom_branch_set_clk_en() Konrad Dybcio
2024-01-02 10:35   ` Johan Hovold
2024-01-02 14:27     ` Konrad Dybcio
2024-01-03 10:18       ` Johan Hovold [this message]
2023-12-30 13:04 ` [PATCH v4 03/12] clk: qcom: gcc-sm6375: Unregister critical clocks Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 04/12] clk: qcom: gpucc-sm6375: " Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 05/12] clk: qcom: gpucc-sm6115: " Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 06/12] clk: qcom: gpucc-sm6115: Add runtime PM Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 07/12] clk: qcom: gcc-sm6115: Unregister critical clocks Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 08/12] clk: qcom: gcc-qcm2290: " Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 09/12] arm64: dts: qcom: sm6375: Add VDD_CX to GCC Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 10/12] arm64: dts: qcom: qcm2290: " Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 11/12] arm64: dts: qcom: sm6115: " Konrad Dybcio
2023-12-30 13:04 ` [PATCH v4 12/12] arm64: dts: qcom: sm6115: Add VDD_CX to GPU_CC Konrad Dybcio

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZZU0eiw_1qSOklRN@hovoldconsulting.com \
    --to=johan@kernel.org \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=bryan.odonoghue@linaro.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=konrad.dybcio@linaro.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marijn.suijten@somainline.org \
    --cc=mturquette@baylibre.com \
    --cc=robh+dt@kernel.org \
    --cc=sboyd@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®