From: "Cabiddu, Giovanni" <giovanni.cabiddu@intel.com>
To: Erick Archer <erick.archer@gmx.com>
Cc: Herbert Xu <herbert@gondor.apana.org.au>,
"David S. Miller" <davem@davemloft.net>,
Tero Kristo <tero.kristo@linux.intel.com>,
"Andy Shevchenko" <andriy.shevchenko@linux.intel.com>,
Damian Muszynski <damian.muszynski@intel.com>,
Shashank Gupta <shashank.gupta@intel.com>,
"Tom Zanussi" <tom.zanussi@linux.intel.com>,
"Gustavo A. R. Silva" <gustavoars@kernel.org>,
<qat-linux@intel.com>, <linux-crypto@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <linux-hardening@vger.kernel.org>
Subject: Re: [PATCH] crypto: qat - use kcalloc_node() instead of kzalloc_node()
Date: Tue, 23 Jan 2024 12:16:13 +0000 [thread overview]
Message-ID: <Za+uDX8DyggIGs9V@gcabiddu-mobl.ger.corp.intel.com> (raw)
In-Reply-To: <20240121164043.11222-1-erick.archer@gmx.com>
On Sun, Jan 21, 2024 at 05:40:43PM +0100, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc_node() function instead of the
> argument count * size in the kzalloc_node() function.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
Acked-by: Giovanni Cabiddu <giovanni.cabiddu@intel.com>
next prev parent reply other threads:[~2024-01-23 12:32 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-01-21 16:40 Erick Archer
2024-01-22 17:55 ` Gustavo A. R. Silva
2024-01-23 12:16 ` Cabiddu, Giovanni [this message]
2024-01-26 9:06 ` Herbert Xu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Za+uDX8DyggIGs9V@gcabiddu-mobl.ger.corp.intel.com \
--to=giovanni.cabiddu@intel.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=damian.muszynski@intel.com \
--cc=davem@davemloft.net \
--cc=erick.archer@gmx.com \
--cc=gustavoars@kernel.org \
--cc=herbert@gondor.apana.org.au \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=qat-linux@intel.com \
--cc=shashank.gupta@intel.com \
--cc=tero.kristo@linux.intel.com \
--cc=tom.zanussi@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®