From: Petr Mladek <pmladek@suse.com>
To: zhang warden <zhangwarden@gmail.com>
Cc: Josh Poimboeuf <jpoimboe@kernel.org>,
mbenes@suse.cz, jikos@kernel.org, joe.lawrence@redhat.com,
live-patching@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] livepatch.h: Add comment to klp transition state
Date: Mon, 6 May 2024 10:37:24 +0200 [thread overview]
Message-ID: <ZjiWxNLI3yS9nFI1@pathway.suse.cz> (raw)
In-Reply-To: <F3E94528-EA85-4A15-8452-EA2DE20EEB88@gmail.com>
On Mon 2024-05-06 10:04:26, zhang warden wrote:
>
>
> > On May 6, 2024, at 05:00, Josh Poimboeuf <jpoimboe@kernel.org> wrote:
> >
> > On Mon, Apr 29, 2024 at 03:26:28PM +0800, zhangwarden@gmail.com wrote:
> >> From: Wardenjohn <zhangwarden@gmail.com>
> >>
> >> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
> >> When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
> >> In order not to introduce potential risks to kernel, just update comment
> >> to these state.
> >> ---
> >> include/linux/livepatch.h | 6 +++---
> >> 1 file changed, 3 insertions(+), 3 deletions(-)
> >>
> >> diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
> >> index 9b9b38e89563..b6a214f2f8e3 100644
> >> --- a/include/linux/livepatch.h
> >> +++ b/include/linux/livepatch.h
> >> @@ -18,9 +18,9 @@
> >> #if IS_ENABLED(CONFIG_LIVEPATCH)
> >>
> >> /* task patch states */
> >> -#define KLP_UNDEFINED -1
> >> -#define KLP_UNPATCHED 0
> >> -#define KLP_PATCHED 1
> >> +#define KLP_UNDEFINED -1 /* idle, no transition in progress */
> >> +#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
> >> +#define KLP_PATCHED 1 /* transitioning to patched state */
> >
> > Instead of the comments, how about we just rename them to
> >
> > KLP_TRANSITION_IDLE
> > KLP_TRANSITION_UNPATCHED
> > KLP_TRANSITION_PATCHED
> >
> > which shouldn't break userspace AFAIK.
Great idea! It is better then nothing.
> Renaming them may be a better way as my previous patch. I would like to know why renaming KLP_*** into
> KLP_TRANSITION_*** will not break userspace while
> Renaming KLP_UNDEWFINED to KLP_IDLE would break the userspace.
As I already wrote in [1], both "task->patch_state == KLP_UNDEFINED"
and "KLP_IDLE" are misleading. They are not talking
about the state of the patch but about the state of the transition.
We could not rename the variables because it would break userspace.
But we could rename the state names at least.
[1] https://lore.kernel.org/r/Zg7EpZol5jB_gHH9@alley
Best Regards,
Petr
prev parent reply other threads:[~2024-05-06 8:37 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-29 7:26 zhangwarden
2024-05-05 21:00 ` Josh Poimboeuf
2024-05-06 2:04 ` zhang warden
2024-05-06 8:37 ` Petr Mladek [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ZjiWxNLI3yS9nFI1@pathway.suse.cz \
--to=pmladek@suse.com \
--cc=jikos@kernel.org \
--cc=joe.lawrence@redhat.com \
--cc=jpoimboe@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=zhangwarden@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®