mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sakari Ailus <sakari.ailus@iki.fi>
To: Sylvain Petinot <sylvain.petinot@foss.st.com>
Cc: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>,
	benjamin.mugnier@foss.st.com, mchehab@kernel.org,
	robh@kernel.org, krzysztof.kozlowski+dt@linaro.org,
	conor+dt@kernel.org, linux-media@vger.kernel.org,
	devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/2] media: dt-bindings: Add ST VD56G3 camera sensor binding
Date: Mon, 27 May 2024 20:08:14 +0000	[thread overview]
Message-ID: <ZlToLtUkVqzrZf4p@valkosipuli.retiisi.eu> (raw)
In-Reply-To: <77fa3ed3-2341-4106-adf2-ec8bd9de91ff@foss.st.com>

Hi Sylvain,

On Mon, May 27, 2024 at 03:14:35PM +0200, Sylvain Petinot wrote:
> >> diff --git a/Documentation/devicetree/bindings/media/i2c/st,st-vd56g3.yaml b/Documentation/devicetree/bindings/media/i2c/st,st-vd56g3.yaml
> >> new file mode 100644
> >> index 000000000000..22cb2557e311
> >> --- /dev/null
> >> +++ b/Documentation/devicetree/bindings/media/i2c/st,st-vd56g3.yaml
> > 
> > Why duplicated 'st'?
> 
> Legacy : our first st-mipid02 driver was upstream this way few years back.
> 
> We have 3 options :
> 
> 1- keep this unpleasant naming to keep consistency with st-mipid02 [1]
> and st-vgxy61 [2]
> 2- rename this driver properly ('vd56g3') and keep the two others the
> old way (I personally don't like this option)
> 3- rename this driver properly ('vd56g3') and in a second patch rename
> the two others drivers.
> 
> I would be interested to get Sakari's opinion on this subject.
> 
> [1]:
> https://elixir.bootlin.com/linux/v6.9.1/source/drivers/media/i2c/st-mipid02.c
> 
> [2]:
> https://elixir.bootlin.com/linux/v6.9.1/source/drivers/media/i2c/st-vgxy61.c

The driver could be renamed to align with a large majority that use the
same name as the bindings without the vendor prefix. You could add
MODULE_ALIAS() to help user space to cope with the change.

The DT compatible string indeed should reflect the name of the device, the
driver is indeed another matter.

-- 
Kind regards,

Sakari Ailus

  parent reply	other threads:[~2024-05-27 20:11 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-21 16:29 [PATCH v2 0/2] media: Add driver for ST VD56G3 camera sensor Sylvain Petinot
2024-05-21 16:29 ` [PATCH v2 1/2] media: dt-bindings: Add ST VD56G3 camera sensor binding Sylvain Petinot
2024-05-21 17:37   ` Krzysztof Kozlowski
2024-05-27 13:14     ` Sylvain Petinot
2024-05-27 19:00       ` Krzysztof Kozlowski
2024-06-03  8:46         ` Sylvain Petinot
2024-05-27 20:08       ` Sakari Ailus [this message]
2024-05-27 19:04   ` Krzysztof Kozlowski
2024-05-28  9:22     ` Sakari Ailus
2024-05-28  9:46       ` Krzysztof Kozlowski
2024-05-28 10:01         ` Sakari Ailus
2024-06-03  8:47           ` Sylvain Petinot
2024-05-21 16:29 ` [PATCH v2 2/2] media: i2c: Add driver for ST VD56G3 camera sensor Sylvain Petinot
2024-05-28 11:49   ` Sakari Ailus
2024-06-03  9:59     ` Sylvain Petinot
2024-09-09  7:06       ` Sakari Ailus
2024-09-09  8:42         ` Sylvain Petinot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ZlToLtUkVqzrZf4p@valkosipuli.retiisi.eu \
    --to=sakari.ailus@iki.fi \
    --cc=benjamin.mugnier@foss.st.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=robh@kernel.org \
    --cc=sylvain.petinot@foss.st.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®